ports/devel/py-hatch-nodejs-version/Makefile
Kai Knoblich d5173cf69d devel/py-hatch-nodejs-version: New port
This package provides two Hatch plugins:

* version source plugin that reads/writes the package version from
  the version field of the Node.js package.json file.

* metadata hook plugin that reads PEP 621 metadata from the Node.js
  package.json file.

WWW: https://github.com/agoose77/hatch-nodejs-version
2023-03-16 06:54:32 +01:00

25 lines
704 B
Makefile

PORTNAME= hatch-nodejs-version
DISTVERSION= 0.3.1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= hatch_nodejs_version-${DISTVERSION}
MAINTAINER= kai@FreeBSD.org
COMMENT= Hatch plugin for versioning from a package.json file
WWW= https://github.com/agoose77/hatch-nodejs-version
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=0.21.0:devel/py-hatchling@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=0.21.0:devel/py-hatchling@${PY_FLAVOR}
USES= python:3.7+
USE_PYTHON= autoplist pep517 pytest
TEST_ENV= PYTHONPATH=${STAGEDIR}${PYTHON_SITELIBDIR}
NO_ARCH= yes
.include <bsd.port.mk>