ports/devel/py-deepdiff/Makefile
Dmitry Marakasov 77d68471ad */*: rename CHEESESHOP to PYPI in MASTER_SITES
PR:			267994
Differential revision:	D37518
Approved by:		bapt
2023-01-11 18:58:34 +03:00

25 lines
702 B
Makefile

PORTNAME= deepdiff
DISTVERSION= 5.8.1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= yuri@FreeBSD.org
COMMENT= Deep difference and search of any Python object/data
WWW= https://github.com/seperman/deepdiff
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ordered-set>=4.1.0:devel/py-ordered-set@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
USES= python:3.5+
USE_PYTHON= distutils autoplist
NO_ARCH= yes
do-test: # some tests fail, see https://github.com/seperman/deepdiff/issues/323
@cd ${WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest
.include <bsd.port.mk>