mirror of
https://git.freebsd.org/ports.git
synced 2025-05-14 16:21:50 -04:00
27 lines
896 B
Makefile
27 lines
896 B
Makefile
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
|
|
|
|
PORTNAME= elasticsearch-async
|
|
PORTVERSION= 6.2.0
|
|
CATEGORIES= textproc python
|
|
MASTER_SITES= CHEESESHOP
|
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
|
|
|
MAINTAINER= sunpoet@FreeBSD.org
|
|
COMMENT= Python Elasticsearch Async Client
|
|
|
|
LICENSE= APACHE20
|
|
LICENSE_FILE= ${WRKSRC}/LICENSE
|
|
|
|
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aiohttp>=0:www/py-aiohttp@${PY_FLAVOR} \
|
|
${PYTHON_PKGNAMEPREFIX}async_timeout>=0:devel/py-async_timeout@${PY_FLAVOR} \
|
|
${PYTHON_PKGNAMEPREFIX}elasticsearch>=6.0.0:textproc/py-elasticsearch@${PY_FLAVOR}
|
|
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR} \
|
|
${PYTHON_PKGNAMEPREFIX}pytest-asyncio>=0:devel/py-pytest-asyncio@${PY_FLAVOR} \
|
|
${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov@${PY_FLAVOR}
|
|
|
|
USES= python:3.4+
|
|
USE_PYTHON= autoplist concurrent distutils
|
|
|
|
NO_ARCH= yes
|
|
|
|
.include <bsd.port.mk>
|