mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
lang/libobjc2: update to 2.2.1
While here use robin-map from ports instead of the submodule.
This commit is contained in:
parent
cb812aa5c7
commit
ffc2bc893a
5 changed files with 53 additions and 25 deletions
|
@ -1,7 +1,6 @@
|
|||
PORTNAME= libobjc2
|
||||
DISTVERSIONPREFIX=v
|
||||
DISTVERSION= 2.1
|
||||
PORTREVISION= 3
|
||||
DISTVERSION= 2.2.1
|
||||
CATEGORIES= lang devel gnustep
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
@ -9,11 +8,12 @@ COMMENT= Replacement Objective-C runtime supporting modern Objective-C features
|
|||
|
||||
LICENSE= MIT
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/include/tsl/robin_map.h:devel/robin-map
|
||||
|
||||
USES= cmake compiler objc:compiler
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= gnustep
|
||||
GH_TUPLE= Tessil:robin-map:757de82:robin_map/third_party/robin-map
|
||||
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
|
@ -21,7 +21,8 @@ LDFLAGS+= -lm
|
|||
|
||||
TEST_TARGET= test
|
||||
|
||||
CMAKE_ARGS+= -DLIB_INSTALL_PATH=lib
|
||||
CMAKE_ARGS+= -DLIB_INSTALL_PATH=lib \
|
||||
-DLOCALBASE=${LOCALBASE}
|
||||
|
||||
LDFLAGS_armv7= -Wl,-znotext
|
||||
SSP_UNSAFE= yes
|
||||
|
|
|
@ -1,5 +1,3 @@
|
|||
TIMESTAMP = 1598301863
|
||||
SHA256 (gnustep-libobjc2-v2.1_GH0.tar.gz) = 78fc3711db14bf863040ae98f7bdca08f41623ebeaf7efaea7dd49a38b5f054c
|
||||
SIZE (gnustep-libobjc2-v2.1_GH0.tar.gz) = 200290
|
||||
SHA256 (Tessil-robin-map-757de82_GH0.tar.gz) = b365d847a23ce48a4e5c76c4a8194693f18323bf7cacdc0f57ada92ee275bd45
|
||||
SIZE (Tessil-robin-map-757de82_GH0.tar.gz) = 63288
|
||||
TIMESTAMP = 1717156055
|
||||
SHA256 (gnustep-libobjc2-v2.2.1_GH0.tar.gz) = 768ea8c5bd0999a29b5d15781125494f986456c1dc5c51d370fb31852cd31ea1
|
||||
SIZE (gnustep-libobjc2-v2.2.1_GH0.tar.gz) = 205087
|
||||
|
|
41
lang/libobjc2/files/patch-CMakeLists.txt
Normal file
41
lang/libobjc2/files/patch-CMakeLists.txt
Normal file
|
@ -0,0 +1,41 @@
|
|||
--- CMakeLists.txt.orig 2024-03-21 16:06:36 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -29,9 +29,10 @@ INCLUDE (FetchContent)
|
||||
INCLUDE (CheckCXXSourceCompiles)
|
||||
INCLUDE (FetchContent)
|
||||
|
||||
+include_directories(${LOCALBASE}/include)
|
||||
+
|
||||
set(libobjc_VERSION 4.6)
|
||||
|
||||
-
|
||||
if (MSVC)
|
||||
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} /EHas")
|
||||
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /EHas")
|
||||
@@ -128,17 +129,6 @@ endif ()
|
||||
list(APPEND libobjc_C_SRCS eh_personality.c)
|
||||
endif ()
|
||||
|
||||
-find_package(tsl-robin-map)
|
||||
-
|
||||
-if (NOT tsl-robin-map_FOUND)
|
||||
- FetchContent_Declare(
|
||||
- robinmap
|
||||
- GIT_REPOSITORY https://github.com/Tessil/robin-map/
|
||||
- GIT_TAG v1.2.1)
|
||||
-
|
||||
- FetchContent_MakeAvailable(robinmap)
|
||||
-endif()
|
||||
-
|
||||
if (WIN32)
|
||||
set(OLD_ABI_COMPAT_DEFAULT false)
|
||||
else()
|
||||
@@ -255,8 +245,6 @@ endif()
|
||||
if (WIN32 AND NOT MINGW)
|
||||
target_link_libraries(objc ntdll.dll)
|
||||
endif()
|
||||
-
|
||||
-target_link_libraries(objc tsl::robin_map)
|
||||
|
||||
set_target_properties(objc PROPERTIES
|
||||
LINKER_LANGUAGE C
|
|
@ -1,13 +0,0 @@
|
|||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index e2746e9..80b7dfe 100644
|
||||
--- CMakeLists.txt
|
||||
+++ CMakeLists.txt
|
||||
@@ -317,7 +317,7 @@ if (ENABLE_OBJCXX)
|
||||
endif()
|
||||
endif ()
|
||||
add_custom_command(OUTPUT eh_trampoline.s
|
||||
- COMMAND ${CMAKE_CXX_COMPILER} ${CMAKE_CXX_FLAGS} -fPIC -S "${CMAKE_SOURCE_DIR}/eh_trampoline.cc" -o - -fexceptions -fno-inline | sed "s/__gxx_personality_v0/test_eh_personality/g" > "${CMAKE_BINARY_DIR}/eh_trampoline.s"
|
||||
+ COMMAND ${CMAKE_CXX_COMPILER} -fPIC -S "${CMAKE_SOURCE_DIR}/eh_trampoline.cc" -o - -fexceptions -fno-inline | sed "s/__gxx_personality_v0/test_eh_personality/g" > "${CMAKE_BINARY_DIR}/eh_trampoline.s"
|
||||
MAIN_DEPENDENCY eh_trampoline.cc)
|
||||
list(APPEND libobjc_ASM_SRCS eh_trampoline.s)
|
||||
list(APPEND libobjc_CXX_SRCS objcxx_eh.cc)
|
|
@ -1,3 +1,5 @@
|
|||
include/Block.h
|
||||
include/Block_private.h
|
||||
include/objc/Availability.h
|
||||
include/objc/Object.h
|
||||
include/objc/Protocol.h
|
||||
|
@ -12,14 +14,13 @@ include/objc/objc-api.h
|
|||
include/objc/objc-arc.h
|
||||
include/objc/objc-auto.h
|
||||
include/objc/objc-class.h
|
||||
include/objc/objc-exception.h
|
||||
include/objc/objc-runtime.h
|
||||
include/objc/objc-visibility.h
|
||||
include/objc/objc.h
|
||||
include/objc/runtime.h
|
||||
include/objc/runtime-deprecated.h
|
||||
include/objc/runtime.h
|
||||
include/objc/slot.h
|
||||
include/Block.h
|
||||
include/Block_private.h
|
||||
lib/libobjc.so
|
||||
lib/libobjc.so.%%SHLIB_MAJOR%%
|
||||
lib/libobjc.so.%%SHLIB_MAJOR%%.%%SHLIB_MINOR%%
|
||||
|
|
Loading…
Add table
Reference in a new issue