- Add USES=libtool and INSTALL_TARGET=install-strip

- Remove pthread patching
This commit is contained in:
Tijl Coosemans 2014-10-05 19:03:12 +00:00
parent 240c394e65
commit ff44a5ac39
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=370105
3 changed files with 4 additions and 19 deletions

View file

@ -3,18 +3,17 @@
PORTNAME= chmlib
PORTVERSION= 0.40
PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= http://www.jedrea.com/chmlib/
MAINTAINER= fluffy@FreeBSD.org
COMMENT= Library for dealing with Microsoft ITSS/CHM format files
USES= gmake tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-io64 --disable-pread --exec-prefix=${PREFIX} --disable-static --enable-examples
INSTALL_TARGET= install-strip
USES= gmake libtool tar:bzip2
USE_LDCONFIG= yes
post-patch:
@${REINPLACE_CMD} -e "s,-lpthread,${PTHREAD_LIBS}," ${WRKSRC}/configure
.include <bsd.port.mk>

View file

@ -1,15 +0,0 @@
--- ltmain.sh.orig Mon Jun 19 09:26:24 2006
+++ ltmain.sh Mon Jun 19 09:26:40 2006
@@ -2077,10 +2077,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false ; then
func_basename "$file"
name="$func_basename_result"
instname="$dir/$name"i
func_show_eval "$install_prog $instname $destdir/$name" 'exit $?'
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View file

@ -7,3 +7,4 @@ include/chm_lib.h
include/lzx.h
lib/libchm.so
lib/libchm.so.0
lib/libchm.so.0.0.0