mirror of
https://git.freebsd.org/ports.git
synced 2025-05-24 23:16:33 -04:00
- Update to version 0.2.12
- Add LICENSE PR: 194494 Submitted by: tkato432@yahoo.com
This commit is contained in:
parent
1cecb4a491
commit
fc952e6355
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=372064
5 changed files with 45 additions and 74 deletions
|
@ -2,42 +2,37 @@
|
||||||
# $FreeBSD$
|
# $FreeBSD$
|
||||||
|
|
||||||
PORTNAME= osmo
|
PORTNAME= osmo
|
||||||
PORTVERSION= 0.2.10
|
PORTVERSION= 0.2.12
|
||||||
PORTREVISION= 7
|
|
||||||
CATEGORIES= deskutils
|
CATEGORIES= deskutils
|
||||||
MASTER_SITES= SF/${PORTNAME}-pim/${PORTNAME}-pim/${PORTNAME}-${PORTVERSION}/
|
MASTER_SITES= SF/${PORTNAME}-pim/${PORTNAME}-pim/${PORTNAME}-${PORTVERSION}
|
||||||
|
|
||||||
MAINTAINER= ports@FreeBSD.org
|
MAINTAINER= ports@FreeBSD.org
|
||||||
COMMENT= Personal organizer
|
COMMENT= Personal organizer
|
||||||
|
|
||||||
LIB_DEPENDS= libxml2.so:${PORTSDIR}/textproc/libxml2 \
|
LICENSE= GPLv2 # (or later)
|
||||||
libnotify.so:${PORTSDIR}/devel/libnotify \
|
|
||||||
libical.so:${PORTSDIR}/devel/libical \
|
LIB_DEPENDS= libical.so:${PORTSDIR}/devel/libical \
|
||||||
libtar.so:${PORTSDIR}/devel/libtar \
|
libnotify.so:${PORTSDIR}/devel/libnotify \
|
||||||
libgringotts.so:${PORTSDIR}/security/libgringotts \
|
libgringotts.so:${PORTSDIR}/security/libgringotts \
|
||||||
libgtkhtml-2.so:${PORTSDIR}/www/libgtkhtml
|
libgtkspell.so:${PORTSDIR}/textproc/gtkspell \
|
||||||
|
libwebkitgtk-1.0.so:${PORTSDIR}/www/webkit-gtk2
|
||||||
|
|
||||||
USE_GNOME= gtk20
|
|
||||||
USES= gettext gmake pkgconfig
|
USES= gettext gmake pkgconfig
|
||||||
|
USE_GNOME= gtk20 libxml2
|
||||||
|
USE_SQLITE= yes
|
||||||
|
GNU_CONFIGURE= yes
|
||||||
|
CONFIGURE_ENV= LIBARCHIVE_CFLAGS=" " LIBARCHIVE_LIBS="-larchive"
|
||||||
INSTALLS_ICONS= yes
|
INSTALLS_ICONS= yes
|
||||||
|
|
||||||
GNU_CONFIGURE= yes
|
CPPFLAGS+= -I${LOCALBASE}/include
|
||||||
LDFLAGS+= -L${LOCALBASE}/lib -lintl
|
LDFLAGS+= -L${LOCALBASE}/lib
|
||||||
CFLAGS+= -I${LOCALBASE}/include/libical
|
|
||||||
|
|
||||||
POFILES= bg ca cs da de el en_GB es fi fr hu it ja lt nl pl pt \
|
POFILES= bg ca cs da de el en_GB es fi fr gl gl_ES hu it ja lt nl \
|
||||||
ru sv tr uk zh_CN
|
pl pt pt_BR ro ru sv te tr uk ur ur_PK zh_CN
|
||||||
|
|
||||||
MSGFMT= ${LOCALBASE}/bin/msgfmt
|
post-build:
|
||||||
|
|
||||||
post-patch:
|
|
||||||
@${REINPLACE_CMD} -e 's|-DGTK_DISABLE_DEPRECATED||g' \
|
|
||||||
${WRKSRC}/src/Makefile.in
|
|
||||||
|
|
||||||
pre-install:
|
|
||||||
# workaround to problem in po makefile
|
|
||||||
.for p in ${POFILES}
|
.for p in ${POFILES}
|
||||||
${MSGFMT} -c ${WRKSRC}/po/$p.po -o ${WRKSRC}/po/$p.mo
|
(cd ${WRKSRC}/po && ${LOCALBASE}/bin/msgfmt -c ${p}.po -o ${p}.mo)
|
||||||
.endfor
|
.endfor
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.include <bsd.port.mk>
|
||||||
|
|
|
@ -1,2 +1,2 @@
|
||||||
SHA256 (osmo-0.2.10.tar.gz) = 4e911c52ac64a088f8a812b354084e7adedd1b54cb0435995a2cdc1d194d0845
|
SHA256 (osmo-0.2.12.tar.gz) = 93bda51614f92e4193840451612e792219f7d8c90d78bdc7ea6d6c14a2be6b78
|
||||||
SIZE (osmo-0.2.10.tar.gz) = 851833
|
SIZE (osmo-0.2.12.tar.gz) = 907452
|
||||||
|
|
17
deskutils/osmo/files/patch-src__backup.c
Normal file
17
deskutils/osmo/files/patch-src__backup.c
Normal file
|
@ -0,0 +1,17 @@
|
||||||
|
--- src/backup.c.orig 2014-10-19 00:26:19.000000000 +0900
|
||||||
|
+++ src/backup.c 2014-10-19 00:32:50.000000000 +0900
|
||||||
|
@@ -41,6 +41,14 @@
|
||||||
|
#include <archive.h>
|
||||||
|
#include <archive_entry.h>
|
||||||
|
|
||||||
|
+#ifdef __FreeBSD__
|
||||||
|
+#include <sys/param.h>
|
||||||
|
+#if __FreeBSD_version <= 1000008 /* r232154: bump for libarchive update */
|
||||||
|
+#define archive_read_support_filter_all(x) \
|
||||||
|
+ archive_read_support_compression_all(x)
|
||||||
|
+#endif
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
/*------------------------------------------------------------------------------*/
|
||||||
|
|
||||||
|
int
|
|
@ -1,48 +0,0 @@
|
||||||
--- src/check_events.c.orig 2011-08-12 15:17:59.000000000 +0200
|
|
||||||
+++ src/check_events.c 2011-08-12 15:20:36.000000000 +0200
|
|
||||||
@@ -454,9 +454,9 @@
|
|
||||||
a->date = 0;
|
|
||||||
|
|
||||||
if (textdesc != NULL)
|
|
||||||
- a->notify = notify_notification_new (item->summary, textdesc, GTK_STOCK_DIALOG_WARNING, NULL);
|
|
||||||
+ a->notify = notify_notification_new (item->summary, textdesc, GTK_STOCK_DIALOG_WARNING);
|
|
||||||
else
|
|
||||||
- a->notify = notify_notification_new (item->summary, text, GTK_STOCK_DIALOG_WARNING, NULL);
|
|
||||||
+ a->notify = notify_notification_new (item->summary, text, GTK_STOCK_DIALOG_WARNING);
|
|
||||||
|
|
||||||
g_free (textdesc);
|
|
||||||
g_free (text);
|
|
||||||
@@ -483,9 +483,7 @@
|
|
||||||
#endif /* HAVE_LIBNOTIFY */
|
|
||||||
|
|
||||||
if (gtk_status_icon_get_visible (appGUI->osmo_trayicon)) {
|
|
||||||
-#ifdef HAVE_LIBNOTIFY
|
|
||||||
- notify_notification_attach_to_status_icon (a->notify, appGUI->osmo_trayicon);
|
|
||||||
-#endif /* HAVE_LIBNOTIFY */
|
|
||||||
+
|
|
||||||
gtk_status_icon_set_from_stock (appGUI->osmo_trayicon, OSMO_STOCK_SYSTRAY_TASK);
|
|
||||||
|
|
||||||
if (config.blink_on_events) {
|
|
||||||
@@ -532,9 +530,9 @@
|
|
||||||
a->time = -1;
|
|
||||||
a->date = 0;
|
|
||||||
if (textdesc != NULL)
|
|
||||||
- a->notify = notify_notification_new (_("Alarm warning!"), textdesc, GTK_STOCK_DIALOG_INFO, NULL);
|
|
||||||
+ a->notify = notify_notification_new (_("Alarm warning!"), textdesc, GTK_STOCK_DIALOG_INFO);
|
|
||||||
else
|
|
||||||
- a->notify = notify_notification_new (_("Alarm warning!"), text, GTK_STOCK_DIALOG_INFO, NULL);
|
|
||||||
+ a->notify = notify_notification_new (_("Alarm warning!"), text, GTK_STOCK_DIALOG_INFO);
|
|
||||||
|
|
||||||
notify_notification_set_timeout (a->notify, NOTIFY_EXPIRES_NEVER);
|
|
||||||
notify_notification_set_urgency (a->notify, NOTIFY_URGENCY_NORMAL);
|
|
||||||
@@ -545,9 +543,7 @@
|
|
||||||
#endif /* HAVE_LIBNOTIFY */
|
|
||||||
|
|
||||||
if (gtk_status_icon_get_visible (appGUI->osmo_trayicon)) {
|
|
||||||
-#ifdef HAVE_LIBNOTIFY
|
|
||||||
- notify_notification_attach_to_status_icon (a->notify, appGUI->osmo_trayicon);
|
|
||||||
-#endif /* HAVE_LIBNOTIFY */
|
|
||||||
+
|
|
||||||
gtk_status_icon_set_from_stock (appGUI->osmo_trayicon, OSMO_STOCK_SYSTRAY_TASK);
|
|
||||||
|
|
||||||
if (config.blink_on_events) {
|
|
|
@ -17,6 +17,8 @@ share/locale/en_GB/LC_MESSAGES/osmo.mo
|
||||||
share/locale/es/LC_MESSAGES/osmo.mo
|
share/locale/es/LC_MESSAGES/osmo.mo
|
||||||
share/locale/fi/LC_MESSAGES/osmo.mo
|
share/locale/fi/LC_MESSAGES/osmo.mo
|
||||||
share/locale/fr/LC_MESSAGES/osmo.mo
|
share/locale/fr/LC_MESSAGES/osmo.mo
|
||||||
|
share/locale/gl/LC_MESSAGES/osmo.mo
|
||||||
|
share/locale/gl_ES/LC_MESSAGES/osmo.mo
|
||||||
share/locale/hu/LC_MESSAGES/osmo.mo
|
share/locale/hu/LC_MESSAGES/osmo.mo
|
||||||
share/locale/it/LC_MESSAGES/osmo.mo
|
share/locale/it/LC_MESSAGES/osmo.mo
|
||||||
share/locale/ja/LC_MESSAGES/osmo.mo
|
share/locale/ja/LC_MESSAGES/osmo.mo
|
||||||
|
@ -24,10 +26,15 @@ share/locale/lt/LC_MESSAGES/osmo.mo
|
||||||
share/locale/nl/LC_MESSAGES/osmo.mo
|
share/locale/nl/LC_MESSAGES/osmo.mo
|
||||||
share/locale/pl/LC_MESSAGES/osmo.mo
|
share/locale/pl/LC_MESSAGES/osmo.mo
|
||||||
share/locale/pt/LC_MESSAGES/osmo.mo
|
share/locale/pt/LC_MESSAGES/osmo.mo
|
||||||
|
share/locale/pt_BR/LC_MESSAGES/osmo.mo
|
||||||
|
share/locale/ro/LC_MESSAGES/osmo.mo
|
||||||
share/locale/ru/LC_MESSAGES/osmo.mo
|
share/locale/ru/LC_MESSAGES/osmo.mo
|
||||||
share/locale/sv/LC_MESSAGES/osmo.mo
|
share/locale/sv/LC_MESSAGES/osmo.mo
|
||||||
|
share/locale/te/LC_MESSAGES/osmo.mo
|
||||||
share/locale/tr/LC_MESSAGES/osmo.mo
|
share/locale/tr/LC_MESSAGES/osmo.mo
|
||||||
share/locale/uk/LC_MESSAGES/osmo.mo
|
share/locale/uk/LC_MESSAGES/osmo.mo
|
||||||
|
share/locale/ur/LC_MESSAGES/osmo.mo
|
||||||
|
share/locale/ur_PK/LC_MESSAGES/osmo.mo
|
||||||
share/locale/zh_CN/LC_MESSAGES/osmo.mo
|
share/locale/zh_CN/LC_MESSAGES/osmo.mo
|
||||||
share/pixmaps/osmo.png
|
share/pixmaps/osmo.png
|
||||||
share/sounds/osmo/alarm.wav
|
share/sounds/osmo/alarm.wav
|
||||||
|
|
Loading…
Add table
Reference in a new issue