mirror of
https://git.freebsd.org/ports.git
synced 2025-05-24 23:16:33 -04:00
Update to jnethack 3.4.1-0.2.
This commit is contained in:
parent
c2ce484b5c
commit
fa9db33be7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=83356
8 changed files with 70 additions and 46 deletions
|
@ -5,7 +5,7 @@
|
|||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTREVISION= 4
|
||||
PORTREVISION= 0
|
||||
|
||||
CATEGORIES= japanese games
|
||||
|
||||
|
@ -20,8 +20,8 @@ MD5_FILE= ${.CURDIR}/distinfo
|
|||
DESCR= ${.CURDIR}/pkg-descr
|
||||
PLIST= ${.CURDIR}/pkg-plist
|
||||
|
||||
PATCH_SITES= http://downloads.sourceforge.jp/jnethack/1864/
|
||||
PATCHFILES= jnethack-${PORTVERSION}-0.9.diff.gz
|
||||
PATCH_SITES= http://downloads.sourceforge.jp/jnethack/4546/
|
||||
PATCHFILES= jnethack-${PORTVERSION}-0.2.diff.gz
|
||||
PATCH_DIST_STRIP= -p1
|
||||
|
||||
USE_BISON= yes
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (nethack-340.tgz) = 0093f14fbbe449d5b188bfb6aa4eae4f
|
||||
MD5 (jnethack-3.4.0-0.9.diff.gz) = 2e6b1f1eac6427005e7554dd9425f358
|
||||
MD5 (nethack-341.tgz) = aefcbeb20210b2d64511c84bd03c3e4e
|
||||
MD5 (jnethack-3.4.1-0.2.diff.gz) = d52566b703f1b6e86bc3992593242a05
|
||||
|
|
|
@ -1,11 +1,29 @@
|
|||
--- include/unixconf.h.orig Tue Aug 13 06:38:29 2002
|
||||
+++ include/unixconf.h Tue Aug 13 06:43:03 2002
|
||||
--- include/unixconf.h.orig Fri Jun 20 21:10:39 2003
|
||||
+++ include/unixconf.h Fri Jun 20 21:13:50 2003
|
||||
@@ -19,7 +19,7 @@
|
||||
*/
|
||||
|
||||
/* define exactly one of the following four choices */
|
||||
-/* #define BSD 1 */ /* define for 4.n BSD */
|
||||
+#define BSD 1 /* define for 4.n BSD */
|
||||
/* also for relatives like SunOS 4.x, DG/UX, and */
|
||||
/* older versions of Linux */
|
||||
/* #define ULTRIX */ /* define for Ultrix v3.0 or higher (but not lower) */
|
||||
@@ -143,7 +143,7 @@
|
||||
* A stat system call is done on the mailbox every MAILCKFREQ moves.
|
||||
*/
|
||||
|
||||
-#define MAIL /* Deliver mail during the game */
|
||||
+/* #define MAIL */ /* Deliver mail during the game */
|
||||
+/* #define MAIL */ /* Deliver mail during the game */
|
||||
|
||||
/* The Andrew Message System does mail a little differently from normal
|
||||
* UNIX. Mail is deposited in the user's own directory in ~/Mailbox
|
||||
@@ -280,7 +280,7 @@
|
||||
#endif
|
||||
|
||||
#if defined(BSD) || defined(ULTRIX)
|
||||
-# if !defined(DGUX) && !defined(SUNOS4)
|
||||
+# if !defined(DGUX) && !defined(SUNOS4) && !defined(__FreeBSD__)
|
||||
#define memcpy(d, s, n) bcopy(s, d, n)
|
||||
#define memcmp(s1, s2, n) bcmp(s2, s1, n)
|
||||
# endif
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- sys/unix/Makefile.src.orig Tue Aug 13 06:38:30 2002
|
||||
+++ sys/unix/Makefile.src Tue Aug 13 06:39:58 2002
|
||||
--- sys/unix/Makefile.src.orig Fri Jun 20 21:14:30 2003
|
||||
+++ sys/unix/Makefile.src Fri Jun 20 21:18:33 2003
|
||||
@@ -147,19 +147,28 @@
|
||||
# directories. The ones given below is the usual spot for linux systems.
|
||||
# The paths are for glibconfig.h and gnomesupport.h respectively.
|
||||
|
@ -9,6 +9,8 @@
|
|||
|
||||
# flags for debugging:
|
||||
# CFLAGS = -g -I../include
|
||||
|
||||
-CFLAGS = -W -g -O -I../include
|
||||
+CFLAGS += -I../include
|
||||
+ifeq ("$(GRAPHICS)","X11_GRAPHICS")
|
||||
+CFLAGS += -DX11_GRAPHICS -I${X11BASE}/include
|
||||
|
@ -17,10 +19,8 @@
|
|||
+CFLAGS += -DQT_GRAPHICS
|
||||
+endif
|
||||
+ifeq ("$(GRAPHICS)","GNOME_GRAPHICS")
|
||||
+CFLAGS += -DGNOME_GRAPHICS
|
||||
+CFLAGS += -DGNOME_GRAPHICS ${CPPFLAGS}
|
||||
+endif
|
||||
|
||||
-CFLAGS = -W -g -O -I../include
|
||||
LFLAGS =
|
||||
|
||||
# The Qt and Be window systems are written in C++, while the rest of
|
||||
|
@ -33,7 +33,7 @@
|
|||
#LD=g++
|
||||
|
||||
# flags for IPv6 support
|
||||
@@ -222,7 +231,26 @@
|
||||
@@ -223,7 +232,26 @@
|
||||
#
|
||||
#
|
||||
WINSRC = $(WINTTYSRC)
|
||||
|
@ -60,7 +60,7 @@
|
|||
|
||||
# on some systems the termcap library is in -ltermcap or -lcurses
|
||||
# on 386 Xenix, the -ltermlib tputs() seems not to work; use -lcurses instead
|
||||
@@ -242,19 +270,19 @@
|
||||
@@ -243,19 +271,19 @@
|
||||
#
|
||||
# libraries for X11
|
||||
# If USE_XPM is defined in config.h, you will also need -lXpm here.
|
||||
|
@ -79,11 +79,11 @@
|
|||
#
|
||||
# libraries for Gnome
|
||||
-WINGNOMELIB = -lgnomeui -lgnome -lart_lgpl -lgtk -lgdk -lpopt
|
||||
+WINGNOMELIB = $(shell ${GNOME_CONFIG} --libs gnomeui) -lgnugetopt
|
||||
+WINGNOMELIB = $(shell ${GNOME_CONFIG} --libs gnomeui) ${LDFLAGS}
|
||||
#
|
||||
# libraries for Gem port
|
||||
WINGEMLIB = -le_gem -lgem
|
||||
@@ -263,6 +291,15 @@
|
||||
@@ -264,6 +292,15 @@
|
||||
WINBELIB = -lbe
|
||||
|
||||
WINLIB = $(WINTTYLIB)
|
||||
|
@ -99,7 +99,7 @@
|
|||
|
||||
# any other strange libraries your system needs (for Sysunix only -- the more
|
||||
# specialized targets should already be right)
|
||||
@@ -296,7 +333,7 @@
|
||||
@@ -297,7 +334,7 @@
|
||||
|
||||
# make NetHack
|
||||
#JP by issei(96/5/27)
|
||||
|
@ -108,20 +108,20 @@
|
|||
# GAME = nethack.prg
|
||||
|
||||
# if you defined RANDOM in unixconf.h/tosconf.h since your system did not come
|
||||
@@ -472,13 +509,13 @@
|
||||
@@ -473,13 +510,13 @@
|
||||
|
||||
# Qt windowport meta-object-compiler output
|
||||
qt_kde0.moc: ../include/qt_kde0.h
|
||||
- $(QTDIR)/bin/moc ../include/qt_kde0.h > qt_kde0.moc
|
||||
+ ${MOC} ../include/qt_kde0.h > qt_kde0.moc
|
||||
- $(QTDIR)/bin/moc -o qt_kde0.moc ../include/qt_kde0.h
|
||||
+ ${MOC} -o qt_kde0.moc ../include/qt_kde0.h
|
||||
|
||||
qt_win.moc: ../include/qt_win.h
|
||||
- $(QTDIR)/bin/moc ../include/qt_win.h > qt_win.moc
|
||||
+ ${MOC} ../include/qt_win.h > qt_win.moc
|
||||
- $(QTDIR)/bin/moc -o qt_win.moc ../include/qt_win.h
|
||||
+ ${MOC} -o qt_win.moc ../include/qt_win.h
|
||||
|
||||
qttableview.moc: ../include/qttableview.h
|
||||
- $(QTDIR)/bin/moc ../include/qttableview.h > qttableview.moc
|
||||
+ ${MOC} ../include/qttableview.h > qttableview.moc
|
||||
- $(QTDIR)/bin/moc -o qttableview.moc ../include/qttableview.h
|
||||
+ ${MOC} -o qttableview.moc ../include/qttableview.h
|
||||
|
||||
$(MAKEDEFS): ../util/makedefs.c $(CONFIG_H) ../include/permonst.h \
|
||||
../include/objclass.h ../include/monsym.h \
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
--- src/topten.c Thu Mar 21 01:43:19 2002
|
||||
+++ src/topten.c Tue Feb 11 15:36:23 2003
|
||||
@@ -855,8 +855,15 @@
|
||||
if (playerct < 1) Strcat(pbuf, "you.");
|
||||
else {
|
||||
if (playerct > 1) Strcat(pbuf, "any of ");
|
||||
- for (i = 0; i < playerct; i++) {
|
||||
- Strcat(pbuf, players[i]);
|
||||
+ for (i = 0; i < playerct && strlen(pbuf) < sizeof(pbuf) - 2;
|
||||
+ i++) {
|
||||
+ size_t len = strlen(pbuf), rest;
|
||||
+ if (strlen(players[i]) > sizeof(pbuf) - len - 2) {
|
||||
+ rest = sizeof(pbuf) - strlen(pbuf) - 2;
|
||||
+ memcpy(pbuf + len, players[i], rest);
|
||||
+ pbuf[len + rest] = '\0';
|
||||
+ } else
|
||||
+ Strcat(pbuf, players[i]);
|
||||
if (i < playerct-1) {
|
||||
if (players[i][0] == '-' &&
|
||||
index("pr", players[i][1]) && players[i][2] == 0)
|
10
japanese/nethack34/files/patch-ai
Normal file
10
japanese/nethack34/files/patch-ai
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- src/files.c.orig Sun Feb 23 23:43:26 2003
|
||||
+++ src/files.c Thu Jun 19 11:51:59 2003
|
||||
@@ -29,6 +29,7 @@
|
||||
#endif
|
||||
|
||||
#if defined(UNIX) && defined(QT_GRAPHICS)
|
||||
+#include <limits.h>
|
||||
#include <dirent.h>
|
||||
#endif
|
||||
|
16
japanese/nethack34/files/patch-minimal_term
Normal file
16
japanese/nethack34/files/patch-minimal_term
Normal file
|
@ -0,0 +1,16 @@
|
|||
|
||||
$FreeBSD: /tmp/pcvs/ports/japanese/nethack34/files/patch-minimal_term,v 1.1 2003-06-20 12:25:08 knu Exp $
|
||||
|
||||
--- win/tty/termcap.c.orig Thu Jun 19 16:12:47 2003
|
||||
+++ win/tty/termcap.c Thu Jun 19 16:13:00 2003
|
||||
@@ -217,10 +217,6 @@
|
||||
error("Terminal must backspace.");
|
||||
# else
|
||||
if(!(BC = Tgetstr("bc"))) { /* termcap also uses bc/bs */
|
||||
-# ifndef MINIMAL_TERM
|
||||
- if(!tgetflag("bs"))
|
||||
- error("Terminal must backspace.");
|
||||
-# endif
|
||||
BC = tbufptr;
|
||||
tbufptr += 2;
|
||||
*BC = '\b';
|
|
@ -90,7 +90,6 @@ bin/%%HACKNAME%%
|
|||
%%HACKDIR%%/jhelp
|
||||
%%HACKDIR%%/jhh
|
||||
%%HACKDIR%%/jhistory
|
||||
%%HACKDIR%%/jjj
|
||||
%%HACKDIR%%/jopthelp
|
||||
%%HACKDIR%%/joracles
|
||||
%%HACKDIR%%/jrumors
|
||||
|
@ -117,6 +116,7 @@ bin/%%HACKNAME%%
|
|||
%%HACKDIR%%/orcus.lev
|
||||
%%HACKDIR%%/pet_mark.xbm
|
||||
%%HACKDIR%%/quest.dat
|
||||
%%HACKDIR%%/recover
|
||||
%%HACKDIR%%/rip.xpm
|
||||
%%HACKDIR%%/sanctum.lev
|
||||
%%HACKDIR%%/soko1-1.lev
|
||||
|
|
Loading…
Add table
Reference in a new issue