Update to 0.7.2.

This commit is contained in:
Akinori MUSHA 2003-08-09 21:59:09 +00:00
parent 4dcea1236f
commit fa7bcf7ff5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=86684
5 changed files with 4564 additions and 59 deletions

View file

@ -1,4 +1,4 @@
# New ports collection makefile for: rbbr
# New ports collection makefile for: ReFe
# Date created: 24 November 2002
# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
#
@ -6,54 +6,32 @@
#
PORTNAME= refe
PORTVERSION= 0.5.0
PORTVERSION= 0.7.2
CATEGORIES= japanese lang ruby
MASTER_SITES= http://www.loveruby.net/archive/refe/ \
http://www.rubyist.net/~rubikitch/refm/:refm \
http://www.loveruby.net/archive/:extrefm
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
ruby-refm.rd.gz:refm \
extrefm.rd:extrefm
MASTER_SITES= http://www.loveruby.net/archive/refe/
MASTER_SITE_SUBDIR= ${PORTNAME}
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ${PORTNAME}-${PORTVERSION}-withdoc
DIST_SUBDIR= ruby
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= knu@FreeBSD.org
COMMENT= Ruby interactive reference in Japanese
IGNOREFILES= ruby-refm.rd.gz \
extrefm.rd
COMMENT= Ruby Reference Referrer
USE_RUBY= yes
USE_RUBY_SETUP= yes
RUBY_SETUP= install.rb
DOCS_EN= ChangeLog \
TODO
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
DOCS_EN= ChangeLog NEWS TODO \
README.en
DOCS_JA= README.ja
.include <bsd.port.pre.mk>
PKGNAMEPREFIX:= ${PKGNAMEPREFIX}${RUBY_PKGNAMEPREFIX}
.if exists(${RUBY_ARCHLIBDIR}/gdbm.so)
RUN_DEPENDS+= ${RUBY_ARCHLIBDIR}/gdbm.so:${PORTSDIR}/databases/ruby-gdbm
PLIST_SUB+= WITH_GDBM="" WITH_DBM="@comment "
.else
PLIST_SUB+= WITH_DBM="" WITH_GDBM="@comment "
.endif
post-extract:
${CP} ${DISTDIR}/${DIST_SUBDIR}/ruby-refm.rd.gz ${WRKSRC}/
${GUNZIP_CMD} ${WRKSRC}/ruby-refm.rd.gz
${CP} ${DISTDIR}/${DIST_SUBDIR}/extrefm.rd ${WRKSRC}/
post-patch:
${RM} -f ${WRKSRC}/lib/refe/*.orig
post-install:
cd ${WRKSRC}; ${PREFIX}/bin/mkrefe -ir ruby-refm.rd
cd ${WRKSRC}; ${PREFIX}/bin/mkrefe -e extrefm.rd
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODDOCDIR}/ja
.for f in ${DOCS_EN}

View file

@ -1,3 +1 @@
MD5 (ruby/refe-0.5.0.tar.gz) = 0b7c9aef76ae8f15cdbcf4158b06b4d7
MD5 (ruby/ruby-refm.rd.gz) = IGNORE
MD5 (ruby/extrefm.rd) = IGNORE
MD5 (ruby/refe-0.7.2-withdoc.tar.gz) = 9b39cd19ddf41c28662fa4127a374d94

View file

@ -1,11 +0,0 @@
--- lib/refe/extrefparser.rb.orig Fri Mar 22 20:21:23 2002
+++ lib/refe/extrefparser.rb Sun Nov 24 17:22:24 2002
@@ -39,7 +39,7 @@
f.each do |line|
next if /\A[=\w]/ === line
if /\A: / === line then
- m = /\A: .*?(\w+)\(/.match(line) or
+ m = /\A: .*?(\w+)(\(|$)/.match(line) or
raise "parse failed: #{line.inspect}"
curr = line
table[ m[1] ] = curr

View file

@ -1,4 +1,4 @@
ReFe is a Ruby interactive reference in Japanese.
Author: Minero Aoki <aamine@loveruby.net>
WWW: http://www.loveruby.net/ja/prog/refe.html
WWW: http://i.loveruby.net/en/refe.html

File diff suppressed because it is too large Load diff