Ledit is a line editor, allowing to use control commands like in emacs

or in shells (bash, tcsh). To be used with interactive commands. It is
written in Ocaml and Camlp4 and uses the library unix.cma.

PR:		ports/77307
Submitted by:	Marwan Burelle <marwan.burelle@lri.fr>
This commit is contained in:
Pav Lucistnik 2005-02-09 21:22:47 +00:00
parent a77166e4ef
commit f96d9de9d8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=128416
5 changed files with 63 additions and 0 deletions

View file

@ -223,6 +223,7 @@
SUBDIR += lavaps SUBDIR += lavaps
SUBDIR += lcdproc SUBDIR += lcdproc
SUBDIR += ldap-account-manager SUBDIR += ldap-account-manager
SUBDIR += ledit
SUBDIR += lfm SUBDIR += lfm
SUBDIR += libcdio SUBDIR += libcdio
SUBDIR += libchk SUBDIR += libchk

29
sysutils/ledit/Makefile Normal file
View file

@ -0,0 +1,29 @@
# ex:ts=8
# Ports collection makefile for: ledit
# Date created: Feb 8, 2005
# Whom: Marwan Burelle <marwan.burelle@lri.fr>
#
# $FreeBSD$
#
PORTNAME= ledit
PORTVERSION= 1.11
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.inria.fr/INRIA/cristal/Daniel.de_Rauglaudre/Tools/
MAINTAINER= marwan.burelle@lri.fr
COMMENT= Line editor to be used with interactive commands
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
ALL_TARGET= all ledit.opt
INSTALL_TARGET= install.opt
PLIST_FILES= bin/ledit
MANCOMPRESSED= no
MANL= ledit.l
.include <bsd.port.mk>

2
sysutils/ledit/distinfo Normal file
View file

@ -0,0 +1,2 @@
MD5 (ledit-1.11.tar.gz) = a2d38ba641682509c1e964ad699a9dd2
SIZE (ledit-1.11.tar.gz) = 14027

View file

@ -0,0 +1,28 @@
--- Makefile.orig Tue Feb 8 18:10:04 2005
+++ Makefile Tue Feb 8 18:17:56 2005
@@ -1,8 +1,10 @@
# $Id: Makefile,v 1.19 2001/10/03 09:36:34 ddr Exp $
-BINDIR=/usr/local/bin
-LIBDIR=/usr/local/lib
-MANDIR=/usr/man/manl
+PREFIX?=/usr/local
+
+BINDIR=$(PREFIX)/bin
+LIBDIR=$(PREFIX)/lib
+MANDIR=$(PREFIX)/man/manl
COMP=ocamlc
COMPOPT=ocamlopt
PP=camlp4r
@@ -33,6 +35,11 @@
install:
-$(MKDIR) $(BINDIR) $(MANDIR)
-cp ledit.out $(BINDIR)/ledit
+ -cp ledit.l $(MANDIR)/ledit.l
+
+install.opt: $(TARGET:.out=.opt)
+ -$(MKDIR) $(BINDIR) $(MANDIR)
+ -cp ledit.opt $(BINDIR)/ledit
-cp ledit.l $(MANDIR)/ledit.l
depend:

3
sysutils/ledit/pkg-descr Normal file
View file

@ -0,0 +1,3 @@
Ledit is a line editor, allowing to use control commands like in emacs
or in shells (bash, tcsh). To be used with interactive commands. It is
written in Ocaml and Camlp4 and uses the library unix.cma.