Po-Chuan Hsieh 2025-03-14 17:41:09 +08:00
parent 87f2141af0
commit f8dfa99d4a
No known key found for this signature in database
GPG key ID: 9A4BD10F002DD04B
3 changed files with 28 additions and 4 deletions

View file

@ -1,5 +1,5 @@
PORTNAME= xhtml2pdf
PORTVERSION= 0.2.16
PORTVERSION= 0.2.17
CATEGORIES= textproc python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1718580146
SHA256 (xhtml2pdf-0.2.16.tar.gz) = 7391adac12afb086561667cdc8d6ef0ac4afe5097bd97383622d42b6343dee71
SIZE (xhtml2pdf-0.2.16.tar.gz) = 138833
TIMESTAMP = 1740836188
SHA256 (xhtml2pdf-0.2.17.tar.gz) = 09ddbc31aa0e38a16f2f3cb73be89af5f7c968c17a564afdd685d280e39c526d
SIZE (xhtml2pdf-0.2.17.tar.gz) = 139727

View file

@ -0,0 +1,24 @@
Reference: https://github.com/xhtml2pdf/xhtml2pdf/commit/3ac6559d670736696e0a12a7e945191b7961428d
--- pyproject.toml.orig 2025-02-23 23:16:52 UTC
+++ pyproject.toml
@@ -53,7 +53,7 @@ dependencies = [
"pyHanko>=0.12.1",
"pyhanko-certvalidator>=0.19.5",
"pypdf>=3.1.0",
- "python-bidi>=0.5.0",
+ "python-bidi>=0.4.2",
"reportlab>=4.0.4,<5",
"svglib>=1.2.1"
]
--- xhtml2pdf/util.py.orig 2025-02-23 22:08:13 UTC
+++ xhtml2pdf/util.py
@@ -22,7 +22,7 @@ import reportlab.pdfbase._cidfontdata
import arabic_reshaper
import reportlab
import reportlab.pdfbase._cidfontdata
-from bidi import get_display
+from bidi.algorithm import get_display
from reportlab.lib.colors import Color, toColor
from reportlab.lib.enums import TA_CENTER, TA_JUSTIFY, TA_LEFT, TA_RIGHT
from reportlab.lib.units import cm, inch