mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
security/pecl-mcrypt: Fix build with php84
- While I'm here: - Fix indent - Remove outdated post-patch: Approved by: portmgr (blanket)
This commit is contained in:
parent
99afeb3ef7
commit
f8d7720ab3
2 changed files with 15 additions and 6 deletions
|
@ -12,11 +12,6 @@ LICENSE= PHP301
|
||||||
LIB_DEPENDS= libltdl.so:devel/libltdl \
|
LIB_DEPENDS= libltdl.so:devel/libltdl \
|
||||||
libmcrypt.so:security/libmcrypt
|
libmcrypt.so:security/libmcrypt
|
||||||
|
|
||||||
USES= php:pecl
|
USES= php:pecl
|
||||||
IGNORE_WITH_PHP= 84
|
|
||||||
|
|
||||||
post-patch:
|
|
||||||
${REINPLACE_CMD} -e 's/RETURN_FALSE$$/RETURN_FALSE;/g' ${WRKSRC}/mcrypt.c
|
|
||||||
${REINPLACE_CMD} -e 's/RETURN_TRUE$$/RETURN_TRUE;/g' ${WRKSRC}/mcrypt.c
|
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.include <bsd.port.mk>
|
||||||
|
|
14
security/pecl-mcrypt/files/patch-php84
Normal file
14
security/pecl-mcrypt/files/patch-php84
Normal file
|
@ -0,0 +1,14 @@
|
||||||
|
--- mcrypt.c.orig 2023-12-19 10:55:02 UTC
|
||||||
|
+++ mcrypt.c
|
||||||
|
@@ -38,7 +38,11 @@
|
||||||
|
#include "php_ini.h"
|
||||||
|
#include "php_globals.h"
|
||||||
|
#include "ext/standard/info.h"
|
||||||
|
+#if PHP_VERSION_ID >= 80400
|
||||||
|
+#include "ext/random/php_random.h"
|
||||||
|
+#else
|
||||||
|
#include "ext/standard/php_rand.h"
|
||||||
|
+#endif
|
||||||
|
#include "zend_smart_str.h"
|
||||||
|
#include "php_mcrypt_filter.h"
|
||||||
|
|
Loading…
Add table
Reference in a new issue