sysutils/rubygem-chef-winrm: Add rubygem-chef-winrm 2.3.11

Windows Remote Management (WinRM) for Ruby

This is a SOAP library that uses the functionality in Windows Remote
Management(WinRM) to call native object in Windows. This includes, but is not
limited to, running batch scripts, powershell scripts and fetching WMI
variables.

As of version 2.0, this gem retains the WinRM name but all powershell calls use
the more modern Powershell Remoting Protocol (PSRP) for initializing runspace
pools as well as creating and processing powershell pipelines.
This commit is contained in:
Po-Chuan Hsieh 2025-02-28 18:33:28 +08:00
parent 902b2b63e4
commit f881cb1a2e
No known key found for this signature in database
GPG key ID: 9A4BD10F002DD04B
5 changed files with 54 additions and 0 deletions

View file

@ -1155,6 +1155,7 @@
SUBDIR += rubygem-chef-telemetry
SUBDIR += rubygem-chef-utils
SUBDIR += rubygem-chef-vault
SUBDIR += rubygem-chef-winrm
SUBDIR += rubygem-chef-zero
SUBDIR += rubygem-choria-mcorpc-support
SUBDIR += rubygem-facter

View file

@ -0,0 +1,29 @@
PORTNAME= chef-winrm
PORTVERSION= 2.3.11
CATEGORIES= sysutils rubygems
MASTER_SITES= RG
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Ruby library for Windows Remote Management
WWW= https://github.com/chef/chef-winrm
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= rubygem-builder>=2.1.2:devel/rubygem-builder \
rubygem-chef-gyoku>=1.4.1:textproc/rubygem-chef-gyoku \
rubygem-erubi>=1.8:www/rubygem-erubi \
rubygem-gssapi>=1.2<2:security/rubygem-gssapi \
rubygem-httpclient>=2.2.0.2<3:www/rubygem-httpclient \
rubygem-logging>=1.6.1<3.0:devel/rubygem-logging \
rubygem-nori>=2.7.0:devel/rubygem-nori \
rubygem-rexml>=3.3<4:textproc/rubygem-rexml \
rubygem-rubyntlm>=0.6.3<0.7:net/rubygem-rubyntlm
USES= gem
NO_ARCH= yes
PLIST_FILES= bin/rwinrm
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
TIMESTAMP = 1740022428
SHA256 (rubygem/chef-winrm-2.3.11.gem) = 555e5e13a0e5724d0a5cdfa124ea4d4b2b6b9802fe46214beac8c2c33bbed26e
SIZE (rubygem/chef-winrm-2.3.11.gem) = 42496

View file

@ -0,0 +1,11 @@
--- chef-winrm.gemspec.orig 2025-02-20 19:35:49 UTC
+++ chef-winrm.gemspec
@@ -30,7 +30,7 @@ Gem::Specification.new do |s|
s.add_runtime_dependency(%q<gssapi>.freeze, ["~> 1.2".freeze])
s.add_runtime_dependency(%q<httpclient>.freeze, ["~> 2.2".freeze, ">= 2.2.0.2".freeze])
s.add_runtime_dependency(%q<logging>.freeze, [">= 1.6.1".freeze, "< 3.0".freeze])
- s.add_runtime_dependency(%q<nori>.freeze, ["= 2.7.0".freeze])
+ s.add_runtime_dependency(%q<nori>.freeze, [">= 2.7.0".freeze])
s.add_runtime_dependency(%q<rexml>.freeze, ["~> 3.3".freeze])
s.add_development_dependency(%q<pry>.freeze, [">= 0".freeze])
s.add_development_dependency(%q<rake>.freeze, [">= 10.3".freeze, "< 13".freeze])

View file

@ -0,0 +1,10 @@
Windows Remote Management (WinRM) for Ruby
This is a SOAP library that uses the functionality in Windows Remote
Management(WinRM) to call native object in Windows. This includes, but is not
limited to, running batch scripts, powershell scripts and fetching WMI
variables.
As of version 2.0, this gem retains the WinRM name but all powershell calls use
the more modern Powershell Remoting Protocol (PSRP) for initializing runspace
pools as well as creating and processing powershell pipelines.