mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
databases/hiredis: Update to upstream commit 7ab6b82
* Disable tests as they require a redis-server Changelog: https://github.com/redis/hiredis/compare/v1.0.2...7ab6b82 PR: 277927 Approved by: portmgr (maintainer timeout, 2+ weeks)
This commit is contained in:
parent
7d8021e152
commit
f72286bcc4
4 changed files with 38 additions and 28 deletions
|
@ -1,6 +1,6 @@
|
||||||
PORTNAME= hiredis
|
PORTNAME= hiredis
|
||||||
PORTVERSION= 1.0.2
|
DISTVERSIONPREFIX= v
|
||||||
DISTVERSIONPREFIX=v
|
DISTVERSION= 1.2.0-15
|
||||||
CATEGORIES= databases
|
CATEGORIES= databases
|
||||||
|
|
||||||
MAINTAINER= olgeni@FreeBSD.org
|
MAINTAINER= olgeni@FreeBSD.org
|
||||||
|
@ -8,28 +8,17 @@ COMMENT= Minimalistic C client library for the Redis database
|
||||||
WWW= https://github.com/redis/hiredis
|
WWW= https://github.com/redis/hiredis
|
||||||
|
|
||||||
LICENSE= BSD3CLAUSE
|
LICENSE= BSD3CLAUSE
|
||||||
|
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||||
|
|
||||||
|
USES= cmake cpe pathfix ssl
|
||||||
|
CPE_VENDOR= redislabs
|
||||||
|
USE_LDCONFIG= yes
|
||||||
|
|
||||||
USE_GITHUB= yes
|
USE_GITHUB= yes
|
||||||
GH_ACCOUNT= redis
|
GH_ACCOUNT= redis
|
||||||
|
GH_TAGNAME= 7ab6b82
|
||||||
|
|
||||||
USES= cpe gmake
|
CMAKE_OFF= ENABLE_NUGET
|
||||||
USE_LDCONFIG= yes
|
CMAKE_ON= DISABLE_TESTS ENABLE_SSL
|
||||||
|
|
||||||
CPE_VENDOR= redislabs
|
|
||||||
|
|
||||||
OPTIONS_DEFINE= OPENSSL
|
|
||||||
OPTIONS_DEFAULT= OPENSSL
|
|
||||||
OPENSSL_MAKE_ARGS= USE_SSL=1
|
|
||||||
|
|
||||||
post-patch:
|
|
||||||
@${REINPLACE_CMD} \
|
|
||||||
-e 's|\$$(INSTALL_LIBRARY_PATH)/\$$(PKGCONF_PATH)|\$$(DESTDIR)\$$(PREFIX)/libdata/\$$(PKGCONF_PATH)|' \
|
|
||||||
${WRKSRC}/Makefile
|
|
||||||
|
|
||||||
post-build:
|
|
||||||
@${STRIP_CMD} ${WRKSRC}/libhiredis.so
|
|
||||||
|
|
||||||
do-test:
|
|
||||||
cd ${WRKSRC} && ${MAKE_CMD} test
|
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.include <bsd.port.mk>
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
TIMESTAMP = 1651162224
|
TIMESTAMP = 1711298380
|
||||||
SHA256 (redis-hiredis-v1.0.2_GH0.tar.gz) = e0ab696e2f07deb4252dda45b703d09854e53b9703c7d52182ce5a22616c3819
|
SHA256 (redis-hiredis-v1.2.0-15-7ab6b82_GH0.tar.gz) = fb136fc3f5bce774eb92709e1d041fa851e1130e95cc3aea5b871b91ff0ce4c5
|
||||||
SIZE (redis-hiredis-v1.0.2_GH0.tar.gz) = 98139
|
SIZE (redis-hiredis-v1.2.0-15-7ab6b82_GH0.tar.gz) = 128129
|
||||||
|
|
11
databases/hiredis/files/patch-hiredis.h
Normal file
11
databases/hiredis/files/patch-hiredis.h
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- hiredis.h.orig 2024-03-24 16:33:25 UTC
|
||||||
|
+++ hiredis.h
|
||||||
|
@@ -48,7 +48,7 @@ typedef long long ssize_t;
|
||||||
|
#define HIREDIS_MAJOR 1
|
||||||
|
#define HIREDIS_MINOR 2
|
||||||
|
#define HIREDIS_PATCH 0
|
||||||
|
-#define HIREDIS_SONAME 1.2.1-dev
|
||||||
|
+#define HIREDIS_SONAME 1.2.1
|
||||||
|
|
||||||
|
/* Connection type can be blocking or non-blocking and is set in the
|
||||||
|
* least significant bit of the flags field in redisContext. */
|
|
@ -3,20 +3,30 @@ include/hiredis/adapters/glib.h
|
||||||
include/hiredis/adapters/ivykis.h
|
include/hiredis/adapters/ivykis.h
|
||||||
include/hiredis/adapters/libev.h
|
include/hiredis/adapters/libev.h
|
||||||
include/hiredis/adapters/libevent.h
|
include/hiredis/adapters/libevent.h
|
||||||
|
include/hiredis/adapters/libhv.h
|
||||||
|
include/hiredis/adapters/libsdevent.h
|
||||||
include/hiredis/adapters/libuv.h
|
include/hiredis/adapters/libuv.h
|
||||||
include/hiredis/adapters/macosx.h
|
include/hiredis/adapters/macosx.h
|
||||||
|
include/hiredis/adapters/poll.h
|
||||||
include/hiredis/adapters/qt.h
|
include/hiredis/adapters/qt.h
|
||||||
|
include/hiredis/adapters/redismoduleapi.h
|
||||||
include/hiredis/alloc.h
|
include/hiredis/alloc.h
|
||||||
include/hiredis/async.h
|
include/hiredis/async.h
|
||||||
include/hiredis/hiredis.h
|
include/hiredis/hiredis.h
|
||||||
include/hiredis/hiredis_ssl.h
|
include/hiredis/hiredis_ssl.h
|
||||||
include/hiredis/read.h
|
include/hiredis/read.h
|
||||||
include/hiredis/sds.h
|
include/hiredis/sds.h
|
||||||
lib/libhiredis.a
|
include/hiredis/sockcompat.h
|
||||||
|
lib/cmake/hiredis/hiredis-config-version.cmake
|
||||||
|
lib/cmake/hiredis/hiredis-config.cmake
|
||||||
|
lib/cmake/hiredis/hiredis-targets-%%CMAKE_BUILD_TYPE%%.cmake
|
||||||
|
lib/cmake/hiredis/hiredis-targets.cmake
|
||||||
|
lib/cmake/hiredis_ssl/hiredis_ssl-config.cmake
|
||||||
|
lib/cmake/hiredis_ssl/hiredis_ssl-targets-%%CMAKE_BUILD_TYPE%%.cmake
|
||||||
|
lib/cmake/hiredis_ssl/hiredis_ssl-targets.cmake
|
||||||
lib/libhiredis.so
|
lib/libhiredis.so
|
||||||
lib/libhiredis.so.1.0.0
|
lib/libhiredis.so.1.2.1
|
||||||
lib/libhiredis_ssl.a
|
|
||||||
lib/libhiredis_ssl.so
|
lib/libhiredis_ssl.so
|
||||||
lib/libhiredis_ssl.so.1.0.0
|
lib/libhiredis_ssl.so.1.2.1
|
||||||
libdata/pkgconfig/hiredis.pc
|
libdata/pkgconfig/hiredis.pc
|
||||||
libdata/pkgconfig/hiredis_ssl.pc
|
libdata/pkgconfig/hiredis_ssl.pc
|
||||||
|
|
Loading…
Add table
Reference in a new issue