mirror of
https://git.freebsd.org/ports.git
synced 2025-05-24 15:07:01 -04:00
- Fix build
- Stage support PR: 184234 Submitted by: Ports Fury
This commit is contained in:
parent
5f05a9fd77
commit
f6c9a93db2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=343271
3 changed files with 106 additions and 91 deletions
|
@ -3,73 +3,80 @@
|
|||
|
||||
PORTNAME= gtksql
|
||||
PORTVERSION= 0.4.5
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-testing/${PORTNAME}-${PORTVERSION}/
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-testing/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Graphical query tool for PostgreSQL/MySQL/SQLite
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE= GPLv2 # (or later)
|
||||
|
||||
LIB_DEPENDS= libavahi-client.so:${PORTSDIR}/net/avahi-app
|
||||
LIB_DEPENDS= libscintilla.so:${PORTSDIR}/x11-toolkits/scintilla
|
||||
RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_AUTOTOOLS= libtool
|
||||
USES= pkgconfig gmake
|
||||
OPTIONS_DEFINE= AVAHI
|
||||
OPTIONS_MULTI= DB
|
||||
OPTIONS_MULTI_DB= MYSQL PGSQL SQLITE
|
||||
OPTIONS_DEFAULT= SQLITE
|
||||
|
||||
USES= gettext gmake pkgconfig
|
||||
USE_GNOME= gtk20
|
||||
LDFLAGS+= -L${LOCALBASE}/lib -lgmodule-2.0
|
||||
GNU_CONFIGURE= yes
|
||||
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
|
||||
AUTOHEADER="${TRUE}"
|
||||
|
||||
MAN1= ${PORTNAME}.1
|
||||
PORTDOCS= AUTHORS ChangeLog NEWS README TODO
|
||||
CPPFLAGS+= -I${LOCALBASE}/include/scintilla -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib -lscintilla -lscintilla_lexers
|
||||
|
||||
OPTIONS_MULTI= DB
|
||||
OPTIONS_MULTI_DB= MYSQL PGSQL SQLITE3
|
||||
OPTIONS_DEFAULT= MYSQL PGSQL SQLITE3
|
||||
|
||||
NO_STAGE= yes
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${PORT_OPTIONS:MAVAHI}
|
||||
LIB_DEPENDS+= libavahi-common.so:${PORTSDIR}/net/avahi-app
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-avahi
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MMYSQL}
|
||||
USE_MYSQL= yes
|
||||
CPPFLAGS+= -I${LOCALBASE}/include/mysql
|
||||
LDFLAGS+= -L${LOCALBASE}/lib/mysql
|
||||
.else
|
||||
CONFIGURE_ARGS+=--without-mysql
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MNLS}
|
||||
USES+= gettext
|
||||
PLIST_SUB+= NLS=""
|
||||
.else
|
||||
CONFIGURE_ARGS+=--disable-nls
|
||||
PLIST_SUB+= NLS="@comment "
|
||||
CONFIGURE_ARGS+= --without-mysql
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MPGSQL}
|
||||
USE_PGSQL= yes
|
||||
.else
|
||||
CONFIGURE_ARGS+=--without-postgresql
|
||||
CONFIGURE_ARGS+= --without-postgresql
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MSQLITE3}
|
||||
LIB_DEPENDS+= libsqlite3.so:${PORTSDIR}/databases/sqlite3
|
||||
.if ${PORT_OPTIONS:MSQLITE}
|
||||
USE_SQLITE= yes
|
||||
.else
|
||||
CONFIGURE_ARGS+=--without-sqlite
|
||||
CONFIGURE_ARGS+= --without-sqlite
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|/usr/include/mysql|${LOCALBASE}/include/mysql|g' \
|
||||
-e 's|/usr/include/postgresql|${LOCALBASE}/include/postgresql/server|g' \
|
||||
@${REINPLACE_CMD} -e \
|
||||
'/-lstdc++/s|^|#| ; \
|
||||
/scintilla.a/s|^|#| ; \
|
||||
/\/scintilla\/include/s|^|#| ; \
|
||||
/ac_header/s|postgres.h|libpq-fe.h| ; \
|
||||
/^packagedatadir/s|=.*|=share/gtksql|' \
|
||||
${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} 's|make|$$(MAKE)|' \
|
||||
${WRKSRC}/scintilla/Makefile.in
|
||||
@${REINPLACE_CMD} 's|-Os|${CFLAGS}|g' \
|
||||
${WRKSRC}/scintilla/gtk/makefile
|
||||
|
||||
post-install:
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
.for file in ${PORTDOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
|
||||
.endfor
|
||||
.endif
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|-O1|| ; \
|
||||
s|-g$$|-DGTK|' \
|
||||
${WRKSRC}/src/Makefile.in
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|<postgres\.h>|<postgresql/internal/c.h>|' \
|
||||
${WRKSRC}/src/d_postgres_f.c
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|mozilla|xdg-open|' \
|
||||
${WRKSRC}/src/gtkui-object.c
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|/usr/local/gtksql|${PREFIX}/lib/gtksql|' \
|
||||
${WRKSRC}/src/plugins.c
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,20 +1,19 @@
|
|||
--- Makefile.in.orig 2013-10-08 11:01:04.306764000 +0200
|
||||
+++ Makefile.in 2013-10-08 11:27:51.000000000 +0200
|
||||
@@ -728,7 +728,7 @@
|
||||
@@ -237,14 +237,12 @@
|
||||
target_alias = @target_alias@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
-SUBDIRS = Pics po scintilla intl src pixmaps man gnome
|
||||
-gtksqldocdir = ${prefix}/doc/gtksql
|
||||
+SUBDIRS = Pics po src pixmaps man gnome
|
||||
+gtksqldocdir = ${docdir}
|
||||
gtksqldoc_DATA = \
|
||||
README\
|
||||
- COPYING\
|
||||
AUTHORS\
|
||||
ChangeLog\
|
||||
- INSTALL\
|
||||
NEWS\
|
||||
TODO
|
||||
|
||||
info-am:
|
||||
|
||||
-install-data-am: install-gtksqldocDATA
|
||||
+install-data-am:
|
||||
|
||||
install-dvi: install-dvi-recursive
|
||||
|
||||
@@ -764,7 +764,7 @@
|
||||
|
||||
ps-am:
|
||||
|
||||
-uninstall-am: uninstall-gtksqldocDATA
|
||||
+uninstall-am:
|
||||
|
||||
.MAKE: $(RECURSIVE_CLEAN_TARGETS) $(RECURSIVE_TARGETS) install-am \
|
||||
install-strip
|
||||
|
|
|
@ -1,35 +1,44 @@
|
|||
bin/gtksql
|
||||
man/man1/gtksql.1.gz
|
||||
share/applications/gtksql.desktop
|
||||
%%NLS%%share/locale/de_DE/LC_MESSAGES/gtksql.mo
|
||||
share/pixmaps/connect-grey.xpm
|
||||
share/pixmaps/connect.png
|
||||
share/pixmaps/connect.xpm
|
||||
share/pixmaps/delete-grey.xpm
|
||||
share/pixmaps/delete.xpm
|
||||
share/pixmaps/disconnect-grey.xpm
|
||||
share/pixmaps/disconnect.png
|
||||
share/pixmaps/disconnect.xpm
|
||||
share/pixmaps/export-grey.xpm
|
||||
share/pixmaps/export.xpm
|
||||
share/pixmaps/gtksql.png
|
||||
share/pixmaps/gtksql.xpm
|
||||
share/pixmaps/gtksql_db.png
|
||||
share/pixmaps/gtksql_field.png
|
||||
share/pixmaps/gtksql_gnome_icon.png
|
||||
share/pixmaps/gtksql_table.png
|
||||
share/pixmaps/new-grey.xpm
|
||||
share/pixmaps/new.xpm
|
||||
share/pixmaps/open-grey.xpm
|
||||
share/pixmaps/open.xpm
|
||||
share/pixmaps/question.xpm
|
||||
share/pixmaps/refresh-grey.xpm
|
||||
share/pixmaps/refresh.xpm
|
||||
share/pixmaps/rename-grey.xpm
|
||||
share/pixmaps/rename.xpm
|
||||
share/pixmaps/save-grey.xpm
|
||||
share/pixmaps/save.xpm
|
||||
share/pixmaps/send-grey.xpm
|
||||
share/pixmaps/send.xpm
|
||||
share/pixmaps/warning.xpm
|
||||
%%NLS%%@dirrmtry share/locale/de_DE/LC_MESSAGES
|
||||
%%NLS%%@dirrmtry share/locale/de_DE
|
||||
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
|
||||
%%PORTDOCS%%%%DOCSDIR%%/NEWS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/TODO
|
||||
%%DATADIR%%/pixmaps/connect-grey.xpm
|
||||
%%DATADIR%%/pixmaps/connect.png
|
||||
%%DATADIR%%/pixmaps/connect.xpm
|
||||
%%DATADIR%%/pixmaps/delete-grey.xpm
|
||||
%%DATADIR%%/pixmaps/delete.xpm
|
||||
%%DATADIR%%/pixmaps/disconnect-grey.xpm
|
||||
%%DATADIR%%/pixmaps/disconnect.png
|
||||
%%DATADIR%%/pixmaps/disconnect.xpm
|
||||
%%DATADIR%%/pixmaps/export-grey.xpm
|
||||
%%DATADIR%%/pixmaps/export.xpm
|
||||
%%DATADIR%%/pixmaps/gtksql.png
|
||||
%%DATADIR%%/pixmaps/gtksql.xpm
|
||||
%%DATADIR%%/pixmaps/gtksql_db.png
|
||||
%%DATADIR%%/pixmaps/gtksql_field.png
|
||||
%%DATADIR%%/pixmaps/gtksql_gnome_icon.png
|
||||
%%DATADIR%%/pixmaps/gtksql_table.png
|
||||
%%DATADIR%%/pixmaps/new-grey.xpm
|
||||
%%DATADIR%%/pixmaps/new.xpm
|
||||
%%DATADIR%%/pixmaps/open-grey.xpm
|
||||
%%DATADIR%%/pixmaps/open.xpm
|
||||
%%DATADIR%%/pixmaps/question.xpm
|
||||
%%DATADIR%%/pixmaps/refresh-grey.xpm
|
||||
%%DATADIR%%/pixmaps/refresh.xpm
|
||||
%%DATADIR%%/pixmaps/rename-grey.xpm
|
||||
%%DATADIR%%/pixmaps/rename.xpm
|
||||
%%DATADIR%%/pixmaps/save-grey.xpm
|
||||
%%DATADIR%%/pixmaps/save.xpm
|
||||
%%DATADIR%%/pixmaps/send-grey.xpm
|
||||
%%DATADIR%%/pixmaps/send.xpm
|
||||
%%DATADIR%%/pixmaps/warning.xpm
|
||||
share/locale/de_DE/LC_MESSAGES/gtksql.mo
|
||||
@dirrmtry share/locale/de_DE/LC_MESSAGES
|
||||
@dirrmtry share/locale/de_DE
|
||||
@dirrm %%DATADIR%%/pixmaps
|
||||
@dirrm %%DATADIR%%
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
|
|
Loading…
Add table
Reference in a new issue