mirror of
https://git.freebsd.org/ports.git
synced 2025-05-22 19:56:53 -04:00
- Add LICENSE_FILE
- Switch to options helpers - Regenerate patches with `make makepatch`
This commit is contained in:
parent
02702cf90a
commit
f51a5a458c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=412074
4 changed files with 17 additions and 20 deletions
|
@ -16,8 +16,7 @@ MAINTAINER= ports@FreeBSD.org
|
||||||
COMMENT= Spreadsheet program for X and terminals
|
COMMENT= Spreadsheet program for X and terminals
|
||||||
|
|
||||||
LICENSE= GPLv2+
|
LICENSE= GPLv2+
|
||||||
|
LICENSE_FILE= ${WRKSRC}/GNU_GENERAL
|
||||||
OPTIONS_DEFINE= X11 DOCS
|
|
||||||
|
|
||||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.orig
|
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.orig
|
||||||
|
|
||||||
|
@ -27,16 +26,12 @@ PORTDOCS= *
|
||||||
PLIST_FILES= bin/pxspread bin/xspread man/man1/pxspread.1.gz \
|
PLIST_FILES= bin/pxspread bin/xspread man/man1/pxspread.1.gz \
|
||||||
man/man1/xspread.1.gz
|
man/man1/xspread.1.gz
|
||||||
|
|
||||||
.include <bsd.port.options.mk>
|
OPTIONS_DEFINE= X11 DOCS
|
||||||
|
|
||||||
.if ${PORT_OPTIONS:MX11}
|
X11_USE= XORG=x11,xau,xcb,xdmcp,xt
|
||||||
USE_XORG= x11 xau xcb xdmcp xt
|
X11_LIB_DEPENDS= libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs
|
||||||
LIB_DEPENDS+= libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs
|
X11_USES= localbase
|
||||||
CPPFLAGS+= -I${LOCALBASE}/include
|
X11_CONFIGURE_ENV_OFF= ac_cv_header_X11_X_h=no
|
||||||
LDFLAGS+= -L${LOCALBASE}/lib
|
|
||||||
.else
|
|
||||||
CONFIGURE_ENV+= ac_cv_header_X11_X_h=no
|
|
||||||
.endif
|
|
||||||
|
|
||||||
post-patch:
|
post-patch:
|
||||||
@${REINPLACE_CMD} 's|/usr/local/lib/libXt|${LOCALBASE}/lib/libXt|' \
|
@${REINPLACE_CMD} 's|/usr/local/lib/libXt|${LOCALBASE}/lib/libXt|' \
|
||||||
|
@ -49,7 +44,9 @@ do-install:
|
||||||
${INSTALL_PROGRAM} ${WRKSRC}/xspread ${STAGEDIR}${PREFIX}/bin/xspread
|
${INSTALL_PROGRAM} ${WRKSRC}/xspread ${STAGEDIR}${PREFIX}/bin/xspread
|
||||||
${INSTALL_MAN} ${WRKSRC}/pxspread.man ${STAGEDIR}${MANPREFIX}/man/man1/pxspread.1
|
${INSTALL_MAN} ${WRKSRC}/pxspread.man ${STAGEDIR}${MANPREFIX}/man/man1/pxspread.1
|
||||||
${INSTALL_MAN} ${WRKSRC}/xspread.man ${STAGEDIR}${MANPREFIX}/man/man1/xspread.1
|
${INSTALL_MAN} ${WRKSRC}/xspread.man ${STAGEDIR}${MANPREFIX}/man/man1/xspread.1
|
||||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
|
||||||
|
do-install-DOCS-on:
|
||||||
|
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||||
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
|
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
|
||||||
${INSTALL_DATA} ${WRKSRC}/x/notes ${STAGEDIR}${DOCSDIR}
|
${INSTALL_DATA} ${WRKSRC}/x/notes ${STAGEDIR}${DOCSDIR}
|
||||||
(cd ${WRKSRC} && ${COPYTREE_SHARE} "doc documents sample_files tests" ${STAGEDIR}${DOCSDIR} "! -name *.tmp")
|
(cd ${WRKSRC} && ${COPYTREE_SHARE} "doc documents sample_files tests" ${STAGEDIR}${DOCSDIR} "! -name *.tmp")
|
||||||
|
|
|
@ -1,5 +1,5 @@
|
||||||
--- Makefile.in.orig Tue Nov 7 11:17:18 1995
|
--- Makefile.in.orig 1995-11-07 02:17:18 UTC
|
||||||
+++ Makefile.in Tue Sep 28 01:41:35 1999
|
+++ Makefile.in
|
||||||
@@ -1,7 +1,7 @@
|
@@ -1,7 +1,7 @@
|
||||||
|
|
||||||
# Common prefix for installation directories.
|
# Common prefix for installation directories.
|
||||||
|
@ -9,7 +9,7 @@
|
||||||
exec_prefix = $(prefix)
|
exec_prefix = $(prefix)
|
||||||
# Where to put the executables.
|
# Where to put the executables.
|
||||||
bindir = $(exec_prefix)/bin
|
bindir = $(exec_prefix)/bin
|
||||||
@@ -19,7 +19,7 @@
|
@@ -19,7 +19,7 @@ CC = @CC@
|
||||||
CFLAGS = @CFLAGS@
|
CFLAGS = @CFLAGS@
|
||||||
DEFS = @DEFS@
|
DEFS = @DEFS@
|
||||||
LIBS = @LIBS@
|
LIBS = @LIBS@
|
||||||
|
|
|
@ -1,5 +1,5 @@
|
||||||
--- config_h.in.orig Tue Nov 7 11:17:21 1995
|
--- config_h.in.orig 1995-11-07 02:17:21 UTC
|
||||||
+++ config_h.in Tue Sep 28 04:00:50 1999
|
+++ config_h.in
|
||||||
@@ -12,7 +12,7 @@
|
@@ -12,7 +12,7 @@
|
||||||
#define SAVENAME "SC.SAVE"
|
#define SAVENAME "SC.SAVE"
|
||||||
|
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- interp.c.orig Tue Nov 7 03:17:26 1995
|
--- interp.c.orig 1995-11-07 02:17:26 UTC
|
||||||
+++ interp.c Fri Mar 10 13:34:37 2000
|
+++ interp.c
|
||||||
@@ -516,7 +516,7 @@
|
@@ -516,7 +516,7 @@ int mo, day, yr;
|
||||||
mdays[1] = 28 + (yr%4 == 0);
|
mdays[1] = 28 + (yr%4 == 0);
|
||||||
|
|
||||||
if (mo < 1 || mo > 12 || day < 1 || day > mdays[--mo] ||
|
if (mo < 1 || mo > 12 || day < 1 || day > mdays[--mo] ||
|
||||||
|
|
Loading…
Add table
Reference in a new issue