mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
math/py-hdbscan: Convert to USE_PYTHON=pep517
- Remove cython version check from BUILD_DEPENDS - Bump PORTREVISION for package change
This commit is contained in:
parent
8fb3a7ebd6
commit
f42471ff18
3 changed files with 18 additions and 5 deletions
|
@ -1,5 +1,6 @@
|
||||||
PORTNAME= hdbscan
|
PORTNAME= hdbscan
|
||||||
PORTVERSION= 0.8.33
|
PORTVERSION= 0.8.33
|
||||||
|
PORTREVISION= 1
|
||||||
CATEGORIES= math python
|
CATEGORIES= math python
|
||||||
MASTER_SITES= PYPI
|
MASTER_SITES= PYPI
|
||||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||||
|
@ -12,8 +13,7 @@ WWW= https://hdbscan.readthedocs.io/en/latest/ \
|
||||||
LICENSE= BSD3CLAUSE
|
LICENSE= BSD3CLAUSE
|
||||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||||
|
|
||||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cython>=0<3:lang/cython@${PY_FLAVOR} \
|
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR} \
|
||||||
${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR} \
|
|
||||||
${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
|
${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
|
||||||
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
|
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
|
||||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}joblib>=1.0:devel/py-joblib@${PY_FLAVOR} \
|
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}joblib>=1.0:devel/py-joblib@${PY_FLAVOR} \
|
||||||
|
@ -22,7 +22,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}joblib>=1.0:devel/py-joblib@${PY_FLAVOR} \
|
||||||
${PYTHON_PKGNAMEPREFIX}scipy>=1.0:science/py-scipy@${PY_FLAVOR}
|
${PYTHON_PKGNAMEPREFIX}scipy>=1.0:science/py-scipy@${PY_FLAVOR}
|
||||||
|
|
||||||
USES= python
|
USES= python
|
||||||
USE_PYTHON= autoplist concurrent cython distutils
|
USE_PYTHON= autoplist concurrent cython pep517
|
||||||
|
|
||||||
post-install:
|
post-install:
|
||||||
${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
|
${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
|
||||||
|
|
|
@ -1,9 +1,11 @@
|
||||||
--- pyproject.toml.orig 2023-07-18 17:51:04 UTC
|
--- pyproject.toml.orig 2023-07-18 17:51:04 UTC
|
||||||
+++ pyproject.toml
|
+++ pyproject.toml
|
||||||
@@ -3,5 +3,5 @@ requires = [
|
@@ -2,6 +2,6 @@ requires = [
|
||||||
|
requires = [
|
||||||
"setuptools",
|
"setuptools",
|
||||||
"wheel",
|
"wheel",
|
||||||
"cython<3",
|
- "cython<3",
|
||||||
- "oldest-supported-numpy"
|
- "oldest-supported-numpy"
|
||||||
|
+ "cython",
|
||||||
+ "numpy"
|
+ "numpy"
|
||||||
]
|
]
|
||||||
|
|
11
math/py-hdbscan/files/patch-setup.py
Normal file
11
math/py-hdbscan/files/patch-setup.py
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- setup.py.orig 2023-07-18 17:51:04 UTC
|
||||||
|
+++ setup.py
|
||||||
|
@@ -85,7 +85,7 @@ configuration = {
|
||||||
|
'cmdclass': {'build_ext': CustomBuildExtCommand},
|
||||||
|
'test_suite': 'nose.collector',
|
||||||
|
'tests_require': ['nose'],
|
||||||
|
- 'data_files': ('hdbscan/dist_metrics.pxd',)
|
||||||
|
+ 'package_data': {'': ['hdbscan/dist_metrics.pxd']},
|
||||||
|
}
|
||||||
|
|
||||||
|
if not HAVE_CYTHON:
|
Loading…
Add table
Reference in a new issue