- Update to version 0.3.0 (sadly, not tagged at GitHub)

- Do not manually strip installed binary, use install/strip target
- Remove no longer required build dependency on `devel/binutils'
- Use more accurate __FreeBSD_version in one of the patches

Prodded by:	Christopher Haglund
Approved by:	maintainer (per earlier email)
This commit is contained in:
Alexey Dokuchaev 2013-11-29 14:19:08 +00:00
parent bc9072ea3d
commit f16431a499
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=335180
4 changed files with 32 additions and 13 deletions

View file

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= grive
PORTVERSION= 0.2.0
PORTREVISION= 1
PORTVERSION= 0.3.0
CATEGORIES= net
MAINTAINER= ktsin@acm.org
@ -11,29 +10,31 @@ COMMENT= Open source client for Google Drive
LICENSE= GPLv2
BUILD_DEPENDS= ${LOCALBASE}/lib/libiberty.a:${PORTSDIR}/devel/binutils
LIB_DEPENDS= libboost_filesystem.so:${PORTSDIR}/devel/boost-libs \
libcurl.so:${PORTSDIR}/ftp/curl \
libexpat.so:${PORTSDIR}/textproc/expat2 \
libgcrypt.so:${PORTSDIR}/security/libgcrypt \
libjson.so:${PORTSDIR}/devel/json-c
libjson.so:${PORTSDIR}/devel/json-c \
libyajl.so:${PORTSDIR}/devel/yajl
USE_GITHUB= yes
GH_ACCOUNT= Grive
GH_PROJECT= ${PORTNAME}
GH_COMMIT= 93d696a
GH_TAGNAME= v${PORTVERSION}
GH_COMMIT= 27817e8
GH_TAGNAME= ${GH_COMMIT}
USES= cmake
CXXFLAGS+= -I${LOCALBASE}/include
INSTALL_TARGET= install/strip
PLIST_FILES= bin/grive man/man1/grive.1.gz
# Allow to build with GCC 4.2
post-patch:
@${REINPLACE_CMD} -e '/FIND_LIBRARY/s,json,&-c,' \
${WRKSRC}/cmake/Modules/FindJSONC.cmake
# Do not build Qt4-based frontend: it's buggy and quite useless anyway
@${REINPLACE_CMD} -e '/ bgrive/d' ${WRKSRC}/CMakeLists.txt
# Allow to build with GCC 4.2
@${REINPLACE_CMD} -e 's,log::,gr::&,g' ${WRKSRC}/grive/src/main.cc
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/grive
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (grive-0.2.0.tar.gz) = f9b32eb9da9f2d47b6642248e1e25606e9ab2cd5b3e94730b23399250ec7f2ec
SIZE (grive-0.2.0.tar.gz) = 144474
SHA256 (grive-0.3.0.tar.gz) = a4e01d76f0e4c3e84fccae0580631117fad7989363c3308a7542b554230f5d76
SIZE (grive-0.3.0.tar.gz) = 162465

View file

@ -0,0 +1,18 @@
--- libgrive/src/drive/State.cc.orig 2013-05-03 00:40:04.000000000 +0800
+++ libgrive/src/drive/State.cc 2013-11-27 15:17:50.000000000 +0800
@@ -248,12 +248,12 @@ void State::Read( const fs::path& filena
void State::Write( const fs::path& filename ) const
{
Json last_sync ;
- last_sync.Add( "sec", Json(m_last_sync.Sec() ) );
- last_sync.Add( "nsec", Json(m_last_sync.NanoSec() ) );
+ last_sync.Add( "sec", Json((boost::uint64_t)m_last_sync.Sec() ) );
+ last_sync.Add( "nsec", Json((boost::uint64_t)m_last_sync.NanoSec() ) );
Json result ;
result.Add( "last_sync", last_sync ) ;
- result.Add( "change_stamp", Json(m_cstamp) ) ;
+ result.Add( "change_stamp", Json((boost::uint64_t)m_cstamp) ) ;
std::ofstream fs( filename.string().c_str() ) ;
fs << result ;

View file

@ -7,7 +7,7 @@ index 0d51136..469e373 100644
}
-#if defined __APPLE__ && defined __DARWIN_64_BIT_INO_T
+#if defined(__FreeBSD__) && __FreeBSD_version < 900000
+#if defined(__FreeBSD__) && __FreeBSD_version < 900010
return DateTime( s.st_ctimespec.tv_sec, s.st_ctimespec.tv_nsec ) ;
#else
return DateTime( s.st_ctim.tv_sec, s.st_ctim.tv_nsec);