mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
net/lambdamoo: fix build on current FreeBSD, define LICENSE
- this has some seriously ancient autotools stuff in it - it doesn't even quite work these days MFH: 2024Q2
This commit is contained in:
parent
5fad94ee1e
commit
f0c5bad08a
7 changed files with 69 additions and 32 deletions
|
@ -9,7 +9,12 @@ MAINTAINER= ports@FreeBSD.org
|
|||
COMMENT= The most commonly used program to run MOOs
|
||||
WWW= https://www.moo.mud.org/
|
||||
|
||||
USES= bison
|
||||
LICENSE= XEROX
|
||||
LICENSE_NAME= unknown
|
||||
LICENSE_FILE= ${WRKSRC}/server.c
|
||||
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
|
||||
|
||||
USES= autoreconf:build bison
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
CONFIGURE_ENV= YACC=${YACC}
|
||||
|
@ -23,6 +28,10 @@ ALL_TARGET=
|
|||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
# needs to run just autoconf, autoreconf doesn't work
|
||||
pre-configure:
|
||||
cd ${WRKSRC} && ${LOCALBASE}/bin/autoconf${_AUTORECONF}
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/moo ${STAGEDIR}${PREFIX}/sbin
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- Makefile.in.orig 2000-01-10 20:54:05.000000000 -0500
|
||||
+++ Makefile.in 2014-08-16 12:36:54.000000000 -0400
|
||||
@@ -14,10 +14,10 @@
|
||||
--- Makefile.in.orig 2000-01-11 01:54:05 UTC
|
||||
+++ Makefile.in
|
||||
@@ -14,10 +14,10 @@ CC = @CC@
|
||||
# Pavel@Xerox.Com
|
||||
|
||||
CC = @CC@
|
||||
|
|
|
@ -1,6 +1,18 @@
|
|||
--- config.h.in.orig Sun Jul 4 16:45:44 1999
|
||||
+++ config.h.in Sun Jul 4 16:45:54 1999
|
||||
@@ -163,7 +163,7 @@
|
||||
--- config.h.in.orig 1998-12-29 05:26:51 UTC
|
||||
+++ config.h.in
|
||||
@@ -94,9 +94,10 @@
|
||||
#undef NDECL_FORK /* <unistd.h> */
|
||||
#undef NDECL_WAITPID /* <sys/wait.h> */
|
||||
|
||||
-/* Some systems declare bzero() in <stdlib.h> instead of in <string.h>. */
|
||||
+/* Some systems declare bzero() in <stdlib.h> or <strings.h> instead of in <string.h>. */
|
||||
|
||||
#undef BZERO_IN_STDLIB_H
|
||||
+#undef BZERO_IN_STRINGS_H
|
||||
|
||||
/* Some header files are only present on certain kinds of UNIXes (e.g., BSD,
|
||||
* System V, or POSIX). The following symbols are defined only if the named
|
||||
@@ -163,7 +164,7 @@
|
||||
* system provides the named functions.
|
||||
*/
|
||||
|
||||
|
@ -9,7 +21,7 @@
|
|||
#undef HAVE_MATHERR
|
||||
#undef HAVE_MKFIFO
|
||||
#undef HAVE_REMOVE
|
||||
@@ -257,12 +257,16 @@
|
||||
@@ -257,12 +258,16 @@
|
||||
#if INT_MAX == 2147483647
|
||||
typedef int int32;
|
||||
typedef unsigned unsigned32;
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
--- configure.orig Mon Apr 8 22:32:10 2002
|
||||
+++ configure Mon Apr 8 22:51:13 2002
|
||||
@@ -599,7 +599,7 @@
|
||||
cat > conftest.c <<EOF
|
||||
#include "confdefs.h"
|
||||
|
||||
-int main(int argc, char *argv) { void *ptr; exit(0); }
|
||||
+int main(int argc, char **argv) { void *ptr; exit(0); }
|
||||
|
||||
EOF
|
||||
eval $compile
|
||||
@@ -1618,7 +1618,7 @@
|
||||
do
|
||||
echo "checking whether $func is declared in sys/ioctl.h"
|
||||
|
||||
-pattern="[^_a-zA-Z0-9]$func *\("
|
||||
+pattern="[^_a-zA-Z0-9]$func\)? *\("
|
||||
cat > conftest.c <<EOF
|
||||
#include "confdefs.h"
|
||||
|
|
@ -1,6 +1,6 @@
|
|||
--- configure.in.orig Mon Apr 8 22:31:30 2002
|
||||
+++ configure.in Mon Apr 8 22:52:21 2002
|
||||
@@ -105,7 +105,7 @@
|
||||
--- configure.in.orig 1997-03-03 03:45:05 UTC
|
||||
+++ configure.in
|
||||
@@ -105,7 +105,7 @@ changequote(,)dnl
|
||||
dnl `header'.
|
||||
define(MOO_FUNC_DECL_CHECK, [
|
||||
changequote(,)dnl
|
||||
|
@ -9,7 +9,7 @@
|
|||
changequote([,])dnl
|
||||
AC_PROGRAM_EGREP($pattern, [
|
||||
#include <$1>
|
||||
@@ -260,7 +260,7 @@
|
||||
@@ -260,7 +260,7 @@ AC_TEST_PROGRAM([
|
||||
SAVECC="$CC"
|
||||
CC="$CC $opt"
|
||||
AC_TEST_PROGRAM([
|
||||
|
@ -18,3 +18,14 @@
|
|||
],
|
||||
[have_ansi=1
|
||||
break],
|
||||
@@ -333,8 +333,9 @@ MOO_NDECL_FUNCS(string.h, bzero memcpy memset strerror
|
||||
#include <memory.h>
|
||||
#endif
|
||||
])
|
||||
-echo checking for bzero being declared in stdlib.h
|
||||
+echo checking for bzero being declared in stdlib.h and strings.h
|
||||
MOO_FUNC_DECL_CHECK(stdlib.h, bzero, AC_DEFINE(BZERO_IN_STDLIB_H))
|
||||
+MOO_FUNC_DECL_CHECK(strings.h, bzero, AC_DEFINE(BZERO_IN_STRINGS_H))
|
||||
MOO_NDECL_FUNCS(sys/time.h, getitimer setitimer select, [
|
||||
#if NEED_SELECT_H
|
||||
#include <sys/types.h>
|
||||
|
|
14
net/lambdamoo/files/patch-my-stat.h
Normal file
14
net/lambdamoo/files/patch-my-stat.h
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- my-stat.h.orig 2024-10-18 08:58:26 UTC
|
||||
+++ my-stat.h
|
||||
@@ -31,11 +31,6 @@ extern int mkfifo(const char *, mode_t);
|
||||
extern int mkfifo(const char *, mode_t);
|
||||
#endif
|
||||
|
||||
-#if !HAVE_MKFIFO
|
||||
-extern int mknod(const char *file, int mode, int dev);
|
||||
-#define mkfifo(path, mode) mknod(path, S_IFIFO | (mode), 0)
|
||||
-#endif
|
||||
-
|
||||
/*
|
||||
* $Log: my-stat.h,v $
|
||||
* Revision 1.3 1998/12/14 13:18:15 nop
|
11
net/lambdamoo/files/patch-my-string.h
Normal file
11
net/lambdamoo/files/patch-my-string.h
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- my-string.h.orig 2024-10-18 08:41:29 UTC
|
||||
+++ my-string.h
|
||||
@@ -72,6 +72,8 @@ extern const char *sys_errlist[];
|
||||
#if NDECL_BZERO && !defined(bzero)
|
||||
# if BZERO_IN_STDLIB_H
|
||||
# include "my-stdlib.h"
|
||||
+# elif BZERO_IN_STRINGS_H
|
||||
+# include <strings.h>
|
||||
# else
|
||||
extern void bzero(char *, int);
|
||||
# endif
|
Loading…
Add table
Reference in a new issue