- Update from 1.0 to 1.1

- Change maintainer email to @FreeBSD.org
- Add staging support
- Add lzip as EXTRACT_DEPENDS

Approved by:	wg (mentor)
This commit is contained in:
Danilo Egea Gondolfo 2013-09-26 12:23:46 +00:00
parent 302a490316
commit f0475bcdd9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=328351
4 changed files with 38 additions and 19 deletions

View file

@ -2,36 +2,29 @@
# $FreeBSD$
PORTNAME= zutils
PORTVERSION= 1.0
PORTVERSION= 1.1
CATEGORIES= archivers
MASTER_SITES= SAVANNAH/zutils
EXTRACT_SUFX= .tar.lz
MAINTAINER= danilogondolfo@gmail.com
MAINTAINER= danilo@FreeBSD.org
COMMENT= Utilities for searching in bzip2, gzip, lzip, and xz archives
LICENSE= GPLv3
PLIST_FILES= bin/zcat \
bin/zcmp \
bin/zdiff \
bin/zegrep \
bin/zfgrep \
bin/zgrep \
bin/ztest \
bin/zutils
EXTRACT_DEPENDS= lzip:${PORTSDIR}/archivers/lzip
MAN1= zcat.1 \
zcmp.1 \
zdiff.1 \
zgrep.1 \
ztest.1
INFO= zutils
NO_STAGE= yes
GNU_CONFIGURE= yes
do-extract:
@${MKDIR} ${WRKDIR}
@(cd ${WRKDIR} ; ${LOCALBASE}/bin/lzip -cd \
${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} | ${TAR} -xf -)
post-patch:
# Remove compiler hardcoded flags and use environment
${REINPLACE_CMD} '23,26d' ${WRKSRC}/configure
${REINPLACE_CMD} '24,27d' ${WRKSRC}/configure
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (zutils-1.0.tar.gz) = 7eff74e89a135480472359a239b71ff0a75db529f813cb1193071de39ed60d04
SIZE (zutils-1.0.tar.gz) = 69558
SHA256 (zutils-1.1.tar.lz) = c431cff331ce20a5405125a5be163de4980f06ecdca3b4e4fbe1ed1f68724e3f
SIZE (zutils-1.1.tar.lz) = 43985

View file

@ -0,0 +1,12 @@
--- ./zutils.h.orig 2013-07-07 14:15:39.000000000 -0300
+++ ./zutils.h 2013-09-25 17:32:23.000000000 -0300
@@ -15,6 +15,9 @@
along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
+#include <sys/types.h>
+#include <signal.h>
+
const char * const Program_name = "Zutils";
const char * const program_name = "zutils";
const char * const config_file_name = "zutilsrc";

View file

@ -0,0 +1,14 @@
bin/zcat
bin/zcmp
bin/zdiff
bin/zegrep
bin/zfgrep
bin/zgrep
bin/ztest
bin/zutils
etc/zutilsrc
man/man1/zcat.1.gz
man/man1/zcmp.1.gz
man/man1/zdiff.1.gz
man/man1/zgrep.1.gz
man/man1/ztest.1.gz