science/qmcpack: update 3.15.0 → 3.17.1

This commit is contained in:
Yuri Victorovich 2024-12-14 20:48:58 -08:00
parent e74eb07b30
commit efa44eab43
4 changed files with 20 additions and 9 deletions

View file

@ -1,12 +1,12 @@
PORTNAME= qmcpack
DISTVERSIONPREFIX= v
DISTVERSION= 3.15.0
PORTREVISION= 6
DISTVERSION= 3.17.1
CATEGORIES= science
MAINTAINER= yuri@FreeBSD.org
COMMENT= Many-body ab initio Quantum Monte Carlo code for quantum chemistry
WWW= https://www.qmcpack.org/
WWW= https://www.qmcpack.org/ \
https://github.com/QMCPACK/qmcpack
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1665201281
SHA256 (QMCPACK-qmcpack-v3.15.0_GH0.tar.gz) = cab0b78a481bac9f74d44d2ab5314443d5fb5891c5fbda4b9a46920c2aea6839
SIZE (QMCPACK-qmcpack-v3.15.0_GH0.tar.gz) = 120993890
TIMESTAMP = 1734220039
SHA256 (QMCPACK-qmcpack-v3.17.1_GH0.tar.gz) = 5318e69a46c035986e560ea3d4c79dc273b67974f01715c93b017ce2a0098399
SIZE (QMCPACK-qmcpack-v3.17.1_GH0.tar.gz) = 122344183

View file

@ -1,6 +1,6 @@
--- CMakeLists.txt.orig 2022-09-28 23:03:18 UTC
--- CMakeLists.txt.orig 2023-08-25 11:42:03 UTC
+++ CMakeLists.txt
@@ -292,7 +292,7 @@ set(CMAKE_CXX_EXTENSIONS OFF)
@@ -303,7 +303,7 @@ include(Testlibstdc++)
include(Testlibstdc++)
# Check that a C++ standard library is configured properly
@ -9,7 +9,7 @@
#-----------------------------------------------------------------------
# SETUP SANITIZERS FLAGS
@@ -1043,7 +1043,7 @@ include(CTest)
@@ -1063,7 +1063,7 @@ include(CTest)
#-------------------------------------------------------------------
# Verify Python3 available
#-------------------------------------------------------------------

View file

@ -0,0 +1,11 @@
--- external_codes/mpi_wrapper/mpi3/include/mpi3/detail/package.hpp.orig 2024-12-15 00:09:27 UTC
+++ external_codes/mpi_wrapper/mpi3/include/mpi3/detail/package.hpp
@@ -24,7 +24,7 @@ struct package : buffer {
public:
explicit package(communicator& comm, buffer::size_type n = 0)
- : buffer{n}, bcomm_{reinterpret_cast<basic_communicator&>(comm)} { // NOLINT(cppcoreguidelines-pro-type-reinterpret-cast) TODO(correaa) break cyclic dependency of classes
+ : buffer(static_cast<size_t>(n)), bcomm_{reinterpret_cast<basic_communicator&>(comm)} { // NOLINT(cppcoreguidelines-pro-type-reinterpret-cast) TODO(correaa) break cyclic dependency of classes
reserve(n);
}
package(package const&) = delete;