Add new port gpstk, the ARL GPS Toolkit; a software library for working

with raw GPS data, NMEA feeds, ephemerii, etc.

Requested by:	Tom McHugh
This commit is contained in:
Bruce M Simpson 2006-11-02 13:13:17 +00:00
parent 4af0efe66d
commit ef3cfe34f8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=176181
11 changed files with 314 additions and 0 deletions

View file

@ -22,6 +22,7 @@
SUBDIR += gpsd SUBDIR += gpsd
SUBDIR += gpsdrive SUBDIR += gpsdrive
SUBDIR += gpsman SUBDIR += gpsman
SUBDIR += gpstk
SUBDIR += jday SUBDIR += jday
SUBDIR += libnova SUBDIR += libnova
SUBDIR += luna SUBDIR += luna

33
astro/gpstk/Makefile Normal file
View file

@ -0,0 +1,33 @@
# New ports collection makefile for: gpstk
# Date created: 12 May 2004
# Whom: bms@FreeBSD.org
#
# $FreeBSD$
#
PORTNAME= gpstk
PORTVERSION= 1.1
CATEGORIES= astro devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= bms@FreeBSD.org
COMMENT= Toolkit for developing GPS applications
BUILD_DEPENDS= ${LOCALBASE}/bin/jam:${PORTSDIR}/devel/jam
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
JAM= ${LOCALBASE}/bin/jam
JAM_ENV= BINDIR=${PREFIX}/bin \
INCDIR=${PREFIX}/include \
LIBDIR=${PREFIX}/lib
do-build:
cd ${WRKSRC} && ${SETENV} ${JAM_ENV} ${JAM}
do-install:
cd ${WRKSRC} && ${SETENV} ${JAM_ENV} ${JAM} install
.include <bsd.port.mk>

3
astro/gpstk/distinfo Normal file
View file

@ -0,0 +1,3 @@
MD5 (gpstk-1.1.tar.gz) = 11c97d2230a6234582fe41d180bee999
SHA256 (gpstk-1.1.tar.gz) = 0fb638d1eb1c45030b8dfec6923352a5c790b5c30db23bc1e3edf92e6c5b7bbd
SIZE (gpstk-1.1.tar.gz) = 3502402

View file

@ -0,0 +1,22 @@
--- Jamrules.orig Wed Jan 19 19:36:30 2005
+++ Jamrules Thu May 12 15:29:05 2005
@@ -9,7 +9,7 @@
KEEPOBJS = true ;
# where to install the .hpp files
-INCDIR = /usr/local/include ;
+#INCDIR = /usr/local/include ;
# override the built-in EXEMODE
EXEMODE = 755 ;
@@ -29,6 +29,10 @@
{
case CYGWIN :
LINKLIBS += -lstdc++ ;
+
+ case FREEBSD :
+ LINKLIBS += -lstdc++ ;
+ CCSHARE_FLAGS = -fPIC ;
case LINUX :
LINKLIBS += -lstdc++ ;

View file

@ -0,0 +1,18 @@
--- apps/checktools/ficacheck.cpp.orig Wed Jan 19 19:36:30 2005
+++ apps/checktools/ficacheck.cpp Thu May 12 15:12:26 2005
@@ -1,11 +1,14 @@
#pragma ident "$Id: //depot/sgl/gpstk/dev/apps/checktools/ficacheck.cpp#1 $"
+using namespace std;
+
+#include <ostream>
+
#include "CheckFrame.hpp"
#include "FICAStream.hpp"
#include "FICData.hpp"
-using namespace std;
using namespace gpstk;
int main(int argc, char* argv[])

View file

@ -0,0 +1,17 @@
--- apps/checktools/ficcheck.cpp.orig Wed Jan 19 19:36:30 2005
+++ apps/checktools/ficcheck.cpp Thu May 12 15:12:26 2005
@@ -1,11 +1,13 @@
#pragma ident "$Id: //depot/sgl/gpstk/dev/apps/checktools/ficcheck.cpp#1 $"
+using namespace std;
+#include <ostream>
+
#include "CheckFrame.hpp"
#include "FICStream.hpp"
#include "FICData.hpp"
-using namespace std;
using namespace gpstk;
int main(int argc, char* argv[])

View file

@ -0,0 +1,18 @@
--- apps/checktools/rmwcheck.cpp.orig Wed Jan 19 19:36:30 2005
+++ apps/checktools/rmwcheck.cpp Thu May 12 15:12:26 2005
@@ -1,12 +1,14 @@
#pragma ident "$Id: //depot/sgl/gpstk/dev/apps/checktools/rmwcheck.cpp#1 $"
+using namespace std;
+#include <ostream>
+
#include "CheckFrame.hpp"
#include "RinexMetStream.hpp"
#include "RinexMetData.hpp"
#include "RinexMetFilterOperators.hpp"
-using namespace std;
using namespace gpstk;
int main(int argc, char* argv[])

View file

@ -0,0 +1,17 @@
--- apps/checktools/rnwcheck.cpp.orig Wed Jan 19 19:36:30 2005
+++ apps/checktools/rnwcheck.cpp Thu May 12 15:12:26 2005
@@ -1,11 +1,13 @@
#pragma ident "$Id: //depot/sgl/gpstk/dev/apps/checktools/rnwcheck.cpp#1 $"
+using namespace std;
+#include <ostream>
+
#include "CheckFrame.hpp"
#include "RinexNavStream.hpp"
#include "RinexNavData.hpp"
-using namespace std;
using namespace gpstk;
int main(int argc, char* argv[])

View file

@ -0,0 +1,17 @@
--- apps/checktools/rowcheck.cpp.orig Wed Jan 19 19:36:30 2005
+++ apps/checktools/rowcheck.cpp Thu May 12 15:12:26 2005
@@ -1,11 +1,13 @@
#pragma ident "$Id: //depot/sgl/gpstk/dev/apps/checktools/rowcheck.cpp#1 $"
+using namespace std;
+#include <ostream>
+
#include "CheckFrame.hpp"
#include "RinexObsStream.hpp"
#include "RinexObsData.hpp"
-using namespace std;
using namespace gpstk;
int main(int argc, char* argv[])

3
astro/gpstk/pkg-descr Normal file
View file

@ -0,0 +1,3 @@
The GPSTk is a C++ library for developing GPS applications.
WWW: http://gpstk.sourceforge.net/

165
astro/gpstk/pkg-plist Normal file
View file

@ -0,0 +1,165 @@
lib/libgpstk.so
lib/libgpstk.a
include/stl_helpers.hpp
include/icd_200_constants.hpp
include/gpstk/
include/gps_constants.hpp
include/getopt.h
include/geometry.hpp
include/convhelp.hpp
include/Xvt.hpp
include/X2Sequence.hpp
include/X1Sequence.hpp
include/WGS84Geoid.hpp
include/VectorOperators.hpp
include/VectorBaseOperators.hpp
include/VectorBase.hpp
include/Vector.hpp
include/ValidType.hpp
include/TropModel.hpp
include/Triple.hpp
include/TabularEphemerisStore.hpp
include/StringUtils.hpp
include/Stats.hpp
include/SatID.hpp
include/SVPCodeGen.hpp
include/SP3Stream.hpp
include/SP3Header.hpp
include/SP3EphemerisStore.hpp
include/SP3Data.hpp
include/SP3Base.hpp
include/SMODFStream.hpp
include/SMODFData.hpp
include/RungeKutta4.hpp
include/RinexObsStream.hpp
include/RinexObsHeader.hpp
include/RinexObsFilterOperators.hpp
include/RinexObsData.hpp
include/RinexObsBase.hpp
include/RinexNavStream.hpp
include/RinexNavHeader.hpp
include/RinexNavFilterOperators.hpp
include/RinexNavData.hpp
include/RinexNavBase.hpp
include/RinexMetStream.hpp
include/RinexMetHeader.hpp
include/RinexMetFilterOperators.hpp
include/RinexMetData.hpp
include/RinexMetBase.hpp
include/RinexEphemerisStore.hpp
include/RTFileFrame.hpp
include/RAIMSolution.hpp
include/Position.hpp
include/PolyFit.hpp
include/PCodeConst.hpp
include/ObservationStore.hpp
include/ObsRngDev.hpp
include/ObsClockModel.hpp
include/ORDEpoch.hpp
include/MiscMath.hpp
include/MatrixOperators.hpp
include/MatrixImplementation.hpp
include/MatrixFunctors.hpp
include/MatrixBaseOperators.hpp
include/MatrixBase.hpp
include/Matrix.hpp
include/MathBase.hpp
include/MSCStream.hpp
include/MSCData.hpp
include/LoopedFramework.hpp
include/LinearClockModel.hpp
include/IonoModelStore.hpp
include/IonoModel.hpp
include/GeoidModel.hpp
include/Geodetic.hpp
include/GenXSequence.hpp
include/GPSZcount.hpp
include/GPSGeoid.hpp
include/FileUtils.hpp
include/FileStore.hpp
include/FileSpec.hpp
include/FileHunter.hpp
include/FileFilterFrameWithHeader.hpp
include/FileFilterFrame.hpp
include/FileFilter.hpp
include/FICStreamBase.hpp
include/FICStream.hpp
include/FICHeader.hpp
include/FICFilterOperators.hpp
include/FICData.hpp
include/FICBase.hpp
include/FICAStream.hpp
include/FFTextStream.hpp
include/FFStreamError.hpp
include/FFStream.hpp
include/FFData.hpp
include/FFBinaryStream.hpp
include/Exception.hpp
include/EpochClockModel.hpp
include/EphemerisStore.hpp
include/EphemerisRange.hpp
include/EngNav.hpp
include/EngEphemeris.hpp
include/EngAlmanac.hpp
include/ECEF.hpp
include/DayTime.hpp
include/CommandOptionWithTimeArg.hpp
include/CommandOptionParser.hpp
include/CommandOption.hpp
include/CodeBuffer.hpp
include/ClockModel.hpp
include/BinUtils.hpp
include/BasicFramework.hpp
include/BCEphemerisStore.hpp
include/AlmanacStore.hpp
include/AlmOrbit.hpp
bin/timcvt
bin/stringutiltest
bin/rowdiff
bin/rowcheck
bin/rnwdiff
bin/rnwcheck
bin/rmwdiff
bin/rmwcheck
bin/rktest
bin/rinexthin
bin/rinex_obs_test
bin/rinex_obs_read_write
bin/rinex_nav_test
bin/rinex_nav_read_write
bin/rinex_met_test
bin/rinex_met_read_write
bin/reszilla
bin/positiontest
bin/petest
bin/navdmp
bin/mergeRinObs
bin/mergeRinNav
bin/mergeRinMet
bin/mergeFIC
bin/gpszcounttest
bin/ficfica
bin/ficdiff
bin/ficcheck
bin/ficafic
bin/ficacheck
bin/fic2rin
bin/exceptiontest
bin/ephdiff
bin/daytimetest
bin/aoa2rin
bin/TECMaps
bin/RinexDump
bin/RinSum
bin/ResCor
bin/NavMerge
bin/MatrixTest
bin/IonoBias
bin/FileSpecTest
bin/EphComp
bin/EditRinex
bin/DiscFix
bin/DayTimeToleranceTest
bin/DayTimeIncrementTest
bin/DayTimeConversionTest
bin/AnotherFileFilterTest