mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
x11/mlterm: Update to 3.9.4
This commit is contained in:
parent
720e6ba10b
commit
ef324dcb1c
6 changed files with 4 additions and 98 deletions
|
@ -1,6 +1,5 @@
|
|||
PORTNAME= mlterm
|
||||
PORTVERSION= 3.9.3
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 3.9.4
|
||||
CATEGORIES= x11
|
||||
|
||||
MAINTAINER= nobutaka@FreeBSD.org
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1680931718
|
||||
SHA256 (arakiken-mlterm-3.9.3_GH0.tar.gz) = b5b76721391de134bd64afb7de6b4256805cf2fc883a2bf2e5d29602ac1b50d9
|
||||
SIZE (arakiken-mlterm-3.9.3_GH0.tar.gz) = 4272090
|
||||
TIMESTAMP = 1743312749
|
||||
SHA256 (arakiken-mlterm-3.9.4_GH0.tar.gz) = 171de4c4f3443bc1211cc51df5caa0e082ffcdd33ab3ce261bc0a4cfe85d9b5e
|
||||
SIZE (arakiken-mlterm-3.9.4_GH0.tar.gz) = 4227568
|
||||
|
|
|
@ -1,46 +0,0 @@
|
|||
--- gtk/vte.c.orig 2023-04-01 13:54:40 UTC
|
||||
+++ gtk/vte.c
|
||||
@@ -1327,8 +1327,8 @@ static void init_screen(VteTerminal *terminal, ui_font
|
||||
|
||||
PVT(terminal)->screen->xterm_listener.set_window_name = set_window_name;
|
||||
PVT(terminal)->screen->xterm_listener.set_icon_name = set_icon_name;
|
||||
- PVT(terminal)->xterm_resize = PVT(terminal)->screen->xterm_listener.resize;
|
||||
- PVT(terminal)->screen->xterm_listener.resize = xterm_resize;
|
||||
+ PVT(terminal)->xterm_resize = (void (*)(void *, u_int, u_int, int))PVT(terminal)->screen->xterm_listener.resize;
|
||||
+ PVT(terminal)->screen->xterm_listener.resize = (void (*)(void *, u_int, u_int, int, int))xterm_resize;
|
||||
|
||||
orig_select_in_window = PVT(terminal)->screen->sel_listener.select_in_window;
|
||||
PVT(terminal)->screen->sel_listener.select_in_window = select_in_window;
|
||||
@@ -3369,19 +3369,19 @@ void vte_terminal_set_color_dim_rgba(VteTerminal *term
|
||||
|
||||
#if GTK_CHECK_VERSION(2, 99, 0)
|
||||
void vte_terminal_set_color_bold_rgba(VteTerminal *terminal, const GdkRGBA *bold) {
|
||||
- set_color_bold(terminal, bold, gdk_rgba_to_string2);
|
||||
+ set_color_bold(terminal, bold, (gchar *(*)(const void *))gdk_rgba_to_string2);
|
||||
}
|
||||
|
||||
void vte_terminal_set_color_foreground_rgba(VteTerminal *terminal, const GdkRGBA *foreground) {
|
||||
- set_color_foreground(terminal, foreground, gdk_rgba_to_string2);
|
||||
+ set_color_foreground(terminal, foreground, (gchar *(*)(const void *))gdk_rgba_to_string2);
|
||||
}
|
||||
|
||||
void vte_terminal_set_color_background_rgba(VteTerminal *terminal, const GdkRGBA *background) {
|
||||
- set_color_background(terminal, background, gdk_rgba_to_string2);
|
||||
+ set_color_background(terminal, background, (gchar *(*)(const void *))gdk_rgba_to_string2);
|
||||
}
|
||||
|
||||
void vte_terminal_set_color_cursor_rgba(VteTerminal *terminal, const GdkRGBA *cursor_background) {
|
||||
- set_color_cursor(terminal, cursor_background, gdk_rgba_to_string2);
|
||||
+ set_color_cursor(terminal, cursor_background, (gchar *(*)(const void *))gdk_rgba_to_string2);
|
||||
}
|
||||
|
||||
#if VTE_CHECK_VERSION(0, 44, 0)
|
||||
@@ -3418,7 +3418,7 @@ void vte_terminal_set_color_highlight_foreground_rgba(
|
||||
void vte_terminal_set_colors_rgba(VteTerminal *terminal, const GdkRGBA *foreground,
|
||||
const GdkRGBA *background, const GdkRGBA *palette,
|
||||
gsize palette_size) {
|
||||
- if (set_colors(terminal, palette, palette_size, sizeof(GdkRGBA), gdk_rgba_to_string2) &&
|
||||
+ if (set_colors(terminal, palette, palette_size, sizeof(GdkRGBA), (gchar *(*)(const char *))gdk_rgba_to_string2) &&
|
||||
palette_size > 0) {
|
||||
if (foreground == NULL) {
|
||||
foreground = &palette[7];
|
|
@ -1,26 +0,0 @@
|
|||
--- tool/mlconfig/Makefile.in.orig 2023-04-01 13:54:40 UTC
|
||||
+++ tool/mlconfig/Makefile.in
|
||||
@@ -70,19 +70,19 @@ mlconfig: $(OBJ)
|
||||
$(LIBTOOL_LINK) $(OBJ) $(CFLAGS) -o mlconfig $(LIBS)
|
||||
# "cd po" must be enclosed by () because it may not return
|
||||
# to the $(top_builddir)/tool/mlconfig at the next line.
|
||||
- if test -d po/Makefile; then (cd po ; $(MAKE) update-gmo); fi
|
||||
- # if test -d po/Makefile; then cd po ; $(MAKE) update-po; fi
|
||||
+ if test -f po/Makefile; then (cd po ; $(MAKE) update-gmo); fi
|
||||
+ # if test -f po/Makefile; then cd po ; $(MAKE) update-po; fi
|
||||
|
||||
.c.o:
|
||||
$(CC) $(DEFS) $(CFLAGS) -c $<
|
||||
|
||||
install: $(LIBEXECDIR@WIN32TAG@)
|
||||
$(LIBTOOL_INSTALL) -m 755 mlconfig $(LIBEXECDIR@WIN32TAG@)
|
||||
- if test -d po/Makefile; then (cd po ; $(MAKE) install); fi
|
||||
+ if test -f po/Makefile; then (cd po ; $(MAKE) install); fi
|
||||
|
||||
uninstall:
|
||||
rm -f $(LIBEXECDIR@WIN32TAG@)/mlconfig
|
||||
- if test -d po/Makefile; then (cd po ; $(MAKE) uninstall); fi
|
||||
+ if test -f po/Makefile; then (cd po ; $(MAKE) uninstall); fi
|
||||
|
||||
$(LIBEXECDIR@WIN32TAG@):
|
||||
mkdir -p $(LIBEXECDIR@WIN32TAG@)
|
|
@ -1,10 +0,0 @@
|
|||
--- tool/w3mmlconfig/mlconfig.cgi.in.orig 2017-01-07 22:24:38 UTC
|
||||
+++ tool/w3mmlconfig/mlconfig.cgi.in
|
||||
@@ -2,6 +2,7 @@
|
||||
|
||||
$DEBUG = 1;
|
||||
|
||||
+use lib '@CGI_BIN@';
|
||||
require 'mlconfig-data.pl';
|
||||
|
||||
open(CHALLENGE, "$ENV{HOME}/.mlterm/challenge");
|
|
@ -1,11 +0,0 @@
|
|||
--- uitoolkit/libtype/ui_window_cairo.c.orig 2023-07-01 12:37:30 UTC
|
||||
+++ uitoolkit/libtype/ui_window_cairo.c
|
||||
@@ -54,7 +54,7 @@ static void adjust_glyphs(ui_font_t *font, cairo_glyph
|
||||
|
||||
static void flush_glyphs(cairo_t *cr) {
|
||||
if (num_glyph_buf > 0) {
|
||||
- u_long pixel = cairo_get_user_data(cr, (cairo_user_data_key_t*)2);
|
||||
+ u_long pixel = (u_long)cairo_get_user_data(cr, (cairo_user_data_key_t*)2);
|
||||
|
||||
cairo_set_scaled_font(cr, cairo_get_user_data(cr, (cairo_user_data_key_t*)1));
|
||||
cairo_set_source_rgba(cr,
|
Loading…
Add table
Reference in a new issue