security/highwayhash: update g20201021 → g20240418

This commit is contained in:
Yuri Victorovich 2025-01-24 01:10:18 -08:00
parent 070dc535d7
commit ed60b91744
4 changed files with 7 additions and 31 deletions

View file

@ -1,6 +1,5 @@
PORTNAME= highwayhash
PORTVERSION= g20201021
PORTREVISION= 1
PORTVERSION= g20240418
PORTEPOCH= 1
CATEGORIES= security
@ -15,10 +14,11 @@ ONLY_FOR_ARCHS= aarch64 amd64 powerpc powerpc64 powerpc64le
ONLY_FOR_ARCHS_REASON= assembly is implemented only for specific architectures in highwayhash/tsc_timer.h
USES= compiler:c++11-lang gmake
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= google
GH_TAGNAME= bdd572de8cfa3a1fbef6ba32307c2629db7c4773
USE_LDCONFIG= yes
GH_TAGNAME= f8381f3
.include <bsd.port.options.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1605342604
SHA256 (google-highwayhash-g20201021-bdd572de8cfa3a1fbef6ba32307c2629db7c4773_GH0.tar.gz) = ebe6fe710f2a4a9417410773a1aeb8e750b036d4843e457054e6209c1fd0b043
SIZE (google-highwayhash-g20201021-bdd572de8cfa3a1fbef6ba32307c2629db7c4773_GH0.tar.gz) = 160264
TIMESTAMP = 1737709612
SHA256 (google-highwayhash-g20240418-f8381f3_GH0.tar.gz) = 015923a26684672d6ae736b0a2d185a313714460ebd314dd505ef609a23bccb1
SIZE (google-highwayhash-g20240418-f8381f3_GH0.tar.gz) = 162190

View file

@ -1,12 +0,0 @@
--- highwayhash/arch_specific.cc.orig 2020-09-22 06:18:43 UTC
+++ highwayhash/arch_specific.cc
@@ -24,8 +24,8 @@
#if __GLIBC__
#include <sys/platform/ppc.h> // __ppc_get_timebase_freq
#elif __FreeBSD__
-#include <sys/sysctl.h>
#include <sys/types.h>
+#include <sys/sysctl.h>
#endif
#endif

View file

@ -1,12 +0,0 @@
--- highwayhash/os_specific.cc.orig 2020-11-29 23:19:18 UTC
+++ highwayhash/os_specific.cc
@@ -53,8 +53,8 @@
#ifdef __FreeBSD__
#define OS_FREEBSD 1
-#include <sys/cpuset.h>
#include <sys/param.h>
+#include <sys/cpuset.h>
#include <unistd.h>
#else
#define OS_FREEBSD 0