math/libformfactor: update 0.1.3 → 0.3.1

This commit is contained in:
Yuri Victorovich 2025-01-19 17:42:35 -08:00
parent 44f5d1bc22
commit ecfef56477
4 changed files with 17 additions and 13 deletions

View file

@ -1,5 +1,5 @@
PORTNAME= libformfactor PORTNAME= libformfactor
DISTVERSION= 0.1.3 DISTVERSION= 0.3.1
CATEGORIES= math CATEGORIES= math
MASTER_SITES= https://jugit.fz-juelich.de/mlz/libformfactor/-/archive/v${DISTVERSION}/ MASTER_SITES= https://jugit.fz-juelich.de/mlz/libformfactor/-/archive/v${DISTVERSION}/
DISTNAME= ${PORTNAME}-v${DISTVERSION} DISTNAME= ${PORTNAME}-v${DISTVERSION}
@ -13,10 +13,12 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= libheinz>0:devel/libheinz BUILD_DEPENDS= libheinz>0:devel/libheinz
USES= cmake:testing USES= compiler:c++20-lang cmake:testing
USE_LDCONFIG= yes USE_LDCONFIG= yes
CMAKE_OFF= BUILD_TESTING CMAKE_OFF= BUILD_TESTING
CMAKE_TESTING_ON= BUILD_TESTING CMAKE_TESTING_ON= BUILD_TESTING
# tests as of 0.3.1: 100% tests passed, 0 tests failed out of 18
.include <bsd.port.mk> .include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1674545116 TIMESTAMP = 1737283223
SHA256 (libformfactor-v0.1.3.tar.gz) = 933f1f0e4f0c7e4c5e14994d1550d242070ad09f9315e0548dd874cecba66032 SHA256 (libformfactor-v0.3.1.tar.gz) = bd03cf8dc77c87116d89932f923e7592e59edecb1bab520a188644198bfe0d68
SIZE (libformfactor-v0.1.3.tar.gz) = 141200 SIZE (libformfactor-v0.3.1.tar.gz) = 317693

View file

@ -1,9 +1,9 @@
--- CMakeLists.txt.orig 2023-01-24 07:39:32 UTC --- CMakeLists.txt.orig 2023-08-02 16:06:12 UTC
+++ CMakeLists.txt +++ CMakeLists.txt
@@ -42,7 +42,9 @@ message(STATUS "LibHeinz: found=${LibHeinz_FOUND}, inc @@ -62,7 +62,9 @@ include(CTest)
include(CTest) ## Tests.
add_subdirectory(ff) include(CTest)
+if (BUILD_TESTING) +if (BUILD_TESTING)
add_subdirectory(test) add_subdirectory(test)
+endif() +endif()

View file

@ -2,10 +2,12 @@ cmake/formfactorConfig.cmake
cmake/formfactorConfigVersion.cmake cmake/formfactorConfigVersion.cmake
cmake/formfactorTargets-%%CMAKE_BUILD_TYPE%%.cmake cmake/formfactorTargets-%%CMAKE_BUILD_TYPE%%.cmake
cmake/formfactorTargets.cmake cmake/formfactorTargets.cmake
include/ff/Platonic.h include/ff/Box.h
include/ff/PolyhedralComponents.h include/ff/Face.h
include/ff/PolyhedralTopology.h include/ff/IBody.h
include/ff/Make.h
include/ff/Polyhedron.h include/ff/Polyhedron.h
include/ff/Prism.h include/ff/Prism.h
include/ff/Topology.h
lib/libformfactor.so lib/libformfactor.so
lib/libformfactor.so.0.1.3 lib/libformfactor.so.0.3.1