mirror of
https://git.freebsd.org/ports.git
synced 2025-05-29 17:36:28 -04:00
Update to 0.3
This commit is contained in:
parent
a3454389d0
commit
ec2b0b5af9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=54792
9 changed files with 56 additions and 24 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= gkrellmlaunch
|
||||
PORTVERSION= 0.2.2
|
||||
PORTVERSION= 0.3
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (gkrellmlaunch-0.2.2.tar.gz) = de4708016f707f98969c6236e10b6763
|
||||
MD5 (gkrellmlaunch-0.3.tar.gz) = dc2ba470c8f9d610469aef74118f7404
|
||||
|
|
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= gkrellmlaunch
|
||||
PORTVERSION= 0.2.2
|
||||
PORTVERSION= 0.3
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (gkrellmlaunch-0.2.2.tar.gz) = de4708016f707f98969c6236e10b6763
|
||||
MD5 (gkrellmlaunch-0.3.tar.gz) = dc2ba470c8f9d610469aef74118f7404
|
||||
|
|
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= wmcliphist
|
||||
PORTVERSION= 0.2
|
||||
PORTVERSION= 0.3
|
||||
CATEGORIES= x11 windowmaker
|
||||
MASTER_SITES= http://linux.nawebu.cz/wmcliphist/
|
||||
|
||||
|
@ -18,10 +18,14 @@ USE_GTK= yes
|
|||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
|
||||
@${MKDIR} ${EXAMPLESDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/.wmcliphistrc ${EXAMPLESDIR}
|
||||
.ifndef(NOPORTDOCS)
|
||||
@${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} -m ${SHAREMODE} \
|
||||
${PREFIX}/share/doc/${PORTNAME}
|
||||
@${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/${PORTNAME}
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
|
||||
.endif #NOPORTDOCS
|
||||
|
||||
post-install:
|
||||
@${SED} 's|%%EXAMPLESDIR%%|${EXAMPLESDIR}|' ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (wmcliphist-0.2.tar.gz) = d8d7d6ec26e958c95651c7dd9c7b5d07
|
||||
MD5 (wmcliphist-0.3.tar.gz) = e3f4cf211a25c0b2ed31a588f81b8d6c
|
||||
|
|
|
@ -1,20 +1,37 @@
|
|||
--- Makefile.orig Tue Mar 20 20:27:15 2001
|
||||
+++ Makefile Fri Jul 27 16:59:05 2001
|
||||
@@ -1,13 +1,14 @@
|
||||
CC = gcc
|
||||
-CFLAGS = -Wall -g -ansi `gtk-config --cflags` -I. -Ifoodock
|
||||
-LFLAGS = `gtk-config --libs`
|
||||
+CFLAGS += -Wall `${GTK_CONFIG} --cflags` $(INCDIR)
|
||||
+LFLAGS = `${GTK_CONFIG} --libs`
|
||||
+INCDIR = -I. -Ifoodock -I${X11BASE}/include
|
||||
OBJECTS = wmcliphist.o
|
||||
TARGET = wmcliphist
|
||||
--- Makefile.orig Thu Dec 20 11:31:46 2001
|
||||
+++ Makefile Sat Feb 16 22:24:52 2002
|
||||
@@ -1,6 +1,4 @@
|
||||
-CC = gcc
|
||||
-
|
||||
-INCLUDES = `gtk-config --cflags` -I. -Ifoodock
|
||||
+INCLUDES = `${GTK_CONFIG} --cflags` -I. -Ifoodock
|
||||
|
||||
all: $(TARGET)
|
||||
# choose icon
|
||||
# for light background
|
||||
@@ -11,7 +9,7 @@
|
||||
#ICON_TYPE = 2
|
||||
|
||||
# for normal use
|
||||
-CFLAGS = -Wall -O2 -ansi -pedantic $(INCLUDES) -DICON_TYPE=$(ICON_TYPE)
|
||||
+CFLAGS += $(INCLUDES) -DICON_TYPE=$(ICON_TYPE)
|
||||
DEBUG =
|
||||
|
||||
# for debuggind purposes
|
||||
@@ -21,7 +19,7 @@
|
||||
#DEBUG = debug.o
|
||||
|
||||
|
||||
-LFLAGS = `gtk-config --libs`
|
||||
+LFLAGS = `${GTK_CONFIG} --libs`
|
||||
|
||||
|
||||
OBJECTS = wmcliphist.o clipboard.o gui.o rcconfig.o history.o hotkeys.o $(DEBUG)
|
||||
@@ -33,7 +31,7 @@
|
||||
lclint $(INCLUDES) +posixlib *.c >lclint.log
|
||||
|
||||
wmcliphist: $(OBJECTS) foodock/foodock.o
|
||||
- $(CC) $(LFLAGS) -o $@ $(OBJECTS) foodock/foodock.o
|
||||
+ $(CC) $(CFLAGS) $(LFLAGS) -o $@ $(OBJECTS) foodock.o
|
||||
|
||||
wmcliphist.o: wmcliphist.c icon.xpm foodock/foodock.h
|
||||
+ $(CC) $(LFLAGS) -o $@ $(OBJECTS) foodock.o
|
||||
|
||||
wmcliphist.o: wmcliphist.c wmcliphist.h icon/wmcliphist_ico_mask.xbm \
|
||||
icon/wmcliphist_ico_dark.xpm icon/wmcliphist_ico_mid.xpm \
|
||||
|
|
9
x11/wmcliphist/pkg-message
Normal file
9
x11/wmcliphist/pkg-message
Normal file
|
@ -0,0 +1,9 @@
|
|||
|
||||
---------------------------------------------------------------------
|
||||
Before using this program, edit
|
||||
|
||||
%%EXAMPLESDIR%%/.wmcliphistrc
|
||||
|
||||
and copy to your home directory.
|
||||
---------------------------------------------------------------------
|
||||
|
|
@ -1,3 +1,5 @@
|
|||
bin/wmcliphist
|
||||
share/examples/wmcliphist/.wmcliphistrc
|
||||
%%PORTDOCS%%share/doc/wmcliphist/README
|
||||
@dirrm share/examples/wmcliphist
|
||||
%%PORTDOCS%%@dirrm share/doc/wmcliphist
|
||||
|
|
Loading…
Add table
Reference in a new issue