Try to unbreak on 4.x.

Based on:	hrs's patch
This commit is contained in:
Jun Kuriyama 2004-05-03 05:12:46 +00:00
parent 0ce4352124
commit eb1767a0a8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=108242
2 changed files with 20 additions and 1 deletions

View file

@ -7,6 +7,7 @@
PORTNAME= XML-AutoWriter
PORTVERSION= 0.38
PORTREVISION= 1
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= XML
@ -23,4 +24,10 @@ MAN3= XML::AutoWriter.3 \
XML::Doctype::ElementDecl.3 \
XML::Doctype.3
.include <bsd.port.mk>
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
RUN_DEPENDS= ${SITE_PERL}/fields.pm:${PORTSDIR}/devel/p5-base
.endif
.include <bsd.port.post.mk>

View file

@ -0,0 +1,12 @@
--- lib/XML/Doctype.pm.orig Mon May 3 13:57:15 2004
+++ lib/XML/Doctype.pm Mon May 3 14:04:55 2004
@@ -62,7 +62,9 @@
=cut
use strict ;
+use Config;
use vars qw( $VERSION %_default_dtds ) ;
+use lib $Config{sitelib};
use fields (
'ELTS', # A hash of declared & undeclared elements, keyed by name
'NAME', # The root node (the name from the DOCTYPE decl).