mirror of
https://git.freebsd.org/ports.git
synced 2025-05-24 23:16:33 -04:00
- Update to version 1.6.1, bugfix and translations release
- Patch things with sed(1) during `post-patch' instead of `pre-patch' - Fix Lua detection properly (patch corresponding pkg-config(1) calls) - Offload CONFIGURE_ENV, add work-around for Gentoo bug #316573 (some messages were misplaced on systems where char is unsigned by default, e.g. PowerPC) - Allow add-ons to be placed inside user's home directory - Drop explicit USE_XORG, improve on comments, do some minor cleanups
This commit is contained in:
parent
858769f75e
commit
ead9c4b39b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=278286
4 changed files with 57 additions and 26 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= celestia
|
||||
PORTVERSION= 1.6.0
|
||||
PORTREVISION= 4
|
||||
PORTVERSION= 1.6.1
|
||||
CATEGORIES= astro
|
||||
MASTER_SITES= SF/${PORTNAME}/Celestia-source/${PORTVERSION}
|
||||
PKGNAMESUFFIX= -${CELESTIA_UI}
|
||||
|
@ -22,13 +21,14 @@ LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
|
|||
|
||||
USE_AUTOTOOLS= libtool
|
||||
USE_GMAKE= yes
|
||||
USE_GL= gl
|
||||
USE_XORG= x11 xt xext xmu xi
|
||||
USE_GETTEXT= yes
|
||||
USE_GL= gl
|
||||
USE_LUA= 5.0+ # should be optional, but the build fails without it
|
||||
WANT_GNOME= yes
|
||||
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
|
||||
CXXFLAGS+= -fsigned-char # fix text rendering (see Gentoo bug 316573)
|
||||
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
|
||||
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
|
||||
|
||||
UI_LIST= glut gtk gnome kde
|
||||
CELESTIA_UI?= glut
|
||||
|
@ -88,15 +88,16 @@ PORTDOCS= AUTHORS ChangeLog README
|
|||
DESKTOP_ENTRIES="Celestia" "Explore space" "celestia.png" "celestia" \
|
||||
"Application;Astronomy;Education;Science;" ${STARTUP_NOTIFY}
|
||||
|
||||
# Lua support should be optional, but the build fails without it
|
||||
USE_LUA= 5.0+
|
||||
CONFIGURE_ARGS+= --with-lua LUA_CFLAGS=-I${LUA_INCDIR} \
|
||||
LUA_LIBS=-L${LUA_LIBDIR} LUALIB_LIBS=-llua
|
||||
|
||||
pre-patch:
|
||||
post-patch:
|
||||
# Fix Lua discovery pkg-config(1) calls
|
||||
@${REINPLACE_CMD} -E 's|lua5\.?|lua-5.|' ${WRKSRC}/configure
|
||||
# Remove controversial compiler options (respect our C[XX]FLAGS)
|
||||
.for o in O2 ffast-math fexpensive-optimizations fomit-frame-pointer
|
||||
@${REINPLACE_CMD} -e 's|-${o}||g' ${WRKSRC}/configure
|
||||
.endfor
|
||||
# Allow add-ons to be placed inside user's home directory
|
||||
@${REINPLACE_CMD} -e '/^#/!s|"extras"|& "~/.celestia"|' \
|
||||
${WRKSRC}/celestia.cfg
|
||||
# Inhibit installation of copies of GPL (lots of them; use LICENSE framework
|
||||
# instead) and remove bogus argument from mv(1)
|
||||
@${REINPLACE_CMD} -e 's|COPYING||g ; s| -b|| ' ${WRKSRC}/Makefile.in
|
||||
|
@ -108,7 +109,7 @@ pre-patch:
|
|||
post-install:
|
||||
# Technically, we should only install icon explicitly for GLUT UI, since
|
||||
# correct icons are properly installed for other cases, but doing it here
|
||||
# does not hurt and simplifies PLIST issues
|
||||
# does not hurt and simplifies PLIST handling
|
||||
${INSTALL_DATA} ${WRKSRC}/src/celestia/gtk/data/celestia.png \
|
||||
${PREFIX}/share/pixmaps
|
||||
.if !defined(NOPORTDOCS)
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (celestia-1.6.0.tar.gz) = 9d9785b651cb42b890765f97234eaed3b03bf5e07dfb1be4f123a27260cdbbd4
|
||||
SIZE (celestia-1.6.0.tar.gz) = 51848015
|
||||
SHA256 (celestia-1.6.1.tar.gz) = d35570ccb9440fc0bd3e73eb9b4c3e8a4c25f3ae444a13d1175053fa16dc34c4
|
||||
SIZE (celestia-1.6.1.tar.gz) = 52600436
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- src/celengine/image.cpp.orig 2009-06-22 17:44:08.000000000 +0200
|
||||
+++ src/celengine/image.cpp 2010-03-29 14:11:02.000000000 +0200
|
||||
@@ -737,7 +737,7 @@
|
||||
|
||||
if (color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8)
|
||||
{
|
||||
- png_set_gray_1_2_4_to_8(png_ptr);
|
||||
+ png_set_expand_gray_1_2_4_to_8(png_ptr);
|
||||
}
|
||||
|
||||
if (png_get_valid(png_ptr, info_ptr, PNG_INFO_tRNS))
|
|
@ -1,21 +1,26 @@
|
|||
bin/celestia
|
||||
share/celestia/celestia.cfg
|
||||
share/celestia/controls.txt
|
||||
share/celestia/controls_be.txt
|
||||
share/celestia/controls_bg.txt
|
||||
share/celestia/controls_de.txt
|
||||
share/celestia/controls_es.txt
|
||||
share/celestia/controls_fr.txt
|
||||
share/celestia/controls_gl.txt
|
||||
share/celestia/controls_it.txt
|
||||
share/celestia/controls_ja.txt
|
||||
share/celestia/controls_ko.txt
|
||||
share/celestia/controls_nl.txt
|
||||
share/celestia/controls_no.txt
|
||||
share/celestia/controls_pl.txt
|
||||
share/celestia/controls_pt.txt
|
||||
share/celestia/controls_pt_BR.txt
|
||||
share/celestia/controls_ru.txt
|
||||
share/celestia/controls_sk.txt
|
||||
share/celestia/controls_sv.txt
|
||||
share/celestia/controls_uk.txt
|
||||
share/celestia/controls_zh_CN.txt
|
||||
share/celestia/controls_zh_TW.txt
|
||||
share/celestia/data/asterisms.dat
|
||||
share/celestia/data/asteroids.ssc
|
||||
share/celestia/data/boundaries.dat
|
||||
|
@ -54,28 +59,37 @@ share/celestia/data/venus_locs.ssc
|
|||
share/celestia/data/visualbins.stc
|
||||
share/celestia/data/world-capitals.ssc
|
||||
share/celestia/demo.cel
|
||||
share/celestia/demo_be.cel
|
||||
share/celestia/demo_de.cel
|
||||
share/celestia/demo_es.cel
|
||||
share/celestia/demo_fr.cel
|
||||
share/celestia/demo_gl.cel
|
||||
share/celestia/demo_it.cel
|
||||
share/celestia/demo_ja.cel
|
||||
share/celestia/demo_ko.cel
|
||||
share/celestia/demo_lt.cel
|
||||
share/celestia/demo_lv.cel
|
||||
share/celestia/demo_nl.cel
|
||||
share/celestia/demo_no.cel
|
||||
share/celestia/demo_pl.cel
|
||||
share/celestia/demo_pt.cel
|
||||
share/celestia/demo_pt_BR.cel
|
||||
share/celestia/demo_ru.cel
|
||||
share/celestia/demo_sk.cel
|
||||
share/celestia/demo_sv.cel
|
||||
share/celestia/demo_tr.cel
|
||||
share/celestia/demo_uk.cel
|
||||
share/celestia/demo_zh_CN.cel
|
||||
share/celestia/demo_zh_TW.cel
|
||||
share/celestia/extras-standard/cassini/cassini.ssc
|
||||
share/celestia/extras-standard/cassini/data/cassini-cruise.xyzv
|
||||
share/celestia/extras-standard/cassini/data/cassini-orbit.xyzv
|
||||
share/celestia/extras-standard/cassini/data/cassini-solstice.xyzv
|
||||
share/celestia/extras-standard/cassini/data/huygens.xyzv
|
||||
share/celestia/extras-standard/cassini/models/cassini.3ds
|
||||
share/celestia/extras-standard/cassini/models/huygens.3ds
|
||||
share/celestia/extras-standard/galileo/data/galileo-cruise.xyzv
|
||||
share/celestia/extras-standard/galileo/data/galileo-orbit.xyzv
|
||||
share/celestia/extras-standard/galileo/galileo.ssc
|
||||
share/celestia/extras-standard/galileo/models/galileo.3ds
|
||||
share/celestia/extras-standard/hubble/hubble.ssc
|
||||
|
@ -138,34 +152,42 @@ share/celestia/fonts/helvbold18.txf
|
|||
share/celestia/fonts/helvbold24.txf
|
||||
share/celestia/fonts/sans10.txf
|
||||
share/celestia/fonts/sans12.txf
|
||||
share/celestia/fonts/sans12_be.txf
|
||||
share/celestia/fonts/sans12_bg.txf
|
||||
share/celestia/fonts/sans12_ja.txf
|
||||
share/celestia/fonts/sans12_ko.txf
|
||||
share/celestia/fonts/sans12_ru.txf
|
||||
share/celestia/fonts/sans12_uk.txf
|
||||
share/celestia/fonts/sans12_zh_CN.txf
|
||||
share/celestia/fonts/sans12_zh_TW.txf
|
||||
share/celestia/fonts/sans14.txf
|
||||
share/celestia/fonts/sans14_be.txf
|
||||
share/celestia/fonts/sans14_ja.txf
|
||||
share/celestia/fonts/sans14_ko.txf
|
||||
share/celestia/fonts/sans14_ru.txf
|
||||
share/celestia/fonts/sans14_uk.txf
|
||||
share/celestia/fonts/sans14_zh_CN.txf
|
||||
share/celestia/fonts/sans14_zh_TW.txf
|
||||
share/celestia/fonts/sans20.txf
|
||||
share/celestia/fonts/sansbold10.txf
|
||||
share/celestia/fonts/sansbold12.txf
|
||||
share/celestia/fonts/sansbold14.txf
|
||||
share/celestia/fonts/sansbold20.txf
|
||||
share/celestia/fonts/sansbold20_be.txf
|
||||
share/celestia/fonts/sansbold20_bg.txf
|
||||
share/celestia/fonts/sansbold20_ja.txf
|
||||
share/celestia/fonts/sansbold20_ko.txf
|
||||
share/celestia/fonts/sansbold20_ru.txf
|
||||
share/celestia/fonts/sansbold20_uk.txf
|
||||
share/celestia/fonts/sansbold20_zh_CN.txf
|
||||
share/celestia/fonts/sansbold20_zh_TW.txf
|
||||
share/celestia/guide.cel
|
||||
share/celestia/guide_be.cel
|
||||
share/celestia/guide_bg.cel
|
||||
share/celestia/guide_de.cel
|
||||
share/celestia/guide_es.cel
|
||||
share/celestia/guide_fr.cel
|
||||
share/celestia/guide_gl.cel
|
||||
share/celestia/guide_it.cel
|
||||
share/celestia/guide_ja.cel
|
||||
share/celestia/guide_ko.cel
|
||||
|
@ -175,9 +197,11 @@ share/celestia/guide_pl.cel
|
|||
share/celestia/guide_pt.cel
|
||||
share/celestia/guide_pt_BR.cel
|
||||
share/celestia/guide_ru.cel
|
||||
share/celestia/guide_sk.cel
|
||||
share/celestia/guide_sv.cel
|
||||
share/celestia/guide_uk.cel
|
||||
share/celestia/guide_zh_CN.cel
|
||||
share/celestia/guide_zh_TW.cel
|
||||
share/celestia/models/E0.png
|
||||
share/celestia/models/MilkyWay.png
|
||||
share/celestia/models/S0.png
|
||||
|
@ -297,10 +321,12 @@ share/celestia/shaders/texphong_arb.vp
|
|||
share/celestia/shaders/texphong_nv.fp
|
||||
share/celestia/splash/splash.png
|
||||
share/celestia/start.cel
|
||||
share/celestia/start_be.cel
|
||||
share/celestia/start_bg.cel
|
||||
share/celestia/start_de.cel
|
||||
share/celestia/start_es.cel
|
||||
share/celestia/start_fr.cel
|
||||
share/celestia/start_gl.cel
|
||||
share/celestia/start_hu.cel
|
||||
share/celestia/start_it.cel
|
||||
share/celestia/start_ja.cel
|
||||
|
@ -312,9 +338,11 @@ share/celestia/start_pl.cel
|
|||
share/celestia/start_pt.cel
|
||||
share/celestia/start_pt_BR.cel
|
||||
share/celestia/start_ru.cel
|
||||
share/celestia/start_sk.cel
|
||||
share/celestia/start_sv.cel
|
||||
share/celestia/start_uk.cel
|
||||
share/celestia/start_zh_CN.cel
|
||||
share/celestia/start_zh_TW.cel
|
||||
share/celestia/textures/flare.jpg
|
||||
share/celestia/textures/hires/dione.jpg
|
||||
share/celestia/textures/hires/enceladus.jpg
|
||||
|
@ -473,6 +501,8 @@ share/celestia/textures/medres/venuslikenight.jpg
|
|||
share/celestia/textures/medres/venussurface.jpg
|
||||
share/locale/ar/LC_MESSAGES/celestia.mo
|
||||
share/locale/ar/LC_MESSAGES/celestia_constellations.mo
|
||||
share/locale/be/LC_MESSAGES/celestia.mo
|
||||
share/locale/be/LC_MESSAGES/celestia_constellations.mo
|
||||
share/locale/bg/LC_MESSAGES/celestia.mo
|
||||
share/locale/bg/LC_MESSAGES/celestia_constellations.mo
|
||||
share/locale/de/LC_MESSAGES/celestia.mo
|
||||
|
@ -484,6 +514,8 @@ share/locale/es/LC_MESSAGES/celestia.mo
|
|||
share/locale/es/LC_MESSAGES/celestia_constellations.mo
|
||||
share/locale/fr/LC_MESSAGES/celestia.mo
|
||||
share/locale/fr/LC_MESSAGES/celestia_constellations.mo
|
||||
share/locale/gl/LC_MESSAGES/celestia.mo
|
||||
share/locale/gl/LC_MESSAGES/celestia_constellations.mo
|
||||
share/locale/hu/LC_MESSAGES/celestia.mo
|
||||
share/locale/hu/LC_MESSAGES/celestia_constellations.mo
|
||||
share/locale/it/LC_MESSAGES/celestia.mo
|
||||
|
@ -498,6 +530,8 @@ share/locale/lv/LC_MESSAGES/celestia.mo
|
|||
share/locale/lv/LC_MESSAGES/celestia_constellations.mo
|
||||
share/locale/nl/LC_MESSAGES/celestia.mo
|
||||
share/locale/nl/LC_MESSAGES/celestia_constellations.mo
|
||||
share/locale/no/LC_MESSAGES/celestia.mo
|
||||
share/locale/no/LC_MESSAGES/celestia_constellations.mo
|
||||
share/locale/pl/LC_MESSAGES/celestia.mo
|
||||
share/locale/pl/LC_MESSAGES/celestia_constellations.mo
|
||||
share/locale/pt/LC_MESSAGES/celestia.mo
|
||||
|
@ -508,12 +542,18 @@ share/locale/ro/LC_MESSAGES/celestia.mo
|
|||
share/locale/ro/LC_MESSAGES/celestia_constellations.mo
|
||||
share/locale/ru/LC_MESSAGES/celestia.mo
|
||||
share/locale/ru/LC_MESSAGES/celestia_constellations.mo
|
||||
share/locale/sk/LC_MESSAGES/celestia.mo
|
||||
share/locale/sk/LC_MESSAGES/celestia_constellations.mo
|
||||
share/locale/sv/LC_MESSAGES/celestia.mo
|
||||
share/locale/sv/LC_MESSAGES/celestia_constellations.mo
|
||||
share/locale/tr/LC_MESSAGES/celestia.mo
|
||||
share/locale/tr/LC_MESSAGES/celestia_constellations.mo
|
||||
share/locale/uk/LC_MESSAGES/celestia.mo
|
||||
share/locale/uk/LC_MESSAGES/celestia_constellations.mo
|
||||
share/locale/zh_CN/LC_MESSAGES/celestia.mo
|
||||
share/locale/zh_CN/LC_MESSAGES/celestia_constellations.mo
|
||||
share/locale/zh_TW/LC_MESSAGES/celestia.mo
|
||||
share/locale/zh_TW/LC_MESSAGES/celestia_constellations.mo
|
||||
share/pixmaps/celestia.png
|
||||
%%KDE%%share/applnk/Edutainment/Science/celestia.desktop
|
||||
%%KDE%%share/apps/celestia
|
||||
|
@ -589,6 +629,7 @@ share/pixmaps/celestia.png
|
|||
@dirrm share/celestia/extras-standard/hubble/models
|
||||
@dirrm share/celestia/extras-standard/hubble
|
||||
@dirrm share/celestia/extras-standard/galileo/models
|
||||
@dirrm share/celestia/extras-standard/galileo/data
|
||||
@dirrm share/celestia/extras-standard/galileo
|
||||
@dirrm share/celestia/extras-standard/cassini/models
|
||||
@dirrm share/celestia/extras-standard/cassini/data
|
||||
|
|
Loading…
Add table
Reference in a new issue