www/py-django52: New port, copied from www/py-django51

Django is a high-level Python Web framework that encourages rapid development
and clean, pragmatic design.

Developed and used over the past two years by a fast-moving online-news
operation, Django was designed from scratch to handle two challenges: the
intensive deadlines of a newsroom and the stringent requirements of experienced
Web developers. It has convenient niceties for developing content-management
systems, but it's an excellent tool for building any Web site.
This commit is contained in:
Wen Heping 2025-04-02 23:47:29 +00:00
parent 7c1a376484
commit e9dda1108f
5 changed files with 96 additions and 0 deletions

View file

@ -1666,6 +1666,7 @@
SUBDIR += py-django42 SUBDIR += py-django42
SUBDIR += py-django50 SUBDIR += py-django50
SUBDIR += py-django51 SUBDIR += py-django51
SUBDIR += py-django52
SUBDIR += py-django_compressor SUBDIR += py-django_compressor
SUBDIR += py-djangocms-admin-style SUBDIR += py-djangocms-admin-style
SUBDIR += py-djangoql SUBDIR += py-djangoql

73
www/py-django52/Makefile Normal file
View file

@ -0,0 +1,73 @@
PORTNAME= django
PORTVERSION= 5.2
CATEGORIES= www python
MASTER_SITES= PYPI \
https://media.djangoproject.com/releases/${PORTVERSION:R}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
PKGNAMESUFFIX= 52
DISTNAME= Django-${PORTVERSION}
DIST_SUBDIR= python
MAINTAINER= python@FreeBSD.org
COMMENT= High-level Python Web Framework
WWW= https://www.djangoproject.com/
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=61.0.0:devel/py-setuptools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asgiref>=3.8.1:www/py-asgiref@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sqlparse>=0.3.1:databases/py-sqlparse@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tblib>0:devel/py-tblib@${PY_FLAVOR}
USES= cpe python:3.10+ shebangfix
USE_PYTHON= autoplist pep517
NO_ARCH= yes
DOCSDIR= ${PREFIX}/share/doc/py-django
PLIST_FILES= share/man/man1/django-admin.1.gz
PORTDOCS= *
SHEBANG_FILES= django/conf/project_template/manage.py-tpl
CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}django[0-9][0-9]
CPE_VENDOR= djangoproject
# Upstream archive contains files with UTF-8 names
# EXTRACT_CMD= ${SETENV} LC_ALL=en_US.UTF-8 /usr/bin/bsdtar
OPTIONS_DEFINE= DOCS HTMLDOCS
OPTIONS_GROUP= DATABASE
OPTIONS_GROUP_DATABASE= PGSQL MYSQL SQLITE
OPTIONS_DEFAULT=SQLITE
HTMLDOCS_DESC= Install HTML documentation (requires Sphinx)
HTMLDOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=0,1:textproc/py-sphinx@${PY_FLAVOR}
HTMLDOCS_IMPLIES= DOCS
HTMLDOCS_USES= gmake
PGSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psycopg2>0:databases/py-psycopg2@${PY_FLAVOR}
MYSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mysqlclient>=1.3.13:databases/py-mysqlclient@${PY_FLAVOR}
SQLITE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
.include <bsd.port.pre.mk>
post-build-HTMLDOCS-on:
cd ${WRKSRC}/docs && ${MAKE_CMD} html SPHINXBUILD=sphinx-build-${PYTHON_VER}
post-install:
${INSTALL_MAN} ${WRKSRC}/docs/man/* ${STAGEDIR}/${PREFIX}/share/man/man1
@${ECHO_MSG} ""
@${ECHO_MSG} " * See http://docs.djangoproject.com/ for complete documentation"
@${ECHO_MSG} ""
post-install-HTMLDOCS-on:
${MKDIR} ${STAGEDIR}/${DOCSDIR}
${CP} -R ${WRKSRC}/docs/_build/html ${STAGEDIR}/${DOCSDIR}
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} tests/runtests.py --settings=test_sqlite
.include <bsd.port.post.mk>

3
www/py-django52/distinfo Normal file
View file

@ -0,0 +1,3 @@
TIMESTAMP = 1743637018
SHA256 (python/Django-5.2.tar.gz) = 1a47f7a7a3d43ce64570d350e008d2949abe8c7e21737b351b6a1611277c6d89
SIZE (python/Django-5.2.tar.gz) = 10824891

View file

@ -0,0 +1,11 @@
--- pyproject.toml.orig 2024-07-30 23:02:39 UTC
+++ pyproject.toml
@@ -3,7 +3,7 @@ build-backend = "setuptools.build_meta"
build-backend = "setuptools.build_meta"
[project]
-name = "Django"
+name = "django"
dynamic = ["version"]
requires-python = ">= 3.10"
dependencies = [

View file

@ -0,0 +1,8 @@
Django is a high-level Python Web framework that encourages rapid development
and clean, pragmatic design.
Developed and used over the past two years by a fast-moving online-news
operation, Django was designed from scratch to handle two challenges: the
intensive deadlines of a newsroom and the stringent requirements of experienced
Web developers. It has convenient niceties for developing content-management
systems, but it's an excellent tool for building any Web site.