mirror of
https://git.freebsd.org/ports.git
synced 2025-05-24 23:16:33 -04:00
Do not let system make.conf inpact the port's makefile
This fixes build on current
This commit is contained in:
parent
48606d8811
commit
e71de09d6d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=318993
11 changed files with 26 additions and 32 deletions
|
@ -13,6 +13,7 @@ USE_LDCONFIG= yes
|
|||
|
||||
SRCFILE= ${WRKSRC}/listcab.cpp
|
||||
PROGFILE= ${SRCFILE:S/.cpp$//}
|
||||
MAKE_ENV= WITHOUT_PROFILE=yes __MAKE_CONF=/dev/null SRCCONF=/dev/null
|
||||
|
||||
post-build:
|
||||
${CXX} ${CXXFLAGS} -o ${PROGFILE} ${SRCFILE} -L${WRKSRC} -lcabinet
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
--- Makefile.orig Tue Aug 19 18:15:11 2003
|
||||
+++ Makefile Tue Aug 19 18:33:06 2003
|
||||
@@ -0,0 +1,16 @@
|
||||
+NOPROFILE= true
|
||||
+NO_PROFILE= true
|
||||
+CXXFLAGS+= -Wno-deprecated
|
||||
+LIB= cabinet
|
||||
+LIBDIR= ${PREFIX}/lib
|
||||
|
|
|
@ -1,9 +1,5 @@
|
|||
# New ports collection makefile for: libpdel
|
||||
# Date created: 22 Apr 2002
|
||||
# Whom: Archie Cobbs
|
||||
#
|
||||
# Created by: Archie Cobbs
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= libpdel
|
||||
PORTVERSION= 0.5.3
|
||||
|
@ -15,6 +11,7 @@ MAINTAINER= mav@alkar.net
|
|||
COMMENT= Packet Design multi-purpose C library for embedded applications
|
||||
|
||||
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
|
||||
MAKE_ENV= WITHOUT_PROFILE=yes __MAKE_CONF=/dev/null SRCCONF=/dev/null
|
||||
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
|
|
|
@ -12,9 +12,12 @@ COMMENT= A memory allocation library with error checking
|
|||
|
||||
MAKEFILE= ${FILESDIR}/Makefile.lib
|
||||
USE_LDCONFIG= yes
|
||||
MAKE_ENV= WITHOUT_PROFILE=yes __MAKE_CONF=/dev/null SRCCONF=/dev/null
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/CREDITS ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
|
||||
|
|
|
@ -1,9 +1,5 @@
|
|||
# New ports collection makefile for: libstocks
|
||||
# Date created: this 7th day of January, 2002
|
||||
# Whom: Mikhail Teterin
|
||||
#
|
||||
# Created by: Mikhail Teterin
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= libstocks
|
||||
PORTVERSION= 0.5.0
|
||||
|
@ -15,6 +11,7 @@ COMMENT= A C library which can be used to fetch stocks quotes
|
|||
|
||||
USE_LDCONFIG= yes
|
||||
REINPLACE_ARGS= -i ""
|
||||
MAKE_ENV= WITHOUT_PROFILE=yes __MAKE_CONF=/dev/null SRCCONF=/dev/null
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's/<malloc.h>/<stdlib.h>/' \
|
||||
|
|
|
@ -1,9 +1,5 @@
|
|||
# New ports collection makefile for: libshhcards
|
||||
# Date created: 12 April 1998
|
||||
# Whom: Andrey Zakhvatov
|
||||
#
|
||||
# Created by: Andrey Zakhvatov
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= libshhcards
|
||||
PORTVERSION= 1.0.5
|
||||
|
@ -18,9 +14,12 @@ COMMENT= Library for displaying game cards on X Window System
|
|||
USE_XORG= xpm
|
||||
MAKEFILE= ${FILESDIR}/Makefile.lib
|
||||
USE_LDCONFIG= yes
|
||||
MAKE_ENV= WITHOUT_PROFILE=yes __MAKE_CONF=/dev/null SRCCONF=/dev/null
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/CREDITS ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
|
||||
|
|
|
@ -5,7 +5,7 @@ LIB= shhcards
|
|||
LIBDIR= ${PREFIX}/lib
|
||||
SHLIB_MAJOR= ${SHLIB_VER}
|
||||
SHLIB_MINOR= 0
|
||||
NOPROFILE= yes
|
||||
NO_PROFILE= yes
|
||||
NOOBJ= yes
|
||||
|
||||
INCS= shhcards.h
|
||||
|
|
|
@ -17,9 +17,10 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
|
|||
CONFLICTS= ming-*
|
||||
|
||||
WRKSRC= ${WRKDIR}/jaming-${PORTVERSION}/src
|
||||
MAKE_ARGS= NOPROFILE=true
|
||||
MAKE_ARGS= NO_PROFILE=true
|
||||
USE_LDCONFIG= yes
|
||||
USES= bison
|
||||
MAKE_ENV= WITHOUT_PROFILE=yes __MAKE_CONF=/dev/null SRCCONF=/dev/null
|
||||
|
||||
UTILS= gif2dbl \
|
||||
gif2mask \
|
||||
|
|
|
@ -1,9 +1,5 @@
|
|||
# New ports collection makefile for: linpack
|
||||
# Date created: 31 October 1994
|
||||
# Whom: ljo
|
||||
#
|
||||
# Created by: ljo
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= linpack
|
||||
PORTVERSION= 1.0
|
||||
|
@ -16,6 +12,7 @@ MAINTAINER= bf@FreeBSD.org
|
|||
COMMENT= Linear Algebra package
|
||||
|
||||
LIB_DEPENDS= blas.2:${PORTSDIR}/math/blas
|
||||
MAKE_ENV= WITHOUT_PROFILE=yes __MAKE_CONF=/dev/null SRCCONF=/dev/null
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
|
|
|
@ -1,9 +1,5 @@
|
|||
# New ports collection makefile for: libcgic
|
||||
# Date created: 27 July 1999
|
||||
# Whom: Andrey Zakhvatov
|
||||
#
|
||||
# Created by: Andrey Zakhvatov
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= cgic
|
||||
PORTVERSION= 2.05
|
||||
|
@ -18,11 +14,14 @@ MAKE_ENV= SHLIB_MAJOR="${SHLIB_MAJOR}"
|
|||
MAKEFILE= ${FILESDIR}/Makefile.lib
|
||||
PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
|
||||
USE_LDCONFIG= yes
|
||||
MAKE_ENV= WITHOUT_PROFILE=yes __MAKE_CONF=/dev/null SRCCONF=/dev/null
|
||||
|
||||
SHLIB_MAJOR= ${PORTVERSION:R}
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/*.html ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
LIB= cgic
|
||||
|
||||
SHLIB_MAJOR?= 1
|
||||
NOPROFILE= yes
|
||||
NO_PROFILE= yes
|
||||
|
||||
LIBDIR= ${PREFIX}/lib
|
||||
INCDIR= ${PREFIX}/include
|
||||
|
|
Loading…
Add table
Reference in a new issue