mirror of
https://git.freebsd.org/ports.git
synced 2025-05-12 23:31:50 -04:00
textproc/py-sphinxcontrib-autoprogram: Update to 0.1.9
- Use pep517 - Add pep420 changes - Directly run tests via unittest - Directly builds docs via sphinx-build ChangeLog: https://github.com/sphinx-contrib/autoprogram/releases/tag/0.1.9 PR: 277749
This commit is contained in:
parent
c2466b5658
commit
e60672e6af
3 changed files with 44 additions and 13 deletions
|
@ -1,5 +1,5 @@
|
||||||
PORTNAME= sphinxcontrib-autoprogram
|
PORTNAME= sphinxcontrib-autoprogram
|
||||||
DISTVERSION= 0.1.8
|
DISTVERSION= 0.1.9
|
||||||
CATEGORIES= textproc
|
CATEGORIES= textproc
|
||||||
MASTER_SITES= PYPI
|
MASTER_SITES= PYPI
|
||||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||||
|
@ -10,28 +10,38 @@ WWW= https://github.com/sphinx-contrib/autoprogram
|
||||||
|
|
||||||
LICENSE= BSD2CLAUSE
|
LICENSE= BSD2CLAUSE
|
||||||
|
|
||||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
|
BUILD_DEPENDS= ${PY_SETUPTOOLS} \
|
||||||
${PYTHON_PKGNAMEPREFIX}sphinx>=1.2,1:textproc/py-sphinx@${PY_FLAVOR}
|
${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
|
||||||
|
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=1.2,1:textproc/py-sphinx@${PY_FLAVOR}
|
||||||
|
|
||||||
USES= python
|
USES= python
|
||||||
USE_PYTHON= autoplist concurrent distutils
|
USE_PYTHON= autoplist concurrent pep517
|
||||||
|
|
||||||
NO_ARCH= yes
|
NO_ARCH= yes
|
||||||
|
|
||||||
OPTIONS_DEFINE= DOCS
|
OPTIONS_DEFINE= DOCS
|
||||||
|
|
||||||
DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
|
DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=1.2,1:textproc/py-sphinx@${PY_FLAVOR}
|
||||||
${PYTHON_PKGNAMEPREFIX}sphinx>=1.2,1:textproc/py-sphinx@${PY_FLAVOR}
|
|
||||||
DOCS_PORTDOCS= *
|
DOCS_PORTDOCS= *
|
||||||
DOCS_VARS= PYDISTUTILS_BUILD_TARGET=build_sphinx \
|
|
||||||
PYDISTUTILS_BUILDARGS="-n --all-files --fresh-env"
|
post-extract:
|
||||||
|
@(cd ${BUILD_WRKSRC}; ${RM} sphinxcontrib/__init__.py;)
|
||||||
|
|
||||||
|
pre-build-DOCS-on:
|
||||||
|
@(cd ${BUILD_WRKSRC}; \
|
||||||
|
${SETENVI} ${WRK_ENV} \
|
||||||
|
sphinx-build-${PYTHON_VER} \
|
||||||
|
-b html -d _build/doctress doc/ build/sphinx/html)
|
||||||
|
|
||||||
post-install-DOCS-on:
|
post-install-DOCS-on:
|
||||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||||
(cd ${WRKSRC}/build/sphinx/html && \
|
(cd ${WRKSRC}/build/sphinx/html && \
|
||||||
${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR} "! -name .buildinfo -and ! -name objects.inv")
|
${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR} \
|
||||||
|
"! -name .buildinfo -and ! -name objects.inv")
|
||||||
|
|
||||||
do-test:
|
do-test:
|
||||||
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
|
@cd ${WRKSRC} && \
|
||||||
|
${SETENV} ${MAKE_ENV} \
|
||||||
|
${PYTHON_CMD} -m unittest -v sphinxcontrib/autoprogram.py
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.include <bsd.port.mk>
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
TIMESTAMP = 1676784775
|
TIMESTAMP = 1710625404
|
||||||
SHA256 (sphinxcontrib-autoprogram-0.1.8.tar.gz) = 5a69729db9d283e0e4c6d349bd60e62a4b8ebd2c07c0ab634b82d08a4121f10a
|
SHA256 (sphinxcontrib-autoprogram-0.1.9.tar.gz) = 219655507fadca29b3062b5d86c37d94db48f03bde4b58d61526872bf72f57cc
|
||||||
SIZE (sphinxcontrib-autoprogram-0.1.8.tar.gz) = 18656
|
SIZE (sphinxcontrib-autoprogram-0.1.9.tar.gz) = 18843
|
||||||
|
|
21
textproc/py-sphinxcontrib-autoprogram/files/patch-setup.py
Normal file
21
textproc/py-sphinxcontrib-autoprogram/files/patch-setup.py
Normal file
|
@ -0,0 +1,21 @@
|
||||||
|
--- setup.py.orig 2024-04-07 02:53:48 UTC
|
||||||
|
+++ setup.py
|
||||||
|
@@ -3,7 +3,7 @@ from __future__ import with_statement
|
||||||
|
|
||||||
|
import sys
|
||||||
|
|
||||||
|
-from setuptools import setup, find_packages
|
||||||
|
+from setuptools import find_namespace_packages, setup, find_packages
|
||||||
|
|
||||||
|
|
||||||
|
# Do not change the variable name. It's parsed by doc/conf.py script.
|
||||||
|
@@ -49,8 +49,7 @@ setup(
|
||||||
|
],
|
||||||
|
python_requires='>=3.8',
|
||||||
|
platforms='any',
|
||||||
|
- packages=find_packages(),
|
||||||
|
- namespace_packages=['sphinxcontrib'],
|
||||||
|
+ packages=find_namespace_packages(include=['sphinxcontrib']),
|
||||||
|
include_package_data=True,
|
||||||
|
install_requires=requires,
|
||||||
|
test_suite='sphinxcontrib.autoprogram.suite'
|
Loading…
Add table
Reference in a new issue