net/ocserv: Do not check for Linux-style /proc filesystem

Otherwise it may fail to run when linprocfs is mounted
on /proc.

Reported by:	Ivan Brawley <ivan@brawley.id.au>
This commit is contained in:
Juraj Lutter 2025-01-03 22:33:10 +01:00
parent dbebb74d71
commit e52c0c3ca5
2 changed files with 14 additions and 5 deletions

View file

@ -1,6 +1,6 @@
PORTNAME= ocserv
DISTVERSION= 1.3.0
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= net net-vpn security
MASTER_SITES= https://www.infradead.org/ocserv/download/

View file

@ -1,6 +1,6 @@
--- configure.ac.orig 2023-12-14 11:45:13 UTC
--- configure.ac.orig 2024-05-05 19:06:59 UTC
+++ configure.ac
@@ -16,7 +16,7 @@ AM_PROG_CC_C_O
@@ -19,7 +19,7 @@ if test "$GCC" = "yes" && ! expr "$CC" : clang >/dev/n
AC_PROG_SED
if test "$GCC" = "yes" && ! expr "$CC" : clang >/dev/null 2>&1;then
@ -8,8 +8,8 @@
+ CFLAGS="$CFLAGS -Wall -Wno-strict-aliasing -Wextra -Wno-unused-parameter -Wno-sign-compare -Wno-missing-field-initializers"
fi
AC_PATH_PROG(CTAGS, ctags, [:])
@@ -219,7 +219,7 @@ if test "$test_for_geoip" = yes && test "$have_maxmind
AC_CHECK_PROGS([IPCALC], [ipcalc ipcalc-ng], [:])
@@ -231,7 +231,7 @@ have_readline=no
fi
have_readline=no
@ -18,3 +18,12 @@
#include <stdio.h>
#include <readline/readline.h>], [rl_replace_line(0,0);])
if test x$ac_cv_libreadline = xyes; then
@@ -675,8 +675,6 @@ AM_CONDITIONAL(ENABLE_OIDC_AUTH_TESTS, test "x$enable_
AM_CONDITIONAL(ENABLE_OIDC_AUTH, test "x$enable_oidc_auth" = xyes)
AM_CONDITIONAL(ENABLE_OIDC_AUTH_TESTS, test "x$enable_oidc_auth" = xyes)
-
-AC_CHECK_FILE(/proc/self/exe, AC_DEFINE([PROC_FS_SUPPORTED],[1], [procfs supported]), [])
uid=$(id -u)
gid=$(id -g)