irc/tircproxy: Remove expired port

2024-04-06 irc/tircproxy: Unmaintained, dead upstream, vaporized from the net
This commit is contained in:
Rene Ladan 2024-04-06 15:48:17 +02:00
parent 99d2952445
commit e3f43be3b6
9 changed files with 1 additions and 188 deletions

1
MOVED
View file

@ -3160,3 +3160,4 @@ graphics/liblug||2024-04-06|Has expired: SUNSITE is no longer maintained
misc/xgas||2024-04-06|Has expired: SUNSITE is no longer maintained
devel/dmucs||2024-04-06|Has expired: Unmaintained, upstream last release was in 2006
multimedia/mjpg-streamer||2024-04-06|Has expired: Unmaintained for a long time and does not work
irc/tircproxy||2024-04-06|Has expired: Unmaintained, dead upstream, vaporized from the net

View file

@ -91,7 +91,6 @@
SUBDIR += soju
SUBDIR += srain
SUBDIR += srvx
SUBDIR += tircproxy
SUBDIR += undernet-ircu
SUBDIR += unreal
SUBDIR += weechat

View file

@ -1,32 +0,0 @@
PORTNAME= tircproxy
PORTVERSION= 0.4.5
PORTREVISION= 4
CATEGORIES= irc
MASTER_SITES= http://bre.klaki.net/programs/tircproxy/
MAINTAINER= bofh@FreeBSD.org
COMMENT= IRC proxy server
DEPRECATED= Unmaintained, dead upstream, vaporized from the net
EXPIRATION_DATE=2024-04-06
GNU_CONFIGURE= YES
WRKSRC= ${WRKDIR}/tircproxy-0.4
OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=int-conversion
.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tircproxy ${STAGEDIR}${PREFIX}/sbin
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>

View file

@ -1,2 +0,0 @@
SHA256 (tircproxy-0.4.5.tar.gz) = 948e3f6797a35f80aedf85b1dd8ae1709741d90e88d53575206df6dd1182877d
SIZE (tircproxy-0.4.5.tar.gz) = 107447

View file

@ -1,26 +0,0 @@
--- Makefile.in Sat Oct 15 06:49:57 2005
+++ Makefile.in Sat Oct 15 06:50:00 2005
@@ -12,7 +12,7 @@
TARGETNAME=@sbindir@/tircproxy
STRIP=@STRIP@
-ALL_CFLAGS=-Wall -I. -I@srcdir@ $(CFLAGS)
+ALL_CFLAGS=-Wall -I. -I@srcdir@ $(CFLAGS) -I/sys -I/usr/src/sys
.SUFFIXES:
.SUFFIXES: .c .o
@@ -26,12 +26,12 @@
tircproxy.static: tircproxy.o
$(CC) $(LDFLAGS) -static -O3 tircproxy.o -o $@ $(LIBS)
strip $@
- pgp -sba $@ -u 3004
+# pgp -sba $@ -u 3004
manual:
@(cd docs; make all)
-all: tircproxy tircproxy.static documentation
+all: tircproxy tircproxy.static
install: tircproxy
$(INSTALL) -o bin -g bin -m 555 tircproxy $(TARGETNAME)

View file

@ -1,76 +0,0 @@
--- tircproxy.c.orig Thu May 4 22:53:30 2000
+++ tircproxy.c Sat Oct 15 07:02:11 2005
@@ -131,9 +131,16 @@
# include <netinet/ip_compat.h>
# endif
# include <netinet/ip_fil.h>
+# include <netinet/ip_nat.h>
+# include <netinet/ip_state.h>
# include <netinet/ip_proxy.h>
# include <netinet/ip_nat.h>
+# include <netinet/ipl.h>
+# include <osreldate.h>
# define TRANS 1
+# ifndef IPL_NAT
+# define IPL_NAT IPNAT_NAME
+# endif
# warning IPF transparent proxying available
# else
# undef IPF
@@ -1066,9 +1073,13 @@
struct sockaddr_in to_addr;
int to_len;
#if IPF
- struct sockaddr_in socketin, sloc;
- natlookup_t natlook;
- int fd;
+#if __FreeBSD_version >=600024
+ ipfobj_t obj;
+#endif
+ struct sockaddr_in socketin, sloc;
+ natlookup_t natlook;
+ natlookup_t *natlookp = &natlook;
+ int fd;
#endif
/* Give this thing 10 minutes to get started (paranoia).
@@ -1144,6 +1155,13 @@
exit(-1);
}
+#if __FreeBSD_version >=600024
+ bzero(&obj, sizeof(obj));
+ obj.ipfo_rev = IPFILTER_VERSION;
+ obj.ipfo_size = sizeof(natlook);
+ obj.ipfo_ptr = &natlook;
+ obj.ipfo_type = IPFOBJ_NATLOOKUP;
+#endif
bzero((char *)&natlook, sizeof(natlook));
natlook.nl_outip = socketin.sin_addr;
natlook.nl_inip = sloc.sin_addr;
@@ -1152,9 +1170,13 @@
natlook.nl_inport = sloc.sin_port;
fd = open(IPL_NAT, O_RDONLY);
- if (ioctl(fd, SIOCGNATL, &natlook) == -1)
+#if __FreeBSD_version >=600024
+ if (ioctl(fd, SIOCGNATL, &obj) == -1)
+#else
+ if (ioctl(fd, SIOCGNATL, &natlookp) == -1)
+#endif
{
- perror("ioctl");
+ perror("ioctl(SIOCGNATL)");
exit(-1);
}
close(fd);
@@ -2201,7 +2223,9 @@
/* People neither using the CDIR stuff nor running as root probably
* couldn't care less about ident problems.
*/
+#ifdef CDIR_IDENT
if (!use_cdir && getuid()) tries = 10;
+#endif
/* FIXME: dangerous sprintfs */
#ifdef CDIR

View file

@ -1,36 +0,0 @@
--- tircproxy.h Sat Oct 15 06:49:51 2005
+++ tircproxy.h Sat Oct 15 06:50:00 2005
@@ -34,8 +34,8 @@
/* Set the location of the broadcast & MOTD files. Undef these to disable
** the broadcasting feature.
*/
-#define BROADCAST_FILE "/tmp/ircbroadcast"
-#define IRC_MOTD_FILE "/etc/motd.irc"
+#define BROADCAST_FILE "/usr/local/etc/tircproxy/ircbroadcast"
+#define IRC_MOTD_FILE "/usr/local/etc/tircproxy/motd.irc"
/* Enable this if you want to use the IPF code for tranparency.
*/
@@ -43,7 +43,7 @@
/* Enable this if you want to use the Linux code for tranparency.
*/
-#define LINUX 1
+#define LINUX 0
/* Enable this if you want to ask proxy users for passwords.
*/
@@ -117,11 +117,11 @@
**
** This means the proxy does NOT need to run as root for ident responses to
** be correct. This method is now obsolete - use UDB if at all possible!
-*/
+
#define CDIR "/var/oidentd/"
#define CDIR_IDENT "ident"
#define CDIR_MAP "user"
-
+*/
/* The following table defines a list of filenames that are not
** to be handled transparently by the DCC code.. if replace points to

View file

@ -1,13 +0,0 @@
This is an IRC proxy server. Features:
+ Supports DCC CHAT, SEND, RESUME and TSEND protocols.
+ Supports both transparent and dedicated operation.
+ Supports "anonymization" to hide users' identities.
+ Supports flexible authentication for access.
+ Can be run either standalone or via inetd.
+ Allows the admin to send "MOTD" style messages and/or
broadcasts to the user(s).
+ Can block trojans such as 'script.ini', 'dmsetup.exe', etc.
+ Access controlled by /etc/hosts.allow and /etc/hosts.deny.
+ Can cooperate with some identd's for non-root operation, or
(if root) can change UID/GID according to client's IP addr.
+ Extensive documentation

View file

@ -1,2 +0,0 @@
sbin/tircproxy
%%PORTDOCS%%share/doc/tircproxy/README