lang/php84: Update version 8.4.0beta4 => 8.4.0beta5

Please DO NOT use this version in production, it is an early test version.

Changelog: https://github.com/php/php-src/blob/php-8.4.0beta5/NEWS
This commit is contained in:
Muhammad Moinur Rahman 2024-09-13 16:44:33 +02:00
parent 4e5a98ed22
commit e2bfd26e66
No known key found for this signature in database
GPG key ID: BDB9B5A617C0BC91
6 changed files with 68 additions and 76 deletions

View file

@ -1,6 +1,6 @@
--- config.m4.orig 2023-11-07 20:02:05 UTC --- config.m4.orig 2024-09-10 16:10:06 UTC
+++ config.m4 +++ config.m4
@@ -387,6 +387,14 @@ if test "$PHP_DB4" != "no"; then @@ -433,6 +433,14 @@ if test "$PHP_DB4" != "no"; then
THIS_PREFIX=$i THIS_PREFIX=$i
THIS_INCLUDE=$i/include/db5.3/db.h THIS_INCLUDE=$i/include/db5.3/db.h
break break
@ -15,12 +15,11 @@
elif test -f "$i/include/db5.1/db.h"; then elif test -f "$i/include/db5.1/db.h"; then
THIS_PREFIX=$i THIS_PREFIX=$i
THIS_INCLUDE=$i/include/db5.1/db.h THIS_INCLUDE=$i/include/db5.1/db.h
@@ -429,7 +437,7 @@ if test "$PHP_DB4" != "no"; then @@ -480,6 +488,7 @@ if test "$PHP_DB4" != "no"; then
break db-5.3
fi db-5.1
done db-5.0
- PHP_DBA_DB_CHECK(4, db-5.3 db-5.1 db-5.0 db-4.8 db-4.7 db-4.6 db-4.5 db-4.4 db-4.3 db-4.2 db-4.1 db-4.0 db-4 db4 db, [(void)db_create((DB**)0, (DB_ENV*)0, 0)]) + db-5
+ PHP_DBA_DB_CHECK(4, db-5 db-5.3 db-5.1 db-5.0 db-4.8 db-4.7 db-4.6 db-4.5 db-4.4 db-4.3 db-4.2 db-4.1 db-4.0 db-4 db-18 db4 db, [(void)db_create((DB**)0, (DB_ENV*)0, 0)]) db-4.8
fi db-4.7
PHP_DBA_STD_RESULT(db4,Berkeley DB4) db-4.6

View file

@ -1,101 +1,92 @@
--- config.m4.orig 2023-11-07 20:02:05 UTC --- config.m4.orig 2024-09-10 16:10:06 UTC
+++ config.m4 +++ config.m4
@@ -102,7 +102,7 @@ PHP_ARG_WITH([adabas],, @@ -117,7 +117,7 @@ PHP_ARG_WITH([adabas],
if test -z "$ODBC_TYPE"; then PHP_ARG_WITH([adabas],
PHP_ARG_WITH([adabas],, [for Adabas support],
[AS_HELP_STRING([[--with-adabas[=DIR]]], [AS_HELP_STRING([[--with-adabas[=DIR]]],
- [Include Adabas D support [/usr/local]])]) - [Include Adabas D support [/usr/local]])])
+ [Include Adabas D support [/usr/local]])], [no], [no]) + [Include Adabas D support [/usr/local]])], [no], [no])
AC_MSG_CHECKING([for Adabas support]) AS_VAR_IF([PHP_ADABAS], [no], [], [
if test "$PHP_ADABAS" != "no"; then AS_VAR_IF([PHP_ADABAS], [yes], [PHP_ADABAS=/usr/local])
@@ -132,7 +132,7 @@ PHP_ARG_WITH([sapdb],, @@ -143,7 +143,7 @@ PHP_ARG_WITH([sapdb],
if test -z "$ODBC_TYPE"; then PHP_ARG_WITH([sapdb],
PHP_ARG_WITH([sapdb],, [for SAP DB support],
[AS_HELP_STRING([[--with-sapdb[=DIR]]], [AS_HELP_STRING([[--with-sapdb[=DIR]]],
- [Include SAP DB support [/usr/local]])]) - [Include SAP DB support [/usr/local]])])
+ [Include SAP DB support [/usr/local]])], [no], [no]) + [Include SAP DB support [/usr/local]])], [no], [no])
AC_MSG_CHECKING([for SAP DB support]) AS_VAR_IF([PHP_SAPDB], [no], [], [
if test "$PHP_SAPDB" != "no"; then AS_VAR_IF([PHP_SAPDB], [yes], [PHP_SAPDB=/usr/local])
@@ -153,7 +153,7 @@ PHP_ARG_WITH([solid],, @@ -160,7 +160,7 @@ PHP_ARG_WITH([solid],
if test -z "$ODBC_TYPE"; then PHP_ARG_WITH([solid],
PHP_ARG_WITH([solid],, [for Solid support],
[AS_HELP_STRING([[--with-solid[=DIR]]], [AS_HELP_STRING([[--with-solid[=DIR]]],
- [Include Solid support [/usr/local/solid]])]) - [Include Solid support [/usr/local/solid]])])
+ [Include Solid support [/usr/local/solid]])], [no], [no]) + [Include Solid support [/usr/local/solid]])], [no], [no])
AC_MSG_CHECKING(for Solid support) AS_VAR_IF([PHP_SOLID], [no], [], [
if test "$PHP_SOLID" != "no"; then AS_VAR_IF([PHP_SOLID], [yes], [PHP_SOLID=/usr/local/solid])
@@ -181,7 +181,7 @@ PHP_ARG_WITH([ibm-db2],, @@ -184,7 +184,7 @@ PHP_ARG_WITH([ibm-db2],
if test -z "$ODBC_TYPE"; then PHP_ARG_WITH([ibm-db2],
PHP_ARG_WITH([ibm-db2],, [for IBM DB2 support],
[AS_HELP_STRING([[--with-ibm-db2[=DIR]]], [AS_HELP_STRING([[--with-ibm-db2[=DIR]]],
- [Include IBM DB2 support [/home/db2inst1/sqllib]])]) - [Include IBM DB2 support [/home/db2inst1/sqllib]])])
+ [Include IBM DB2 support [/home/db2inst1/sqllib]])], [no], [no]) + [Include IBM DB2 support [/home/db2inst1/sqllib]])], [no], [no])
AC_MSG_CHECKING(for IBM DB2 support) AS_VAR_IF([PHP_IBM_DB2], [no], [], [
if test "$PHP_IBM_DB2" != "no"; then AS_VAR_IF([PHP_IBM_DB2], [yes], [
@@ -222,7 +222,7 @@ PHP_ARG_WITH([empress],, @@ -222,7 +222,7 @@ PHP_ARG_WITH([empress],
PHP_ARG_WITH([empress],, [for Empress support],
[AS_HELP_STRING([[--with-empress[=DIR]]], [AS_HELP_STRING([[--with-empress[=DIR]]],
[Include Empress support $EMPRESSPATH (Empress Version >= 8.60 [Include Empress support $EMPRESSPATH (Empress Version >= 8.60
- required)])]) - required)])])
+ required)])], [no], [no]) + required)])], [no], [no])
AC_MSG_CHECKING(for Empress support) AS_VAR_IF([PHP_EMPRESS], [no], [], [
if test "$PHP_EMPRESS" != "no"; then AS_VAR_IF([PHP_EMPRESS], [yes], [
@@ -248,7 +248,7 @@ PHP_ARG_WITH([empress-bcs],, @@ -246,7 +246,7 @@ PHP_ARG_WITH([empress-bcs],
PHP_ARG_WITH([empress-bcs],, [for Empress local access support],
[AS_HELP_STRING([[--with-empress-bcs[=DIR]]], [AS_HELP_STRING([[--with-empress-bcs[=DIR]]],
[Include Empress Local Access support $EMPRESSPATH (Empress Version >= [Include Empress Local Access support $EMPRESSPATH (Empress Version >=
- 8.60 required)])]) - 8.60 required)])])
+ 8.60 required)])], [no], [no]) + 8.60 required)])], [no], [no])
AC_MSG_CHECKING(for Empress local access support) AS_VAR_IF([PHP_EMPRESS_BCS], [no], [], [
if test "$PHP_EMPRESS_BCS" != "no"; then AS_VAR_IF([PHP_EMPRESS_BCS], [yes], [
@@ -294,7 +294,7 @@ PHP_ARG_WITH([custom-odbc],, @@ -290,7 +290,7 @@ PHP_ARG_WITH([custom-odbc],
your include dirs. For example, you should define following for Sybase SQL your include dirs. For example, you should define following for Sybase SQL
Anywhere 5.5.00 on QNX, prior to running this configure script: Anywhere 5.5.00 on QNX, prior to running this configure script:
CPPFLAGS="-DODBC_QNX -DSQLANY_BUG" LDFLAGS=-lunix CPPFLAGS="-DODBC_QNX -DSQLANY_BUG" LDFLAGS=-lunix
- CUSTOM_ODBC_LIBS="-ldblib -lodbc"])]) - CUSTOM_ODBC_LIBS="-ldblib -lodbc"])])
+ CUSTOM_ODBC_LIBS="-ldblib -lodbc"])], [no], [no]) + CUSTOM_ODBC_LIBS="-ldblib -lodbc"])], [no], [no])
AC_MSG_CHECKING(for a custom ODBC support) AS_VAR_IF([PHP_CUSTOM_ODBC], [no], [], [
if test "$PHP_CUSTOM_ODBC" != "no"; then AS_VAR_IF([PHP_CUSTOM_ODBC], [yes], [PHP_CUSTOM_ODBC=/usr/local])
@@ -317,7 +317,7 @@ PHP_ARG_WITH([iodbc],, @@ -309,7 +309,7 @@ PHP_ARG_WITH([iodbc],
if test -z "$ODBC_TYPE"; then PHP_ARG_WITH([iodbc],
PHP_ARG_WITH([iodbc],, [whether to build with iODBC support],
[AS_HELP_STRING([--with-iodbc], [AS_HELP_STRING([--with-iodbc],
- [Include iODBC support])]) - [Include iODBC support])])
+ [Include iODBC support])], [no], [no]) + [Include iODBC support])], [no], [no])
AC_MSG_CHECKING(whether to build with iODBC support) AS_VAR_IF([PHP_IODBC], [no], [], [
if test "$PHP_IODBC" != "no"; then PKG_CHECK_MODULES([ODBC], [libiodbc])
@@ -335,7 +335,7 @@ PHP_ARG_WITH([esoob],, @@ -324,7 +324,7 @@ PHP_ARG_WITH([esoob],
if test -z "$ODBC_TYPE"; then PHP_ARG_WITH([esoob],
PHP_ARG_WITH([esoob],, [for Easysoft ODBC-ODBC Bridge support],
[AS_HELP_STRING([[--with-esoob[=DIR]]], [AS_HELP_STRING([[--with-esoob[=DIR]]],
- [Include Easysoft OOB support [/usr/local/easysoft/oob/client]])]) - [Include Easysoft OOB support [/usr/local/easysoft/oob/client]])])
+ [Include Easysoft OOB support [/usr/local/easysoft/oob/client]])], [no], [no]) + [Include Easysoft OOB support [/usr/local/easysoft/oob/client]])], [no], [no])
AC_MSG_CHECKING(for Easysoft ODBC-ODBC Bridge support) AS_VAR_IF([PHP_ESOOB], [no], [], [
if test "$PHP_ESOOB" != "no"; then AS_VAR_IF([PHP_ESOOB], [yes], [PHP_ESOOB=/usr/local/easysoft/oob/client])
@@ -358,7 +358,7 @@ PHP_ARG_WITH([unixODBC],, @@ -371,7 +371,7 @@ PHP_ARG_WITH([dbmaker],
if test -z "$ODBC_TYPE"; then PHP_ARG_WITH([dbmaker],
PHP_ARG_WITH([unixODBC],, [for DBMaker support],
[AS_HELP_STRING([--with-unixODBC],
- [Include unixODBC support])])
+ [Include unixODBC support])], [no], [no])
AC_MSG_CHECKING(whether to build with unixODBC support)
if test "$PHP_UNIXODBC" != "no"; then
@@ -386,7 +386,7 @@ PHP_ARG_WITH([dbmaker],,
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH([dbmaker],,
[AS_HELP_STRING([[--with-dbmaker[=DIR]]], [AS_HELP_STRING([[--with-dbmaker[=DIR]]],
- [Include DBMaker support])]) - [Include DBMaker support])])
+ [Include DBMaker support])], [no], [no]) + [Include DBMaker support])], [no], [no])
AC_MSG_CHECKING(for DBMaker support) AS_VAR_IF([PHP_DBMAKER], [no], [], [
if test "$PHP_DBMAKER" != "no"; then AS_VAR_IF([PHP_DBMAKER], [yes], [

View file

@ -1,5 +1,5 @@
PORTNAME= php84 PORTNAME= php84
DISTVERSION= 8.4.0beta4 DISTVERSION= 8.4.0beta5
PORTREVISION?= 0 PORTREVISION?= 0
CATEGORIES?= lang devel www CATEGORIES?= lang devel www
MASTER_SITES= https://downloads.php.net/~saki/ \ MASTER_SITES= https://downloads.php.net/~saki/ \
@ -168,6 +168,7 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/php.ini-development ${WRKSRC}/php.ini-production \ ${INSTALL_DATA} ${WRKSRC}/php.ini-development ${WRKSRC}/php.ini-production \
${WRKDIR}/php.conf ${STAGEDIR}/${PREFIX}/etc ${WRKDIR}/php.conf ${STAGEDIR}/${PREFIX}/etc
${INSTALL_DATA} ${WRKSRC}/Zend/zend_property_hooks.h ${STAGEDIR}${PREFIX}/include/php/Zend ${INSTALL_DATA} ${WRKSRC}/Zend/zend_property_hooks.h ${STAGEDIR}${PREFIX}/include/php/Zend
${INSTALL_DATA} ${WRKSRC}/Zend/zend_lazy_objects.h ${STAGEDIR}${PREFIX}/include/php/Zend
post-install-CGI-on: post-install-CGI-on:
${STRIP_CMD} ${STAGEDIR}/${PREFIX}/bin/php-cgi ${STRIP_CMD} ${STAGEDIR}/${PREFIX}/bin/php-cgi

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1725002588 TIMESTAMP = 1726217958
SHA256 (php-8.4.0beta4.tar.xz) = bafb6f5c10a0b34ed5f2ff28eb12bc4154ffef4c04534c03e993e1c951fb9d22 SHA256 (php-8.4.0beta5.tar.xz) = 86c9e6fe9b4ab2046832ab65f955c50d663a6fccb3f6d6fbddc4aa9b96a561b7
SIZE (php-8.4.0beta4.tar.xz) = 13459160 SIZE (php-8.4.0beta5.tar.xz) = 13498220

View file

@ -1,4 +1,4 @@
--- configure.ac.orig 2024-08-27 14:33:48 UTC --- configure.ac.orig 2024-09-10 16:10:06 UTC
+++ configure.ac +++ configure.ac
@@ -55,6 +55,7 @@ AH_BOTTOM([ @@ -55,6 +55,7 @@ AH_BOTTOM([
@ -8,7 +8,7 @@
#endif /* PHP_CONFIG_H */ #endif /* PHP_CONFIG_H */
]) ])
@@ -248,7 +249,6 @@ AS_VAR_APPEND([CPPFLAGS], [" -D_GNU_SOURCE"]) @@ -249,7 +250,6 @@ AS_VAR_APPEND([CPPFLAGS], [" -D_GNU_SOURCE"])
dnl require extensions to C and POSIX. dnl require extensions to C and POSIX.
AS_VAR_APPEND([CPPFLAGS], [" -D_GNU_SOURCE"]) AS_VAR_APPEND([CPPFLAGS], [" -D_GNU_SOURCE"])
@ -16,10 +16,10 @@
PHP_HELP_SEPARATOR([SAPI modules:]) PHP_HELP_SEPARATOR([SAPI modules:])
PHP_SHLIB_SUFFIX_NAMES PHP_SHLIB_SUFFIX_NAMES
PHP_BUILD_PROGRAM PHP_BUILD_PROGRAM
@@ -1371,7 +1371,7 @@ EXPANDED_PHP_CONFIG_FILE_SCAN_DIR=`eval echo "$PHP_CON @@ -1368,7 +1368,7 @@ EXPANDED_PHP_CONFIG_FILE_SCAN_DIR=$(eval echo "$PHP_CO
EXPANDED_DATADIR=$datadir EXPANDED_DATADIR=$datadir
EXPANDED_PHP_CONFIG_FILE_PATH=`eval echo "$PHP_CONFIG_FILE_PATH"` EXPANDED_PHP_CONFIG_FILE_PATH=$(eval echo "$PHP_CONFIG_FILE_PATH")
EXPANDED_PHP_CONFIG_FILE_SCAN_DIR=`eval echo "$PHP_CONFIG_FILE_SCAN_DIR"` EXPANDED_PHP_CONFIG_FILE_SCAN_DIR=$(eval echo "$PHP_CONFIG_FILE_SCAN_DIR")
-INCLUDE_PATH=.:$EXPANDED_PEAR_INSTALLDIR -INCLUDE_PATH=.:$EXPANDED_PEAR_INSTALLDIR
+INCLUDE_PATH=.:${prefix}/share/pear +INCLUDE_PATH=.:${prefix}/share/pear

View file

@ -75,6 +75,7 @@ include/php/Zend/zend_iterators.h
include/php/Zend/zend_language_parser.h include/php/Zend/zend_language_parser.h
include/php/Zend/zend_language_scanner.h include/php/Zend/zend_language_scanner.h
include/php/Zend/zend_language_scanner_defs.h include/php/Zend/zend_language_scanner_defs.h
include/php/Zend/zend_lazy_objects.h
include/php/Zend/zend_list.h include/php/Zend/zend_list.h
include/php/Zend/zend_llist.h include/php/Zend/zend_llist.h
include/php/Zend/zend_long.h include/php/Zend/zend_long.h