mirror of
https://git.freebsd.org/ports.git
synced 2025-05-12 23:31:50 -04:00
devel/py-multiset: New port: Implementation of a multiset
This commit is contained in:
parent
d41545557a
commit
e26a46d3a9
5 changed files with 47 additions and 0 deletions
|
@ -4916,6 +4916,7 @@
|
|||
SUBDIR += py-multi_key_dict
|
||||
SUBDIR += py-multipledispatch
|
||||
SUBDIR += py-multiprocess
|
||||
SUBDIR += py-multiset
|
||||
SUBDIR += py-multitasking
|
||||
SUBDIR += py-munch
|
||||
SUBDIR += py-murmurhash
|
||||
|
|
24
devel/py-multiset/Makefile
Normal file
24
devel/py-multiset/Makefile
Normal file
|
@ -0,0 +1,24 @@
|
|||
PORTNAME= multiset
|
||||
DISTVERSION= 3.0.1
|
||||
CATEGORIES= devel python
|
||||
MASTER_SITES= PYPI
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
COMMENT= Implementation of a multiset
|
||||
WWW= https://github.com/wheerd/multiset
|
||||
|
||||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=3.4:devel/py-setuptools_scm@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
|
||||
|
||||
USES= dos2unix python
|
||||
USE_PYTHON= pep517 autoplist pytest
|
||||
|
||||
DOS2UNIX_FILES= pyproject.toml
|
||||
|
||||
NO_ARCH= yes
|
||||
|
||||
.include <bsd.port.mk>
|
3
devel/py-multiset/distinfo
Normal file
3
devel/py-multiset/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1680195127
|
||||
SHA256 (multiset-3.0.1.tar.gz) = e45671cae8385a8e6248a9b07a3a83280c2d0cc4312713058cfbacdc5ec9973e
|
||||
SIZE (multiset-3.0.1.tar.gz) = 33433
|
13
devel/py-multiset/files/patch-pyproject.toml
Normal file
13
devel/py-multiset/files/patch-pyproject.toml
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- pyproject.toml.orig 2023-03-30 16:54:02 UTC
|
||||
+++ pyproject.toml
|
||||
@@ -1,7 +1,7 @@
|
||||
[build-system]
|
||||
requires = [
|
||||
"setuptools >= 42",
|
||||
- "setuptools_scm[toml]>=3.4,<6",
|
||||
+ "setuptools_scm[toml]>=3.4",
|
||||
"wheel"
|
||||
]
|
||||
-build-backend = "setuptools.build_meta"
|
||||
\ No newline at end of file
|
||||
+build-backend = "setuptools.build_meta"
|
6
devel/py-multiset/pkg-descr
Normal file
6
devel/py-multiset/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
The multiset package provides a multiset implementation for python.
|
||||
|
||||
A multiset is similar to the builtin set, but it allows an element to occur
|
||||
multiple times. It is an unordered collection of elements which have to be
|
||||
hashable just like in a set. It supports the same methods and operations as set
|
||||
does, e.g. membership test, union, intersection, and (symmetric) difference.
|
Loading…
Add table
Reference in a new issue