mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
net-mgmt/tcpreplay: take maintainership, add LICENSE_FILE, OPTIONS modified
Also: - replace patch for fix build (upstream issue: https://github.com/appneta/tcpreplay/issues/809); - remake patches with makepatch; - remove GNU_CONFIGURE_MANPREFIX. Version 4.5.1 contains many bug fixes: https://github.com/appneta/tcpreplay/releases/tag/v4.5.1 PR: 280260 Approved by: ehaupt (maintainer) MFH: 2024Q3
This commit is contained in:
parent
82cba748fb
commit
e2455c7452
5 changed files with 39 additions and 35 deletions
|
@ -3,11 +3,12 @@ DISTVERSION= 4.5.1
|
|||
CATEGORIES= net-mgmt
|
||||
MASTER_SITES= https://github.com/appneta/${PORTNAME}/releases/download/v${DISTVERSION}/
|
||||
|
||||
MAINTAINER= ehaupt@FreeBSD.org
|
||||
MAINTAINER= mew14930xvi@inbox.lv
|
||||
COMMENT= Tool to replay saved packet capture files
|
||||
WWW= https://github.com/appneta/tcpreplay
|
||||
|
||||
LICENSE= GPLv3
|
||||
LICENSE_FILE= ${WRKSRC}/docs/LICENSE
|
||||
|
||||
BUILD_DEPENDS= pcapnav-config:net/libpcapnav
|
||||
LIB_DEPENDS= libdnet.so:net/libdnet \
|
||||
|
@ -17,7 +18,6 @@ USES= cpe gmake libtool pkgconfig tar:xz
|
|||
CPE_VENDOR= broadcom
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
|
||||
# libopts options are required when using autogen
|
||||
CONFIGURE_ARGS= --disable-libopts-install \
|
||||
--disable-local-libopts \
|
||||
|
@ -26,15 +26,10 @@ CONFIGURE_ARGS= --disable-libopts-install \
|
|||
|
||||
TEST_TARGET= test
|
||||
|
||||
OPTIONS_DEFAULT= LIBPCAP_BASE
|
||||
OPTIONS_SINGLE= LIBPCAP
|
||||
OPTIONS_SINGLE_LIBPCAP= LIBPCAP_BASE LIBPCAP_PORTS
|
||||
|
||||
LIBPCAP_BASE_DESC= Build with libpcap from the base OS
|
||||
LIBPCAP_PORTS_DESC= Build with net/libpcap
|
||||
|
||||
LIBPCAP_BASE_CONFIGURE_ON= --with-libpcap=/usr/lib
|
||||
OPTIONS_DEFINE= LIBPCAP_PORTS
|
||||
LIBPCAP_PORTS_DESC= Build with net/libpcap instead of from the base OS
|
||||
# needs .so version (see: 262976)
|
||||
LIBPCAP_PORTS_LIB_DEPENDS= libpcap.so.1:net/libpcap
|
||||
LIBPCAP_PORTS_CONFIGURE_OFF= --with-libpcap=/usr/lib
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- Makefile.in.orig 2022-02-05 21:30:36 UTC
|
||||
--- Makefile.in.orig 2024-07-12 17:15:27 UTC
|
||||
+++ Makefile.in
|
||||
@@ -892,7 +892,7 @@ autoopts:
|
||||
@@ -900,7 +900,7 @@ test:
|
||||
|
||||
test:
|
||||
echo Making test in $(TEST_DIR)
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
--- lib/queue.h.orig 2024-03-24 16:55:28 UTC
|
||||
+++ lib/queue.h
|
||||
@@ -36,8 +36,8 @@
|
||||
* @(#)queue.h 8.5 (Berkeley) 8/20/94
|
||||
*/
|
||||
|
||||
-#ifndef _SYS_QUEUE_H_
|
||||
-#define _SYS_QUEUE_H_
|
||||
+#ifndef _QUEUE_H_
|
||||
+#define _QUEUE_H_
|
||||
|
||||
/*
|
||||
* This file defines five types of data structures: singly-linked lists,
|
||||
@@ -508,4 +508,4 @@ struct { \
|
||||
(elm2)->field.cqe_prev->field.cqe_next = (elm2); \
|
||||
} while (0)
|
||||
|
||||
-#endif /* !_SYS_QUEUE_H_ */
|
||||
+#endif /* !_QUEUE_H_ */
|
15
net-mgmt/tcpreplay/files/patch-src_fragroute_mod.c
Normal file
15
net-mgmt/tcpreplay/files/patch-src_fragroute_mod.c
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- src/fragroute/mod.c.orig 2023-12-31 18:39:02 UTC
|
||||
+++ src/fragroute/mod.c
|
||||
@@ -8,11 +8,11 @@
|
||||
*/
|
||||
|
||||
#include "mod.h"
|
||||
+#include "lib/queue.h"
|
||||
#include "defines.h"
|
||||
#include "config.h"
|
||||
#include "common.h"
|
||||
#include "argv.h"
|
||||
-#include "lib/queue.h"
|
||||
#include <ctype.h>
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
13
net-mgmt/tcpreplay/files/patch-src_fragroute_pkt.h
Normal file
13
net-mgmt/tcpreplay/files/patch-src_fragroute_pkt.h
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- src/fragroute/pkt.h.orig 2023-12-31 18:39:02 UTC
|
||||
+++ src/fragroute/pkt.h
|
||||
@@ -8,9 +8,9 @@
|
||||
|
||||
#pragma once
|
||||
|
||||
+#include "lib/queue.h"
|
||||
#include "defines.h"
|
||||
#include "config.h"
|
||||
-#include "lib/queue.h"
|
||||
#include <sys/time.h>
|
||||
|
||||
#ifdef HAVE_LIBDNET
|
Loading…
Add table
Reference in a new issue