editors/hexcurse: switch to maintained fork, update, and undeprecate

Keep the current port name for the time being, despite that fork had
added the `-ng' suffix, to help Git track history better, as it does
not have proper support for renames.  While here, adjust the LICENSE.
This commit is contained in:
Alexey Dokuchaev 2025-02-10 04:12:00 +00:00
parent e43d411d65
commit e177e3a3c8
4 changed files with 14 additions and 38 deletions

View file

@ -1,29 +1,27 @@
PORTNAME= hexcurse
DISTVERSIONPREFIX= v
DISTVERSION= 1.60.0
PORTREVISION= 1
DISTVERSION= 1.70.0
CATEGORIES= editors
MAINTAINER= bofh@FreeBSD.org
COMMENT= Versatile ncurses-based hex editor
WWW= https://BSDforge.com/projects/editors/hexcurse/
WWW= https://github.com/prso/hexcurse-ng
LICENSE= GPLv2
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
DEPRECATED= Unmaintained, last release in 2015
EXPIRATION_DATE=2025-02-11
USES= ncurses
USES= autoreconf ncurses
USE_GITHUB= yes
GH_ACCOUNT= LonnyGomes
GH_ACCOUNT= prso
GH_PROJECT= ${PORTNAME}-ng
GNU_CONFIGURE= yes
CFLAGS+= -Wno-error=deprecated-non-prototype \
-Wno-error=format-security \
-Wno-error=format-truncation
INSTALL_TARGET= install-strip
PLIST_FILES= bin/hexcurse share/man/man1/hexcurse.1.gz
post-patch:
@${REINPLACE_CMD} -e 's, getopt\.c,,' ${WRKSRC}/src/Makefile.am
@${REINPLACE_CMD} -e 's,hgetopt,getopt,' ${WRKSRC}/src/hexcurse.c
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1615680672
SHA256 (LonnyGomes-hexcurse-v1.60.0_GH0.tar.gz) = f6919e4a824ee354f003f0c42e4c4cef98a93aa7e3aa449caedd13f9a2db5530
SIZE (LonnyGomes-hexcurse-v1.60.0_GH0.tar.gz) = 171904
TIMESTAMP = 1724695608
SHA256 (prso-hexcurse-ng-v1.70.0_GH0.tar.gz) = 54d93391bc769173b7e584406e58aee1d01b56298a8acdd8abd9c90ccc1a7b5b
SIZE (prso-hexcurse-ng-v1.70.0_GH0.tar.gz) = 192001

View file

@ -1,11 +0,0 @@
--- include/hex.h.orig 2015-11-18 04:33:09 UTC
+++ include/hex.h
@@ -126,7 +126,7 @@ extern bool color_enabled;
#define max(a,b) ((a) >(b) ? (a) : (b))
#endif
-FILE *fpIN; /* global file ptr */
+extern FILE *fpIN; /* global file ptr */
/* function prototypes */

View file

@ -1,11 +0,0 @@
--- src/file.c.orig 2015-11-18 04:33:09 UTC
+++ src/file.c
@@ -18,6 +18,8 @@
\******************************************************************************/
#include "hex.h"
+FILE *fpIN; /* global file ptr */
+
/*******************************************************\
* Description: prints out a line of text to the screen*
* the current address line and both the *