mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
x11-toolkits/py-tktreectrl: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
This commit is contained in:
parent
bbb8831b02
commit
e0d3db201b
3 changed files with 32 additions and 1 deletions
|
@ -1,5 +1,6 @@
|
|||
PORTNAME= tktreectrl
|
||||
PORTVERSION= 2.0.2
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= x11-toolkits tk python
|
||||
MASTER_SITES= SF/tkintertreectrl/TkinterTreectrl-${PORTVERSION:R}/
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -12,13 +13,18 @@ WWW= https://tkintertreectrl.sourceforge.net/
|
|||
LICENSE= PD
|
||||
|
||||
# x11-toolkits/tktreectrl does not provide libtreectrl.so
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
|
||||
LIB_DEPENDS= libtreectrl.so.1:x11-toolkits/tktreectrl
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Pmw>=0:x11-toolkits/py-Pmw@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}tkinter>=0:x11-toolkits/py-tkinter@${PY_FLAVOR}
|
||||
|
||||
USES= python tk:run zip
|
||||
USE_PYTHON= autoplist concurrent distutils
|
||||
USE_PYTHON= autoplist concurrent pep517
|
||||
|
||||
NO_ARCH= yes
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${WRKSRC}/setup.py ${WRKSRC}/TkTreectrl/__init__.py
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -0,0 +1,11 @@
|
|||
--- TkTreectrl/__init__.py.orig 2012-11-20 20:15:04 UTC
|
||||
+++ TkTreectrl/__init__.py
|
||||
@@ -13,7 +13,7 @@ Treectrl, MultiListbox, ScrolledTreectrl, ScrolledMult
|
||||
|
||||
Treectrl, MultiListbox, ScrolledTreectrl, ScrolledMultiListbox, ScrolledWidget
|
||||
'''
|
||||
-__version__ = '2.0'
|
||||
+__version__ = '%%PORTVERSION%%'
|
||||
|
||||
ABOVE = 'above'
|
||||
ACTIVE = 'active'
|
14
x11-toolkits/py-tktreectrl/files/patch-setup.py
Normal file
14
x11-toolkits/py-tktreectrl/files/patch-setup.py
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- setup.py.orig 2013-05-06 09:00:53 UTC
|
||||
+++ setup.py
|
||||
@@ -1,9 +1,9 @@ from distutils.core import setup
|
||||
from distutils.core import setup
|
||||
|
||||
-version = '2.0'
|
||||
+version = '%%PORTVERSION%%'
|
||||
|
||||
setup(
|
||||
- name="TkinterTreectrl",
|
||||
+ name="tktreectrl",
|
||||
version=version,
|
||||
description="Tkinter wrapper for TkTreectrl",
|
||||
author="Michael Lange",
|
Loading…
Add table
Reference in a new issue