math/p5-PDL-Graphics-PLplot: Add p5-PDL-Graphics-PLplot 0.84

PDL::Graphics::PLplot is the PDL interface to the PLplot graphics library. It
provides a familiar 'perlish' Object Oriented interface as well as access to the
low-level PLplot commands from the C-API.
This commit is contained in:
Po-Chuan Hsieh 2025-01-29 01:03:19 +08:00
parent 98a7ddcb17
commit e05d39136c
No known key found for this signature in database
GPG key ID: 9A4BD10F002DD04B
6 changed files with 67 additions and 0 deletions

View file

@ -822,6 +822,7 @@
SUBDIR += p5-PDL-GSL SUBDIR += p5-PDL-GSL
SUBDIR += p5-PDL-Graphics-IIS SUBDIR += p5-PDL-Graphics-IIS
SUBDIR += p5-PDL-Graphics-Limits SUBDIR += p5-PDL-Graphics-Limits
SUBDIR += p5-PDL-Graphics-PLplot
SUBDIR += p5-Parse-Range SUBDIR += p5-Parse-Range
SUBDIR += p5-Roman SUBDIR += p5-Roman
SUBDIR += p5-Set-IntSpan SUBDIR += p5-Set-IntSpan

View file

@ -0,0 +1,25 @@
PORTNAME= PDL-Graphics-PLplot
PORTVERSION= 0.84
CATEGORIES= math perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Object-oriented interface from perl/PDL to the PLPLOT plotting library
WWW= https://metacpan.org/dist/PDL-Graphics-PLplot
BUILD_DEPENDS= p5-Devel-CheckLib>=0:devel/p5-Devel-CheckLib \
${RUN_DEPENDS}
LIB_DEPENDS= libplplot.so:math/plplot
RUN_DEPENDS= p5-PDL>=2.083:math/p5-PDL
USES= perl5
USE_PERL5= configure
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/Makefile.PL
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/PDL/Graphics/PLplot/PLplot.so
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
TIMESTAMP = 1736671139
SHA256 (PDL-Graphics-PLplot-0.84.tar.gz) = 9c3986c93c9936f4534b9265b7223ceaee48a0f35895e5d44329465aeb782d20
SIZE (PDL-Graphics-PLplot-0.84.tar.gz) = 192581

View file

@ -0,0 +1,31 @@
--- Makefile.PL.orig 2024-04-21 20:36:49 UTC
+++ Makefile.PL
@@ -7,7 +7,6 @@ use Devel::CheckLib;
use PDL::Core::Dev;
use Devel::CheckLib;
-use Alien::PLplot;
my $PL_MAJOR = 5; # minimum required
my $PL_MINOR = 13;
@@ -31,9 +30,9 @@ sub probe {
}
sub probe {
- $header = (Alien::PLplot->inline_auto_include)->[0];
- $plplot_include_path = Alien::PLplot->cflags;
- $libs = Alien::PLplot->libs;
+ $header = 'plplot.h';
+ $plplot_include_path = '-I%%LOCALBASE%%/include/plplot';
+ $libs = '-L%%LOCALBASE%%/lib -lplplot';
}
probe;
@@ -77,7 +76,6 @@ $hash{CONFIGURE_REQUIRES} = {
$hash{CONFIGURE_REQUIRES} = {
'PDL' => '2.083', # output OtherPars
'Devel::CheckLib' => 0,
- 'Alien::PLplot' => 0,
};
# $hash{'OPTIMIZE'} = '-g'; # If you want to debug, uncomment this.
$hash{TEST_REQUIRES} = {

View file

@ -0,0 +1,3 @@
PDL::Graphics::PLplot is the PDL interface to the PLplot graphics library. It
provides a familiar 'perlish' Object Oriented interface as well as access to the
low-level PLplot commands from the C-API.

View file

@ -0,0 +1,4 @@
%%SITE_ARCH%%/PDL/Demos/PLplot.pm
%%SITE_ARCH%%/PDL/Graphics/PLplot.pm
%%SITE_ARCH%%/auto/PDL/Graphics/PLplot/PLplot.so
%%PERL5_MAN3%%/PDL::Graphics::PLplot.3.gz