Properly patch for png 1.5

This commit is contained in:
Baptiste Daroussin 2014-12-23 23:39:53 +00:00
parent 5a0aee42a5
commit de40ad94ae
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=375374
3 changed files with 14 additions and 14 deletions

View file

@ -3,7 +3,7 @@
PORTNAME= zsnes PORTNAME= zsnes
PORTVERSION= 1.51 PORTVERSION= 1.51
PORTREVISION= 10 PORTREVISION= 11
PORTEPOCH= 1 PORTEPOCH= 1
CATEGORIES= emulators CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/ZSNES%20v${PORTVERSION} MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/ZSNES%20v${PORTVERSION}
@ -14,7 +14,7 @@ COMMENT= Intel x86 only Super Nintendo Entertainment System (SNES) Emulator
# This must be >= 0.98! # This must be >= 0.98!
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
ONLY_FOR_ARCHS= i386 ONLY_FOR_ARCHS= i386
ONLY_FOR_ARCHS_REASON= non-portable, for a portable emulator see emulators/snes9x ONLY_FOR_ARCHS_REASON= non-portable, for a portable emulator see emulators/snes9x
@ -42,8 +42,8 @@ OPENGL_CONFIGURE_ENABLE= opengl
AO_LIB_DEPENDS= libao.so:${PORTSDIR}/audio/libao AO_LIB_DEPENDS= libao.so:${PORTSDIR}/audio/libao
AO_CONFIGURE_ENABLE= libao AO_CONFIGURE_ENABLE= libao
CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15 CFLAGS+= -I${LOCALBASE}/include
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15 CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.options.mk> .include <bsd.port.options.mk>

View file

@ -0,0 +1,10 @@
--- zip/zpng.c.orig 2007-01-15 23:06:29 UTC
+++ zip/zpng.c
@@ -129,7 +129,6 @@ int Png_Dump(const char *filename, unsig
png_set_IHDR(png_ptr, info_ptr, width, height, 8,
PNG_COLOR_TYPE_RGB, PNG_INTERLACE_NONE,
PNG_COMPRESSION_TYPE_DEFAULT, PNG_FILTER_TYPE_DEFAULT);
- info_ptr->color_type = PNG_COLOR_TYPE_RGB;
//Allocate an array of scanline pointers
row_pointers = (png_bytep*)malloc(height*sizeof(png_bytep));

View file

@ -1,10 +0,0 @@
--- zip/zpng.c.orig 2007-01-16 00:06:29.000000000 +0100
+++ zip/zpng.c 2012-05-06 16:01:13.000000000 +0200
@@ -21,6 +21,7 @@
#ifndef NO_PNG
#include <png.h>
+#include <pngpriv.h>
#endif
#ifdef __UNIXSDL__