mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
deskutils/mytetra: the port had been updated to version 1.44.183
The author had finally tagged the latest commit as a new release in several years (since 2021).
This commit is contained in:
parent
058327d156
commit
dd84435d9d
4 changed files with 24 additions and 36 deletions
|
@ -1,9 +1,7 @@
|
|||
PORTNAME= mytetra
|
||||
DISTVERSION= 1_43_27
|
||||
PORTVERSION= 1.44.183
|
||||
DISTVERSIONPREFIX= v.
|
||||
CATEGORIES= deskutils
|
||||
MASTER_SITES= https://webhamster.ru/db/data/articles/105/ \
|
||||
http://vault.101011010.xyz/distfiles/
|
||||
DISTNAME= ${PORTNAME}_${DISTVERSION}_src
|
||||
|
||||
MAINTAINER= danfe@FreeBSD.org
|
||||
COMMENT= Smart manager for information collecting
|
||||
|
@ -11,14 +9,25 @@ WWW= https://webhamster.ru/site/page/index/articles/projectcode/138
|
|||
|
||||
LICENSE= GPLv3
|
||||
|
||||
USES= gmake qmake qt:5 zip
|
||||
USES= gmake qmake qt:5
|
||||
USE_QT= buildtools:build core gui network printsupport svg widgets xml
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= xintrea
|
||||
GH_PROJECT= ${PORTNAME}_dev
|
||||
|
||||
PLIST_FILES= bin/mytetra share/applications/mytetra.desktop \
|
||||
share/icons/hicolor/48x48/apps/mytetra.png \
|
||||
share/icons/hicolor/scalable/apps/mytetra.svg
|
||||
|
||||
post-extract:
|
||||
${CHMOD} -x ${WRKSRC}/desktop/any/mytetra.desktop
|
||||
@${CHMOD} -x ${WRKSRC}/app/desktop/any/mytetra.desktop
|
||||
|
||||
post-patch:
|
||||
# Delete homegrown strcasestr() implementation (breaks the build):
|
||||
# https://github.com/xintrea/mytetra_dev/issues/164
|
||||
@${REINPLACE_CMD} \
|
||||
-e '/for strcasestr() in string\.h/,+4d' \
|
||||
-e '/^int mystrncmpi/,+28d' \
|
||||
${WRKSRC}/thirdParty/mimetex/mimetex.c
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1530899149
|
||||
SHA256 (mytetra_1_43_27_src.zip) = f649d1932c7a40ba2e5e7258fac672c7a90cb46273cfb50b21d8c7f300c1ac6d
|
||||
SIZE (mytetra_1_43_27_src.zip) = 14309620
|
||||
TIMESTAMP = 1739887377
|
||||
SHA256 (xintrea-mytetra_dev-v.1.44.183_GH0.tar.gz) = 5141d593c433f122ff3e53769aa647b7ebaf02a83ef28986773c2f023befe075
|
||||
SIZE (xintrea-mytetra_dev-v.1.44.183_GH0.tar.gz) = 3771637
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- mytetra.pro.orig 2018-06-12 15:49:29 UTC
|
||||
+++ mytetra.pro
|
||||
--- app/app.pro.orig 2025-02-18 14:02:57 UTC
|
||||
+++ app/app.pro
|
||||
@@ -6,7 +6,7 @@ TARGET_OS=ANY_OS
|
||||
|
||||
# Build type
|
||||
|
@ -8,7 +8,7 @@
|
|||
+BUILD_TYPE=$$find(CONFIG, debug|release)
|
||||
|
||||
# Enable console for Windows
|
||||
# 0 - disable, 1 - enable
|
||||
# 0 - disable, 1 - enable (this is for compile mytetra.exe and rename to mytetra_debug.exe)
|
||||
@@ -54,13 +54,7 @@ QT = gui \
|
||||
CONFIG += qt \
|
||||
warn_on
|
||||
|
@ -24,7 +24,7 @@
|
|||
|
||||
# If Windows console enable
|
||||
equals(WINDOWS_CONSOLE_ENABLE, 1) {
|
||||
@@ -91,7 +85,7 @@ INCLUDEPATH += $${_PRO_FILE_PWD_}/src
|
||||
@@ -92,7 +86,7 @@ INCLUDEPATH += $${_PRO_FILE_PWD_}/src
|
||||
contains(TARGET_OS, ANY_OS) {
|
||||
message(Building the any OS version...)
|
||||
SYSTEM_PROGRAM_NAME=mytetra
|
||||
|
@ -33,7 +33,7 @@
|
|||
}
|
||||
|
||||
contains(TARGET_OS, MEEGO_OS){
|
||||
@@ -115,7 +109,7 @@ message(Set installation directory for binary file to
|
||||
@@ -116,7 +110,7 @@ message(Set installation directory for binary file to
|
||||
target.path=$${BINARY_INSTALL_PATH}
|
||||
INSTALLS+=target
|
||||
|
||||
|
@ -42,7 +42,7 @@
|
|||
contains(TARGET_OS, ANY_OS) {
|
||||
desktop_file.files=desktop/any/mytetra.desktop
|
||||
}
|
||||
@@ -127,11 +121,11 @@ contains(TARGET_OS, ANDROID_OS) {
|
||||
@@ -128,11 +122,11 @@ contains(TARGET_OS, ANDROID_OS) {
|
||||
}
|
||||
INSTALLS+=desktop_file
|
||||
|
|
@ -1,21 +0,0 @@
|
|||
--- src/main.cpp.orig 2018-06-17 14:02:54 UTC
|
||||
+++ src/main.cpp
|
||||
@@ -1,4 +1,4 @@
|
||||
-#include <sys/timeb.h>
|
||||
+#include <sys/time.h>
|
||||
|
||||
#include <QTranslator>
|
||||
#include <QToolButton>
|
||||
@@ -572,9 +572,9 @@ int getMilliCount(void)
|
||||
// Something like GetTickCount but portable
|
||||
// It rolls over every ~ 12.1 days (0x100000/24/60/60)
|
||||
// Use getMilliSpan to correct for rollover
|
||||
- timeb tb;
|
||||
- ftime( &tb );
|
||||
- int nCount = tb.millitm + (tb.time & 0xfffff) * 1000;
|
||||
+ timeval tv;
|
||||
+ gettimeofday(&tv, NULL);
|
||||
+ int nCount = tv.tv_usec / 1000 + (tv.tv_sec & 0xfffff) * 1000;
|
||||
return nCount;
|
||||
}
|
||||
|
Loading…
Add table
Reference in a new issue