mirror of
https://git.freebsd.org/ports.git
synced 2025-05-25 15:36:35 -04:00
- Update to 1.18 [1]
- Convert KNOBS to new options framework [1] - Drop ABI version numbers in LIB_DEPENDS [1] - Add UPDATING entry to inform users of IPv6 changes to devel/libvanessa_socket that affect perdition [2] PR: ports/174550 [1], ports/174410 [2] Submitted by: Thomas Vogt <thomas@bsdunix.ch> (maintainer) [1], Joel Ray Holveck <joelh@piquan.org> [2]
This commit is contained in:
parent
e5d9873aeb
commit
db5d2a7cc1
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=310110
14 changed files with 120 additions and 151 deletions
15
UPDATING
15
UPDATING
|
@ -5,6 +5,21 @@ they are unavoidable.
|
||||||
You should get into the habit of checking this file for changes each time
|
You should get into the habit of checking this file for changes each time
|
||||||
you update your ports collection, before attempting any port upgrades.
|
you update your ports collection, before attempting any port upgrades.
|
||||||
|
|
||||||
|
20130108:
|
||||||
|
AFFECTS: users of devel/libvanessa_socket, mail/perdition
|
||||||
|
AUTHOR: jhale@FreeBSD.org
|
||||||
|
|
||||||
|
The update of devel/libvanessa_socket to 0.0.12 (used by Perdition)
|
||||||
|
adds IPv6 support. If the hostname in bind_address has both IPv4 and
|
||||||
|
IPv6 addresses in DNS, then Perdition will ONLY listen on IPv6.
|
||||||
|
|
||||||
|
If you prefer to continue to use IPv4, you need to change the
|
||||||
|
bind_address in /usr/local/etc/perdition/perdition.conf to use an
|
||||||
|
explicit IPv4 address. This can be in addition to, or instead of,
|
||||||
|
the current hostname, depending on whether you want to use IPv6 or
|
||||||
|
not. If your Perdition server does not have an IPv6 address
|
||||||
|
listed in DNS, this change does not affect you.
|
||||||
|
|
||||||
20130108:
|
20130108:
|
||||||
AFFECTS: users of sysutils/cfengine*
|
AFFECTS: users of sysutils/cfengine*
|
||||||
AUTHOR: gjb@FreeBSD.org
|
AUTHOR: gjb@FreeBSD.org
|
||||||
|
|
|
@ -2,10 +2,9 @@
|
||||||
# $FreeBSD$
|
# $FreeBSD$
|
||||||
|
|
||||||
PORTNAME= perdition
|
PORTNAME= perdition
|
||||||
PORTVERSION= 1.17.1
|
PORTVERSION= 1.18
|
||||||
PORTREVISION= 7
|
|
||||||
CATEGORIES= mail net security
|
CATEGORIES= mail net security
|
||||||
MASTER_SITES= http://www.vergenet.net/linux/perdition/download/${PORTVERSION}/
|
MASTER_SITES= http://horms.net/projects/perdition/download/${PORTVERSION}/
|
||||||
|
|
||||||
MAINTAINER= thomas@bsdunix.ch
|
MAINTAINER= thomas@bsdunix.ch
|
||||||
COMMENT= POP3 & IMAP4 proxy that can map users to multiple backend servers
|
COMMENT= POP3 & IMAP4 proxy that can map users to multiple backend servers
|
||||||
|
@ -23,39 +22,34 @@ MANCOMPRESSED= no
|
||||||
USE_AUTOTOOLS= libtool
|
USE_AUTOTOOLS= libtool
|
||||||
USE_GETTEXT= yes
|
USE_GETTEXT= yes
|
||||||
GNU_CONFIGURE= yes
|
GNU_CONFIGURE= yes
|
||||||
CONFIGURE_ENV= BDB_LIB=db3
|
|
||||||
CPPFLAGS+= -I${LOCALBASE}/include
|
CPPFLAGS+= -I${LOCALBASE}/include
|
||||||
LDFLAGS+= -L${LOCALBASE}/lib
|
LDFLAGS+= -L${LOCALBASE}/lib
|
||||||
MAKE_ENV+= DOCSDIR=${DOCSDIR}
|
MAKE_ENV+= DOCSDIR=${DOCSDIR}
|
||||||
CONFIGURE_ARGS+=--disable-daemon-map --localstatedir=/var
|
CONFIGURE_ARGS+=--localstatedir=/var
|
||||||
|
|
||||||
USE_LDCONFIG= yes
|
USE_LDCONFIG= yes
|
||||||
USE_RC_SUBR= perdition perdition.pop3 perdition.pop3s \
|
USE_RC_SUBR= perdition perdition.pop3 perdition.pop3s \
|
||||||
perdition.imap4 perdition.imap4s perdition.imaps
|
perdition.imap4 perdition.imap4s perdition.imaps
|
||||||
|
|
||||||
##
|
OPTIONS_DEFINE= BDB DAEMON_MAP GDBM MYSQL NIS ODBC OPENLDAP OPENSSL PGSQL POSIX_REGEX SSL
|
||||||
## Available knobs:
|
OPTIONS_DEFAULT= GDBM POSIX_REGEX SSL
|
||||||
## WITH_BDB: Enable Berkerley database backend
|
|
||||||
## WITH_DAEMON_MAP: Enable Daemon Map support
|
|
||||||
## WITH_GDBM: Enable gdbm database backend
|
|
||||||
## WITH_MYSQL: Enable MySQL database backend
|
|
||||||
## WITH_NIS: Enable NIS database backend
|
|
||||||
## WITH_PGSQL: Enable PostgreSQL database backend
|
|
||||||
## WITH_ODBC: Enable ODBC database backend
|
|
||||||
## WITH_OPENLDAP: Enable OpenLDAP database backend
|
|
||||||
##
|
|
||||||
## WITHOUT_SSL: Disable OpenSSL support
|
|
||||||
## WITHOUT_POSIX_REGEX: Disable native regex support
|
|
||||||
##
|
|
||||||
|
|
||||||
.if !defined(WITHOUT_SSL)
|
DAEMON_MAP_DESC= Daemon Map support
|
||||||
|
GDBM_DESC= GDBM database backend
|
||||||
|
NIS_DESC= NIS database backend
|
||||||
|
OPENLDAP_DESC= OpenLDAP database backend
|
||||||
|
POSIX_REGEX_DESC= Native regex support
|
||||||
|
|
||||||
|
.include <bsd.port.options.mk>
|
||||||
|
|
||||||
|
.if ${PORT_OPTIONS:MOPENSSL}
|
||||||
CONFIGURE_ARGS+= --enable-ssl
|
CONFIGURE_ARGS+= --enable-ssl
|
||||||
USE_OPENSSL= yes
|
USE_OPENSSL= yes
|
||||||
.else
|
.else
|
||||||
CONFIGURE_ARGS+= --disable-ssl
|
CONFIGURE_ARGS+= --disable-ssl
|
||||||
.endif
|
.endif
|
||||||
|
|
||||||
.if !defined(WITHOUT_POSIX_REGEX)
|
.if ${PORT_OPTIONS:MPOSIX_REGEX}
|
||||||
CONFIGURE_ARGS+= --enable-posix_regex
|
CONFIGURE_ARGS+= --enable-posix_regex
|
||||||
PLIST_SUB+= POSIXREGEX=""
|
PLIST_SUB+= POSIXREGEX=""
|
||||||
.else
|
.else
|
||||||
|
@ -63,7 +57,7 @@ CONFIGURE_ARGS+= --disable-posix_regex
|
||||||
PLIST_SUB+= POSIXREGEX="@comment "
|
PLIST_SUB+= POSIXREGEX="@comment "
|
||||||
.endif
|
.endif
|
||||||
|
|
||||||
.if defined(WITH_DAEMON_MAP)
|
.if ${PORT_OPTIONS:MDAEMON_MAP}
|
||||||
CONFIGURE_ARGS+= --enable-daemon-map
|
CONFIGURE_ARGS+= --enable-daemon-map
|
||||||
PLIST_SUB+= DAEMONMAP=""
|
PLIST_SUB+= DAEMONMAP=""
|
||||||
LIB_DEPENDS+= gdbm:${PORTSDIR}/databases/gdbm
|
LIB_DEPENDS+= gdbm:${PORTSDIR}/databases/gdbm
|
||||||
|
@ -72,17 +66,18 @@ CONFIGURE_ARGS+= --disable-daemon-map
|
||||||
PLIST_SUB+= DAEMONMAP="@comment "
|
PLIST_SUB+= DAEMONMAP="@comment "
|
||||||
.endif
|
.endif
|
||||||
|
|
||||||
.if defined(WITH_BDB)
|
.if ${PORT_OPTIONS:MBDB}
|
||||||
|
CPPFLAGS+= -I${BDB_INCLUDE_DIR}
|
||||||
CONFIGURE_ARGS+= --enable-bdb
|
CONFIGURE_ARGS+= --enable-bdb
|
||||||
PLIST_SUB+= BDB=""
|
PLIST_SUB+= BDB=""
|
||||||
LIB_DEPENDS+= db3.3:${PORTSDIR}/databases/db3
|
USE_BDB= yes
|
||||||
MAN1+= makebdb.1
|
MAN1+= makebdb.1
|
||||||
.else
|
.else
|
||||||
CONFIGURE_ARGS+= --disable-bdb
|
CONFIGURE_ARGS+= --disable-bdb
|
||||||
PLIST_SUB+= BDB="@comment "
|
PLIST_SUB+= BDB="@comment "
|
||||||
.endif
|
.endif
|
||||||
|
|
||||||
.if defined(WITH_NIS)
|
.if ${PORT_OPTIONS:MNIS}
|
||||||
CONFIGURE_ARGS+= --enable-nis
|
CONFIGURE_ARGS+= --enable-nis
|
||||||
PLIST_SUB+= NIS=""
|
PLIST_SUB+= NIS=""
|
||||||
.else
|
.else
|
||||||
|
@ -90,9 +85,9 @@ CONFIGURE_ARGS+= --disable-nis
|
||||||
PLIST_SUB+= NIS="@comment "
|
PLIST_SUB+= NIS="@comment "
|
||||||
.endif
|
.endif
|
||||||
|
|
||||||
.if defined(WITH_GDBM)
|
.if ${PORT_OPTIONS:MGDBM}
|
||||||
CONFIGURE_ARGS+= --enable-gdbm
|
CONFIGURE_ARGS+= --enable-gdbm
|
||||||
LIB_DEPENDS+= gdbm.4:${PORTSDIR}/databases/gdbm
|
LIB_DEPENDS+= gdbm:${PORTSDIR}/databases/gdbm
|
||||||
PLIST_SUB+= GDBM=""
|
PLIST_SUB+= GDBM=""
|
||||||
MAN1+= makegdbm.1
|
MAN1+= makegdbm.1
|
||||||
.else
|
.else
|
||||||
|
@ -100,8 +95,8 @@ CONFIGURE_ARGS+= --disable-gdbm
|
||||||
PLIST_SUB+= GDBM="@comment "
|
PLIST_SUB+= GDBM="@comment "
|
||||||
.endif
|
.endif
|
||||||
|
|
||||||
.if defined(WITH_MYSQL)
|
.if ${PORT_OPTIONS:MMYSQL}
|
||||||
USE_MYSQL= YES
|
USE_MYSQL= yes
|
||||||
CONFIGURE_ARGS+= --enable-mysql
|
CONFIGURE_ARGS+= --enable-mysql
|
||||||
PLIST_SUB+= MYSQL=""
|
PLIST_SUB+= MYSQL=""
|
||||||
MAN8+= perditiondb_mysql_makedb.8
|
MAN8+= perditiondb_mysql_makedb.8
|
||||||
|
@ -110,7 +105,7 @@ CONFIGURE_ARGS+= --disable-mysql
|
||||||
PLIST_SUB+= MYSQL="@comment "
|
PLIST_SUB+= MYSQL="@comment "
|
||||||
.endif
|
.endif
|
||||||
|
|
||||||
.if defined(WITH_PGSQL)
|
.if ${PORT_OPTIONS:MPGSQL}
|
||||||
CONFIGURE_ARGS+= --enable-pg
|
CONFIGURE_ARGS+= --enable-pg
|
||||||
USE_PGSQL= yes
|
USE_PGSQL= yes
|
||||||
PLIST_SUB+= PGSQL=""
|
PLIST_SUB+= PGSQL=""
|
||||||
|
@ -120,8 +115,8 @@ CONFIGURE_ARGS+= --disable-pg
|
||||||
PLIST_SUB+= PGSQL="@comment "
|
PLIST_SUB+= PGSQL="@comment "
|
||||||
.endif
|
.endif
|
||||||
|
|
||||||
.if defined(WITH_OPENLDAP)
|
.if ${PORT_OPTIONS:MOPENLDAP}
|
||||||
USE_OPENLDAP= YES
|
USE_OPENLDAP= yes
|
||||||
CONFIGURE_ARGS+= --enable-ldap \
|
CONFIGURE_ARGS+= --enable-ldap \
|
||||||
--with-ldap-schema-directory=${LOCALBASE}/etc/openldap/schema/ \
|
--with-ldap-schema-directory=${LOCALBASE}/etc/openldap/schema/ \
|
||||||
--disable-ldap-doc
|
--disable-ldap-doc
|
||||||
|
@ -132,9 +127,9 @@ CONFIGURE_ARGS+= --disable-ldap
|
||||||
PLIST_SUB+= OPENLDAP="@comment "
|
PLIST_SUB+= OPENLDAP="@comment "
|
||||||
.endif
|
.endif
|
||||||
|
|
||||||
.if defined(WITH_ODBC)
|
.if ${PORT_OPTIONS:MODBC}
|
||||||
CONFIGURE_ARGS+= --enable-odbc
|
CONFIGURE_ARGS+= --enable-odbc
|
||||||
LIB_DEPENDS+= odbc.2:${PORTSDIR}/databases/unixODBC
|
LIB_DEPENDS+= odbc:${PORTSDIR}/databases/unixODBC
|
||||||
PLIST_SUB+= ODBC=""
|
PLIST_SUB+= ODBC=""
|
||||||
MAN8+= perditiondb_odbc_makedb.8
|
MAN8+= perditiondb_odbc_makedb.8
|
||||||
.else
|
.else
|
||||||
|
@ -142,13 +137,14 @@ CONFIGURE_ARGS+= --disable-odbc
|
||||||
PLIST_SUB+= ODBC="@comment "
|
PLIST_SUB+= ODBC="@comment "
|
||||||
.endif
|
.endif
|
||||||
|
|
||||||
pre-everything:: show-options
|
post-patch:
|
||||||
|
cd ${WRKSRC} && ${REINPLACE_CMD} -e 's|-ldb|-l${BDB_LIB_NAME}|g' \
|
||||||
show-options:
|
configure \
|
||||||
@${SED} -ne 's/^##//p' ${.CURDIR}/Makefile
|
makebdb/Makefile.in \
|
||||||
|
perdition/db/bdb/Makefile.in
|
||||||
|
|
||||||
post-install:
|
post-install:
|
||||||
.if !defined(NOPORTDOCS)
|
.if ${PORT_OPTIONS:MDOCS}
|
||||||
@${MKDIR} ${DOCSDIR}
|
@${MKDIR} ${DOCSDIR}
|
||||||
@${INSTALL_DATA} ${WRKSRC}/etc/pam.d/perdition ${DOCSDIR}/perdition-pam.sample
|
@${INSTALL_DATA} ${WRKSRC}/etc/pam.d/perdition ${DOCSDIR}/perdition-pam.sample
|
||||||
@${ECHO_MSG} ""
|
@${ECHO_MSG} ""
|
||||||
|
|
|
@ -1,2 +1,2 @@
|
||||||
SHA256 (perdition-1.17.1.tar.gz) = e2abd57aa76b106591056ef835e26816c71c3b39dc55bc3aeba6dfeefac7af26
|
SHA256 (perdition-1.18.tar.gz) = cad541ca1881de8eec74106851d10c2027588b96cf1f70e3cf395f2c24c4ecaa
|
||||||
SIZE (perdition-1.17.1.tar.gz) = 638162
|
SIZE (perdition-1.18.tar.gz) = 602933
|
||||||
|
|
|
@ -1,23 +1,23 @@
|
||||||
--- etc/perdition/Makefile.in.orig 2007-11-02 15:40:32.000000000 +0100
|
--- etc/perdition/Makefile.in.orig 2012-03-20 05:07:55.000000000 -0700
|
||||||
+++ etc/perdition/Makefile.in 2007-11-02 15:45:43.000000000 +0100
|
+++ etc/perdition/Makefile.in 2012-12-12 16:48:33.000000000 -0800
|
||||||
@@ -259,16 +259,16 @@
|
@@ -303,14 +303,17 @@
|
||||||
@list='$(perditionconf_DATA)'; for p in $$list; do \
|
echo "$$d$$p"; \
|
||||||
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
done | $(am__base_list) | \
|
||||||
f=$(am__strip_dir) \
|
while read files; do \
|
||||||
- echo " $(perditionconfDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(perditionconfdir)/$$f'"; \
|
- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(perditionconfdir)'"; \
|
||||||
- $(perditionconfDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(perditionconfdir)/$$f"; \
|
- $(INSTALL_DATA) $$files "$(DESTDIR)$(perditionconfdir)" || exit $$?; \
|
||||||
+ echo " $(perditionconfDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(perditionconfdir)/$$f-dist'"; \
|
+ for p in $$files; do \
|
||||||
+ $(perditionconfDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(perditionconfdir)/$$f-dist"; \
|
+ $(am__strip_dir) \
|
||||||
|
+ echo " $(INSTALL_DATA) $$p '$(DESTDIR)$(perditionconfdir)/$$f-dist'"; \
|
||||||
|
+ $(INSTALL_DATA) $$p "$(DESTDIR)$(perditionconfdir)/$$f-dist" || exit $$?; \
|
||||||
|
+ done; \
|
||||||
done
|
done
|
||||||
|
|
||||||
uninstall-perditionconfDATA:
|
uninstall-perditionconfDATA:
|
||||||
@$(NORMAL_UNINSTALL)
|
@$(NORMAL_UNINSTALL)
|
||||||
@list='$(perditionconf_DATA)'; for p in $$list; do \
|
@list='$(perditionconf_DATA)'; test -n "$(perditionconfdir)" || list=; \
|
||||||
f=$(am__strip_dir) \
|
- files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
|
||||||
- echo " rm -f '$(DESTDIR)$(perditionconfdir)/$$f'"; \
|
+ files=`for p in $$list; do echo $$p-dist; done | sed -e 's|^.*/||'`; \
|
||||||
- rm -f "$(DESTDIR)$(perditionconfdir)/$$f"; \
|
test -n "$$files" || exit 0; \
|
||||||
+ echo " rm -f '$(DESTDIR)$(perditionconfdir)/$$f-dist'"; \
|
echo " ( cd '$(DESTDIR)$(perditionconfdir)' && rm -f" $$files ")"; \
|
||||||
+ rm -f "$(DESTDIR)$(perditionconfdir)/$$f-dist"; \
|
cd "$(DESTDIR)$(perditionconfdir)" && rm -f $$files
|
||||||
done
|
|
||||||
tags: TAGS
|
|
||||||
TAGS:
|
|
||||||
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- makebdb/Makefile.in.orig 2007-11-02 15:47:34.000000000 +0100
|
|
||||||
+++ makebdb/Makefile.in 2007-11-02 15:48:33.000000000 +0100
|
|
||||||
@@ -231,7 +231,7 @@
|
|
||||||
options.c \
|
|
||||||
options.h
|
|
||||||
|
|
||||||
-makebdb_LDADD = -L../libjain -L../libjain/.libs/ -ljain -ldb -lpopt \
|
|
||||||
+makebdb_LDADD = -L../libjain -L../libjain/.libs/ -ljain -ldb3 -lpopt \
|
|
||||||
@dmalloc_lib@
|
|
||||||
|
|
||||||
INCLUDES = -I$(top_srcdir)/libjain
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- makebdb/makebdb.c.orig Mon Apr 28 08:13:47 2003
|
|
||||||
+++ makebdb/makebdb.c Sun Jun 15 18:36:21 2003
|
|
||||||
@@ -35,7 +35,7 @@
|
|
||||||
#include <unistd.h>
|
|
||||||
#include <stdlib.h>
|
|
||||||
#include <ctype.h>
|
|
||||||
-#include <db.h>
|
|
||||||
+#include <db3/db.h>
|
|
||||||
|
|
||||||
#include "options.h"
|
|
||||||
|
|
10
mail/perdition/files/patch-makegdbm-options.h
Normal file
10
mail/perdition/files/patch-makegdbm-options.h
Normal file
|
@ -0,0 +1,10 @@
|
||||||
|
--- ./makegdbm/options.h.orig 2013-01-08 16:04:27.000000000 -0500
|
||||||
|
+++ ./makegdbm/options.h 2013-01-08 16:04:51.000000000 -0500
|
||||||
|
@@ -39,7 +39,6 @@
|
||||||
|
#endif
|
||||||
|
|
||||||
|
extern gdbm_error gdbm_errno;
|
||||||
|
-extern char *gdbm_version;
|
||||||
|
|
||||||
|
#define COPYRIGHT \
|
||||||
|
"(c) 1999 Horms <horms@verge.net.au>\nReleased under the GNU GPL\n"
|
|
@ -1,11 +0,0 @@
|
||||||
--- perdition/db/bdb/Makefile.in.orig 2007-11-02 15:49:39.000000000 +0100
|
|
||||||
+++ perdition/db/bdb/Makefile.in 2007-11-02 15:50:20.000000000 +0100
|
|
||||||
@@ -235,7 +235,7 @@
|
|
||||||
perditiondb_bdb.h
|
|
||||||
|
|
||||||
libperditiondb_bdb_la_LDFLAGS = -version-info 0:0:0
|
|
||||||
-libperditiondb_bdb_la_LIBADD = -ldb
|
|
||||||
+libperditiondb_bdb_la_LIBADD = -ldb3
|
|
||||||
INCLUDES = \
|
|
||||||
-I$(top_srcdir)/ \
|
|
||||||
-I$(top_srcdir)/perdition \
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- perdition/db/bdb/perditiondb_bdb.h.orig Tue Dec 6 15:58:20 2005
|
|
||||||
+++ perdition/db/bdb/perditiondb_bdb.h Tue Dec 6 15:58:34 2005
|
|
||||||
@@ -29,7 +29,7 @@
|
|
||||||
#include <unistd.h>
|
|
||||||
#include <stdlib.h>
|
|
||||||
#include <ctype.h>
|
|
||||||
-#include <db.h>
|
|
||||||
+#include <db3/db.h>
|
|
||||||
#include "log.h"
|
|
||||||
|
|
||||||
#ifndef PERDITIONDB_BDB_SYSCONFDIR
|
|
|
@ -0,0 +1,10 @@
|
||||||
|
--- ./perdition/db/gdbm/perditiondb_gdbm.h.orig 2013-01-08 16:05:30.000000000 -0500
|
||||||
|
+++ ./perdition/db/gdbm/perditiondb_gdbm.h 2013-01-08 16:05:40.000000000 -0500
|
||||||
|
@@ -31,7 +31,6 @@
|
||||||
|
#include <gdbm.h>
|
||||||
|
|
||||||
|
extern gdbm_error gdbm_errno;
|
||||||
|
-extern char *gdbm_version;
|
||||||
|
|
||||||
|
#ifndef PERDITIONDB_GDBM_SYSCONFDIR
|
||||||
|
#define PERDITIONDB_GDBM_SYSCONFDIR "/usr/local/etc/perdition"
|
|
@ -1,13 +1,11 @@
|
||||||
--- perdition/db/ldap/Makefile.in.orig Tue Dec 6 15:59:30 2005
|
--- perdition/db/ldap/Makefile.in.orig 2012-03-20 05:08:04.000000000 -0700
|
||||||
+++ perdition/db/ldap/Makefile.in Tue Dec 6 16:04:27 2005
|
+++ perdition/db/ldap/Makefile.in 2012-12-12 16:50:02.000000000 -0800
|
||||||
@@ -545,8 +545,8 @@
|
@@ -864,7 +864,7 @@
|
||||||
"$(DESTDIR)@ldap_schemadir@"; \
|
@LDAP_SCHEMA_TRUE@ test -n "@ldap_schemadir@"
|
||||||
fi; \
|
@LDAP_SCHEMA_TRUE@ mkdir -p "$(DESTDIR)@ldap_schemadir@"
|
||||||
if test -w "$(DESTDIR)@ldap_schemadir@"; then \
|
@LDAP_SCHEMA_TRUE@ chmod 755 "$(DESTDIR)@ldap_schemadir@"
|
||||||
- install -m644 $< \
|
-@LDAP_SCHEMA_TRUE@ install -m 644 $< "$(DESTDIR)@ldap_schemadir@/"
|
||||||
- "$(DESTDIR)@ldap_schemadir@/perdition.schema";\
|
+@LDAP_SCHEMA_TRUE@ for p in $< ; do $(am__strip_dir) install -m 644 $$p "$(DESTDIR)@ldap_schemadir@/$$f-dist" ; done
|
||||||
+ install -m644 $(schema_sources) \
|
|
||||||
+ "$(DESTDIR)@ldap_schemadir@/perdition.schema-dist";\
|
|
||||||
fi \
|
|
||||||
fi
|
|
||||||
|
|
||||||
|
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||||
|
# Otherwise a system limit (for SysV at least) may be exceeded.
|
||||||
|
|
|
@ -1,23 +1,23 @@
|
||||||
--- perdition/db/posix_regex/Makefile.in.orig 2007-11-02 15:53:56.000000000 +0100
|
--- perdition/db/posix_regex/Makefile.in.orig 2012-03-20 05:08:06.000000000 -0700
|
||||||
+++ perdition/db/posix_regex/Makefile.in 2007-11-02 15:55:31.000000000 +0100
|
+++ perdition/db/posix_regex/Makefile.in 2012-12-12 16:47:41.000000000 -0800
|
||||||
@@ -355,16 +355,16 @@
|
@@ -414,14 +414,17 @@
|
||||||
@list='$(conf_DATA)'; for p in $$list; do \
|
echo "$$d$$p"; \
|
||||||
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
done | $(am__base_list) | \
|
||||||
f=$(am__strip_dir) \
|
while read files; do \
|
||||||
- echo " $(confDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(confdir)/$$f'"; \
|
- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(confdir)'"; \
|
||||||
- $(confDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(confdir)/$$f"; \
|
- $(INSTALL_DATA) $$files "$(DESTDIR)$(confdir)" || exit $$?; \
|
||||||
+ echo " $(confDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(confdir)/$$f-dist'"; \
|
+ for p in $$files; do \
|
||||||
+ $(confDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(confdir)/$$f-dist"; \
|
+ $(am__strip_dir) \
|
||||||
|
+ echo " $(INSTALL_DATA) $$p '$(DESTDIR)$(confdir)/$$f-dist'"; \
|
||||||
|
+ $(INSTALL_DATA) $$p "$(DESTDIR)$(confdir)/$$f-dist" || exit $$?; \
|
||||||
|
+ done ; \
|
||||||
done
|
done
|
||||||
|
|
||||||
uninstall-confDATA:
|
uninstall-confDATA:
|
||||||
@$(NORMAL_UNINSTALL)
|
@$(NORMAL_UNINSTALL)
|
||||||
@list='$(conf_DATA)'; for p in $$list; do \
|
@list='$(conf_DATA)'; test -n "$(confdir)" || list=; \
|
||||||
f=$(am__strip_dir) \
|
- files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
|
||||||
- echo " rm -f '$(DESTDIR)$(confdir)/$$f'"; \
|
+ files=`for p in $$list; do echo $$p-dist; done | sed -e 's|^.*/||'`; \
|
||||||
- rm -f "$(DESTDIR)$(confdir)/$$f"; \
|
test -n "$$files" || exit 0; \
|
||||||
+ echo " rm -f '$(DESTDIR)$(confdir)/$$f-dist'"; \
|
echo " ( cd '$(DESTDIR)$(confdir)' && rm -f" $$files ")"; \
|
||||||
+ rm -f "$(DESTDIR)$(confdir)/$$f-dist"; \
|
cd "$(DESTDIR)$(confdir)" && rm -f $$files
|
||||||
done
|
|
||||||
|
|
||||||
ID: $(HEADERS) $(SOURCES) $(LISP) $(TAGS_FILES)
|
|
||||||
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- perdition/Makefile.in.orig Tue Dec 6 16:08:58 2005
|
|
||||||
+++ perdition/Makefile.in Tue Dec 6 16:09:36 2005
|
|
||||||
@@ -560,8 +560,6 @@
|
|
||||||
for i in pop3 pop3s imap4 imap4s imaps; do \
|
|
||||||
(cd $(DESTDIR)$(sbindir) && rm -f perdition.$$i && \
|
|
||||||
ln -sf perdition perdition.$$i); \
|
|
||||||
- (cd $(DESTDIR)$(mandir)/man8 && rm -f perdition.$$i && \
|
|
||||||
- ln -sf perdition.8 perdition.$$i.8); \
|
|
||||||
done
|
|
||||||
|
|
||||||
uninstall-local:
|
|
|
@ -9,11 +9,6 @@ etc/perdition/perdition.conf-dist
|
||||||
etc/perdition/popmap-dist
|
etc/perdition/popmap-dist
|
||||||
etc/perdition/Makefile.popmap-dist
|
etc/perdition/Makefile.popmap-dist
|
||||||
etc/perdition/Makefile
|
etc/perdition/Makefile
|
||||||
include/jain.h
|
|
||||||
lib/libjain.so.0
|
|
||||||
lib/libjain.so
|
|
||||||
lib/libjain.la
|
|
||||||
lib/libjain.a
|
|
||||||
%%BDB%%lib/libperditiondb_bdb.so.0
|
%%BDB%%lib/libperditiondb_bdb.so.0
|
||||||
%%BDB%%lib/libperditiondb_bdb.so
|
%%BDB%%lib/libperditiondb_bdb.so
|
||||||
%%BDB%%lib/libperditiondb_bdb.la
|
%%BDB%%lib/libperditiondb_bdb.la
|
||||||
|
|
Loading…
Add table
Reference in a new issue