mirror of
https://git.freebsd.org/ports.git
synced 2025-05-07 11:20:46 -04:00
1) Add OPTIONS support for:
- SOCKETS - Unix domain socket support and tests - SCTP - Stream Control Transmission Protocol support and tests - EXS - ICSC async socket support - HISTOGRAM - Optional histogram output - OMNI - Enable OMNI tests 2) Patch to $WRKSRC/configure which fixes CPU measurement and ROUTE lookup routines in netperf, which result in this output: ------------- checking which CPU utilization measurement type to use... "none. Consider teaching configure about your platform." checking which route lookup type to use... "none. Consider teaching configure about your platform." -------------- 3) Add to default configure_args --enable-dirty --enable-demo --enable-burst --enable-intervals Note: these just add additional command arguments and options, and are not globally enabled in netperf so wont affect existing users/tests. Submitted by: koobs (No email address by the request)
This commit is contained in:
parent
445960e818
commit
db38baefd0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=296647
2 changed files with 73 additions and 4 deletions
|
@ -7,18 +7,58 @@
|
|||
|
||||
PORTNAME= netperf
|
||||
PORTVERSION= 2.5.0
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= benchmarks ipv6
|
||||
MASTER_SITES= ftp://ftp.netperf.org/netperf/
|
||||
MASTER_SITES= ftp://ftp.netperf.org/netperf/ \
|
||||
http://fossies.org/unix/misc/
|
||||
|
||||
MAINTAINER= sumikawa@FreeBSD.org
|
||||
COMMENT= Network performance benchmarking package
|
||||
|
||||
OPTIONS= SOCKETS "Enable Unix Domain socket support" On \
|
||||
SCTP "Enable SCTP support" On \
|
||||
EXS "Enable ICSC async socket support" On \
|
||||
HISTOGRAM "Enable optional histogram output" On \
|
||||
OMNI "Enable OMNI tests" Off \
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= "transform="
|
||||
CONFIGURE_ARGS= --program-prefix="" --program-suffix=""
|
||||
MAN1= netperf.1 netserver.1
|
||||
CONFIGURE_ARGS= --program-prefix="" --program-suffix="" --enable-dirty \
|
||||
--enable-demo --enable-burst --enable-intervals
|
||||
|
||||
.if !defined(WITHOUT_SOCKETS)
|
||||
CONFIGURE_ARGS+= --enable-unixdomain
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-unixdomain
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_SCTP)
|
||||
CONFIGURE_ARGS+= --enable-sctp
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-sctp
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_EXS)
|
||||
CONFIGURE_ARGS+= --enable-exs
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-exs
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_HISTOGRAM)
|
||||
CONFIGURE_ARGS+= --enable-histogram
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-histogram
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_OMNI)
|
||||
CONFIGURE_ARGS+= --enable-omni
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-omni
|
||||
.endif
|
||||
|
||||
MAN1= netperf.1 netserver.1
|
||||
INFO= netperf
|
||||
SCRIPTS= arr_script packet_byte_script sctp_stream_script snapshot_script \
|
||||
tcp_range_script tcp_rr_script tcp_stream_script udp_rr_script \
|
||||
|
|
29
benchmarks/netperf/files/patch-configure
Normal file
29
benchmarks/netperf/files/patch-configure
Normal file
|
@ -0,0 +1,29 @@
|
|||
--- ./configure.orig 2012-05-12 07:05:20.000000000 +1000
|
||||
+++ ./configure 2012-05-12 07:22:49.000000000 +1000
|
||||
@@ -6594,7 +6594,7 @@
|
||||
done
|
||||
|
||||
case "$host" in
|
||||
- *-*-freebsd78.*)
|
||||
+ *-*-freebsd[7-9].*)
|
||||
# FreeBSD 7.x and later SCTP support doesn't need -lsctp.
|
||||
;;
|
||||
*)
|
||||
@@ -7169,7 +7169,7 @@
|
||||
enable_cpuutil="kstat - auto"
|
||||
NETCPU_SOURCE="kstat"
|
||||
;;
|
||||
- *-*-freebsd[4-7].* | *-*-netbsd[1-9].* )
|
||||
+ *-*-freebsd[4-9].* | *-*-netbsd[1-9].* )
|
||||
use_cpuutil=true
|
||||
|
||||
$as_echo "#define USE_SYSCTL /**/" >>confdefs.h
|
||||
@@ -7238,7 +7238,7 @@
|
||||
enable_rtlookup="rtmget - auto"
|
||||
NETRTLKUP_SOURCE="rtmget"
|
||||
;;
|
||||
- *-*-freebsd[4-7].* | *-*-darwin*)
|
||||
+ *-*-freebsd[4-9].* | *-*-darwin*)
|
||||
use_rtlookup=true
|
||||
enable_rtlookup="rtmget - auto"
|
||||
NETRTLKUP_SOURCE="rtmget"
|
Loading…
Add table
Reference in a new issue