mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
net/belle-sip: Update version 5.2.94=>5.4.2
Changelog: https://gitlab.linphone.org/BC/public/belle-sip/-/tags/5.4.2 Sponsored by: Cybermancer Infosec
This commit is contained in:
parent
5acdf03123
commit
d9dbd96087
8 changed files with 2571 additions and 63 deletions
|
@ -1,5 +1,5 @@
|
||||||
PORTNAME= belle-sip
|
PORTNAME= belle-sip
|
||||||
DISTVERSION= 5.2.94
|
DISTVERSION= 5.4.2
|
||||||
CATEGORIES= net java
|
CATEGORIES= net java
|
||||||
|
|
||||||
MAINTAINER= bofh@FreeBSD.org
|
MAINTAINER= bofh@FreeBSD.org
|
||||||
|
@ -9,23 +9,24 @@ WWW= https://www.linphone.org/technical-corner/belle-sip.html
|
||||||
LICENSE= GPLv2+
|
LICENSE= GPLv2+
|
||||||
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
|
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
|
||||||
|
|
||||||
LIB_DEPENDS= libantlr3c.so:devel/libantlr3c \
|
BUILD_DEPENDS= ${LOCALBASE}/lib/libbctoolbox.a:net/bctoolbox \
|
||||||
libbctoolbox.so:net/bctoolbox \
|
${LOCALBASE}/lib/libbcunit.a:devel/bcunit \
|
||||||
libbelr.so:textproc/belr
|
${LOCALBASE}/lib/libbelr.a:textproc/belr
|
||||||
|
LIB_DEPENDS= libantlr3c.so:devel/libantlr3c
|
||||||
|
|
||||||
USES= cmake cpe java:build tar:bz2
|
USES= cmake cpe java:build tar:bz2
|
||||||
CPE_VENDOR= linphone
|
CPE_VENDOR= linphone
|
||||||
USE_GITLAB= yes
|
USE_GITLAB= yes
|
||||||
GL_SITE= https://gitlab.linphone.org/BC
|
GL_SITE= https://gitlab.linphone.org/BC
|
||||||
GL_ACCOUNT= public
|
GL_ACCOUNT= public
|
||||||
|
GL_TUPLE= https://gitlab.linphone.org/BC/public:external:cpp-httplib:a2ed0d11c134b6c23da275103b5183b423cea8a8:httplib/tester/cpp-httplib
|
||||||
USE_LDCONFIG= yes
|
USE_LDCONFIG= yes
|
||||||
|
|
||||||
CMAKE_ARGS= -DCMAKE_PREFIX_PATH=${LOCALBASE} \
|
CMAKE_ARGS= -DCMAKE_PREFIX_PATH=${LOCALBASE} \
|
||||||
-DENABLE_STATIC=NO \
|
|
||||||
-DENABLE_STRICT=NO \
|
-DENABLE_STRICT=NO \
|
||||||
-DENABLE_TESTS=NO
|
-DENABLE_TESTS=NO \
|
||||||
|
-DENABLE_UNIT_TESTS=NO
|
||||||
|
|
||||||
post-patch:
|
LDFLAGS+= -lpthread
|
||||||
@${REINPLACE_CMD} '/clock_gettime/d' ${WRKSRC}/CMakeLists.txt
|
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.include <bsd.port.mk>
|
||||||
|
|
|
@ -1,3 +1,5 @@
|
||||||
TIMESTAMP = 1690557657
|
TIMESTAMP = 1743022710
|
||||||
SHA256 (belle-sip-5.2.94.tar.bz2) = d94d4310a48162f480d60076867f325e99ac256d4a871d8e1062810c63e90f80
|
SHA256 (belle-sip-5.4.2.tar.bz2) = a8d74d193a3ac71c338c69b4047e91e59c1af9eb9640a2882aee4be8a6c5a889
|
||||||
SIZE (belle-sip-5.2.94.tar.bz2) = 3436258
|
SIZE (belle-sip-5.4.2.tar.bz2) = 655526
|
||||||
|
SHA256 (external-cpp-httplib-a2ed0d11c134b6c23da275103b5183b423cea8a8_GL0.tar.gz) = 9b4db463ede003979bd5ea9ec97c7b80e06b1d6da3f05ce39c43670c6807a0f0
|
||||||
|
SIZE (external-cpp-httplib-a2ed0d11c134b6c23da275103b5183b423cea8a8_GL0.tar.gz) = 1153181
|
||||||
|
|
2516
net/belle-sip/files/belle_sip_headers_impl.cc
Normal file
2516
net/belle-sip/files/belle_sip_headers_impl.cc
Normal file
File diff suppressed because it is too large
Load diff
18
net/belle-sip/files/patch-CMakeLists.txt
Normal file
18
net/belle-sip/files/patch-CMakeLists.txt
Normal file
|
@ -0,0 +1,18 @@
|
||||||
|
--- CMakeLists.txt.orig 2025-03-19 14:44:20 UTC
|
||||||
|
+++ CMakeLists.txt
|
||||||
|
@@ -60,7 +60,6 @@ check_library_exists("dl" "dlopen" "" HAVE_LIBDL)
|
||||||
|
list(APPEND CMAKE_MODULE_PATH "${PROJECT_SOURCE_DIR}/cmake")
|
||||||
|
|
||||||
|
check_library_exists("dl" "dlopen" "" HAVE_LIBDL)
|
||||||
|
-check_library_exists("rt" "clock_gettime" "" HAVE_LIBRT)
|
||||||
|
|
||||||
|
cmake_push_check_state(RESET)
|
||||||
|
check_symbol_exists("res_ndestroy" "resolv.h" HAVE_RES_NDESTROY)
|
||||||
|
@@ -78,6 +77,7 @@ find_package(Threads)
|
||||||
|
|
||||||
|
find_package(Threads)
|
||||||
|
|
||||||
|
+find_package(OpenSSL REQUIRED)
|
||||||
|
find_package(Belr 5.3.0 REQUIRED)
|
||||||
|
find_package(BCToolbox 5.3.0 REQUIRED OPTIONAL_COMPONENTS tester)
|
||||||
|
#Mandatory to init default compilation flags
|
|
@ -1,8 +1,8 @@
|
||||||
--- src/belle_sip_headers_impl.c.orig 2022-05-18 04:20:06 UTC
|
--- src/belle_sip_headers_impl.cc.orig 2025-03-26 20:44:32 UTC
|
||||||
+++ src/belle_sip_headers_impl.c
|
+++ src/belle_sip_headers_impl.cc
|
||||||
@@ -1873,11 +1873,6 @@ BELLESIP_EXPORT time_t belle_sip_header_date_get_time(
|
@@ -2084,11 +2084,6 @@ BELLESIP_EXPORT time_t belle_sip_header_date_get_time(
|
||||||
char tmp2[17] ={0};
|
char tmp2[17] = {0};
|
||||||
int i,j;
|
int i, j;
|
||||||
time_t seconds;
|
time_t seconds;
|
||||||
-#if defined(BELLE_SIP_WINDOWS_UNIVERSAL) || defined(BELLE_SIP_MSC_VER_GREATER_19)
|
-#if defined(BELLE_SIP_WINDOWS_UNIVERSAL) || defined(BELLE_SIP_MSC_VER_GREATER_19)
|
||||||
- long adjust_timezone;
|
- long adjust_timezone;
|
||||||
|
@ -11,10 +11,10 @@
|
||||||
-#endif
|
-#endif
|
||||||
|
|
||||||
/* time headers are in GMT as spec says */
|
/* time headers are in GMT as spec says */
|
||||||
sscanf(obj->date,"%3c,%d %16s %d %d:%d:%d",tmp1,&ret.tm_mday,tmp2,
|
sscanf(obj->date, "%3c,%d %16s %d %d:%d:%d", tmp1, &ret.tm_mday, tmp2, &ret.tm_year, &ret.tm_hour, &ret.tm_min,
|
||||||
@@ -1899,25 +1894,11 @@ success:
|
@@ -2110,25 +2105,11 @@ success:
|
||||||
success:
|
success:
|
||||||
ret.tm_isdst=0;
|
ret.tm_isdst = 0;
|
||||||
|
|
||||||
-#if TARGET_IPHONE_SIMULATOR
|
-#if TARGET_IPHONE_SIMULATOR
|
||||||
- /* 'timezone' is buggy on iOS simulator, use the timegm() function to convert to UTC timestamp
|
- /* 'timezone' is buggy on iOS simulator, use the timegm() function to convert to UTC timestamp
|
||||||
|
@ -30,12 +30,12 @@
|
||||||
-#endif
|
-#endif
|
||||||
-#endif
|
-#endif
|
||||||
-
|
-
|
||||||
if (seconds==(time_t)-1) {
|
if (seconds == (time_t)-1) {
|
||||||
- belle_sip_error("mktime() failed: %s",strerror(errno));
|
- belle_sip_error("mktime() failed: %s", strerror(errno));
|
||||||
+ belle_sip_error("timegm() failed: %s",strerror(errno));
|
+ belle_sip_error("timegm() failed: %s", strerror(errno));
|
||||||
return (time_t)-1;
|
return (time_t)-1;
|
||||||
}
|
}
|
||||||
- return seconds-(time_t)adjust_timezone;
|
- return seconds - (time_t)adjust_timezone;
|
||||||
+ return seconds;
|
+ return seconds;
|
||||||
}
|
}
|
||||||
|
|
|
@ -1,10 +1,10 @@
|
||||||
--- src/belle_sip_internal.h.orig 2022-05-18 04:20:06 UTC
|
--- src/belle_sip_internal.h.orig 2025-03-19 14:44:20 UTC
|
||||||
+++ src/belle_sip_internal.h
|
+++ src/belle_sip_internal.h
|
||||||
@@ -25,6 +25,7 @@
|
@@ -21,6 +21,7 @@
|
||||||
#include <stdio.h>
|
#define belle_utils_h
|
||||||
#include <sys/types.h>
|
|
||||||
#include <errno.h>
|
#include <errno.h>
|
||||||
+#include <netinet/in.h>
|
+#include <netinet/in.h>
|
||||||
|
#include <stdio.h>
|
||||||
/* include all public headers*/
|
#include <stdlib.h>
|
||||||
#include "belle-sip/belle-sip.h"
|
#include <string.h>
|
||||||
|
|
|
@ -1,29 +0,0 @@
|
||||||
--- src/dns/dns.c.orig 2022-06-15 16:24:13 UTC
|
|
||||||
+++ src/dns/dns.c
|
|
||||||
@@ -5012,7 +5012,7 @@ static int guess_scope_id(void){
|
|
||||||
struct ifaddrs *ifp;
|
|
||||||
struct ifaddrs *ifpstart;
|
|
||||||
int scope_id = -1;
|
|
||||||
-
|
|
||||||
+
|
|
||||||
if (getifaddrs(&ifpstart) < 0) {
|
|
||||||
return -1;
|
|
||||||
}
|
|
||||||
@@ -5035,7 +5035,7 @@ static int guess_scope_id(void){
|
|
||||||
}
|
|
||||||
}
|
|
||||||
freeifaddrs(ifpstart);
|
|
||||||
-
|
|
||||||
+
|
|
||||||
return scope_id;
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -5044,7 +5044,7 @@ int dns_resconf_loadfromresolv(struct dns_resolv_conf
|
|
||||||
union res_sockaddr_union addresses[3];
|
|
||||||
int i,error,write_index;
|
|
||||||
|
|
||||||
-
|
|
||||||
+ memset(&res, 0, sizeof(res));
|
|
||||||
if ((error = res_ninit(&res))) {
|
|
||||||
return error;
|
|
||||||
}
|
|
|
@ -1,10 +1,10 @@
|
||||||
include/belle-sip/auth-helper.h
|
include/belle-sip/auth-helper.h
|
||||||
|
include/belle-sip/bearer-token.h
|
||||||
include/belle-sip/belle-sdp.h
|
include/belle-sip/belle-sdp.h
|
||||||
include/belle-sip/belle-sip.h
|
include/belle-sip/belle-sip.h
|
||||||
include/belle-sip/bodyhandler.h
|
include/belle-sip/bodyhandler.h
|
||||||
include/belle-sip/defs.h
|
include/belle-sip/defs.h
|
||||||
include/belle-sip/dialog.h
|
include/belle-sip/dialog.h
|
||||||
include/belle-sip/dict.h
|
|
||||||
include/belle-sip/generic-uri.h
|
include/belle-sip/generic-uri.h
|
||||||
include/belle-sip/headers.h
|
include/belle-sip/headers.h
|
||||||
include/belle-sip/http-listener.h
|
include/belle-sip/http-listener.h
|
||||||
|
@ -28,11 +28,11 @@ include/belle-sip/transaction.h
|
||||||
include/belle-sip/types.h
|
include/belle-sip/types.h
|
||||||
include/belle-sip/utils.h
|
include/belle-sip/utils.h
|
||||||
include/belle-sip/wakelock.h
|
include/belle-sip/wakelock.h
|
||||||
lib/libbellesip.so
|
lib/libbelle-sip.a
|
||||||
lib/libbellesip.so.1
|
|
||||||
libdata/pkgconfig/belle-sip.pc
|
libdata/pkgconfig/belle-sip.pc
|
||||||
lib/cmake/BelleSIP/BelleSIPConfig.cmake
|
lib/cmake/BelleSIP/BelleSIPConfig.cmake
|
||||||
lib/cmake/BelleSIP/BelleSIPConfigVersion.cmake
|
lib/cmake/BelleSIP/BelleSIPConfigVersion.cmake
|
||||||
lib/cmake/BelleSIP/BelleSIPTargets-%%CMAKE_BUILD_TYPE%%.cmake
|
lib/cmake/BelleSIP/BelleSIPTargets-%%CMAKE_BUILD_TYPE%%.cmake
|
||||||
lib/cmake/BelleSIP/BelleSIPTargets.cmake
|
lib/cmake/BelleSIP/BelleSIPTargets.cmake
|
||||||
share/belr/grammars/sdp_grammar
|
share/belr/grammars/sdp_grammar.belr
|
||||||
|
share/belr/grammars/sip_grammar.belr
|
||||||
|
|
Loading…
Add table
Reference in a new issue