mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
graphics/py-pyganim: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
This commit is contained in:
parent
459d857af3
commit
d7fce4c1c7
2 changed files with 22 additions and 2 deletions
|
@ -1,6 +1,6 @@
|
||||||
PORTNAME= pyganim
|
PORTNAME= pyganim
|
||||||
PORTVERSION= 0.9.2
|
PORTVERSION= 0.9.2
|
||||||
PORTREVISION= 5
|
PORTREVISION= 6
|
||||||
CATEGORIES= graphics python
|
CATEGORIES= graphics python
|
||||||
MASTER_SITES= PYPI
|
MASTER_SITES= PYPI
|
||||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||||
|
@ -13,10 +13,12 @@ WWW= https://inventwithpython.com/pyganim/ \
|
||||||
|
|
||||||
LICENSE= BSD2CLAUSE
|
LICENSE= BSD2CLAUSE
|
||||||
|
|
||||||
|
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
|
||||||
|
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
|
||||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}game>=0:devel/py-game@${PY_FLAVOR}
|
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}game>=0:devel/py-game@${PY_FLAVOR}
|
||||||
|
|
||||||
USES= python zip
|
USES= python zip
|
||||||
USE_PYTHON= autoplist concurrent distutils
|
USE_PYTHON= autoplist concurrent pep517
|
||||||
|
|
||||||
NO_ARCH= yes
|
NO_ARCH= yes
|
||||||
|
|
||||||
|
|
18
graphics/py-pyganim/files/patch-setup.py
Normal file
18
graphics/py-pyganim/files/patch-setup.py
Normal file
|
@ -0,0 +1,18 @@
|
||||||
|
--- setup.py.orig 2015-08-03 09:20:46 UTC
|
||||||
|
+++ setup.py
|
||||||
|
@@ -2,7 +2,7 @@ setup(
|
||||||
|
|
||||||
|
|
||||||
|
setup(
|
||||||
|
- name='Pyganim',
|
||||||
|
+ name='pyganim',
|
||||||
|
version='0.9.2',
|
||||||
|
url='http://inventwithpython.com/pyganim',
|
||||||
|
author='Al Sweigart',
|
||||||
|
@@ -28,4 +28,4 @@ setup(
|
||||||
|
'Programming Language :: Python :: 3.4',
|
||||||
|
'Programming Language :: Python :: 3.5',
|
||||||
|
],
|
||||||
|
-)
|
||||||
|
\ No newline at end of file
|
||||||
|
+)
|
Loading…
Add table
Reference in a new issue