mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
x11/xfce4-terminal: Update to 1.1.5
- Convert build to using meson - Add option to control WAYLAND support
This commit is contained in:
parent
f6b6a54870
commit
d5c6e7cbf7
3 changed files with 37 additions and 12 deletions
|
@ -1,5 +1,5 @@
|
||||||
PORTNAME= xfce4-terminal
|
PORTNAME= xfce4-terminal
|
||||||
PORTVERSION= 1.1.4
|
PORTVERSION= 1.1.5
|
||||||
CATEGORIES= x11 xfce
|
CATEGORIES= x11 xfce
|
||||||
MASTER_SITES= XFCE/apps
|
MASTER_SITES= XFCE/apps
|
||||||
DIST_SUBDIR= xfce4
|
DIST_SUBDIR= xfce4
|
||||||
|
@ -11,22 +11,29 @@ WWW= https://docs.xfce.org/apps/xfce4-terminal/start
|
||||||
LICENSE= GPLv2
|
LICENSE= GPLv2
|
||||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||||
|
|
||||||
|
BUILD_DEPENDS= ${LOCALBASE}/share/xml/docbook/4.4/catalog.xml:textproc/docbook-xml \
|
||||||
|
${LOCALBASE}/share/xsl/docbook/html/refentry.xsl:textproc/docbook-xsl \
|
||||||
|
xsltproc:textproc/libxslt
|
||||||
LIB_DEPENDS= libpcre2-8.so:devel/pcre2
|
LIB_DEPENDS= libpcre2-8.so:devel/pcre2
|
||||||
|
|
||||||
USES= compiler:c11 gettext-tools gmake gnome pkgconfig tar:bzip2 xfce \
|
USES= compiler:c11 gettext-tools gnome meson pkgconfig tar:xz xfce \
|
||||||
xorg
|
xorg
|
||||||
USE_GNOME= cairo gdkpixbuf glib20 gtk30 vte3
|
USE_GNOME= cairo gdkpixbuf glib20 gtk30 vte3
|
||||||
USE_XFCE= libmenu xfconf
|
USE_XFCE= libmenu xfconf
|
||||||
USE_XORG= ice sm x11
|
USE_XORG= ice sm x11
|
||||||
|
|
||||||
GNU_CONFIGURE= yes
|
MESON_ARGS= -Dlibutempter=enabled
|
||||||
CONFIGURE_ARGS= --with-utempter
|
|
||||||
INSTALL_TARGET= install-strip
|
|
||||||
|
|
||||||
OPTIONS_DEFINE= NLS
|
OPTIONS_DEFINE= NLS WAYLAND
|
||||||
OPTIONS_SUB= yes
|
OPTIONS_DEFAULT= WAYLAND
|
||||||
|
OPTIONS_SUB= yes
|
||||||
|
|
||||||
NLS_USES= gettext-runtime
|
NLS_USES= gettext-runtime
|
||||||
NLS_CONFIGURE_ENABLE= nls
|
|
||||||
|
WAYLAND_LIB_DEPENDS= libgtk-layer-shell.so:x11-toolkits/gtk-layer-shell
|
||||||
|
WAYLAND_MESON_ENABLED= gtk-layer-shell wayland
|
||||||
|
|
||||||
|
post-patch-NLS-off:
|
||||||
|
@${REINPLACE_CMD} -e "/^subdir('po')/d" ${WRKSRC}/meson.build
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.include <bsd.port.mk>
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
TIMESTAMP = 1735174820
|
TIMESTAMP = 1743025057
|
||||||
SHA256 (xfce4/xfce4-terminal-1.1.4.tar.bz2) = 873c921da1f4b986ffb459d4960789c9c063af98648c9f0ca146dc6f6f5b71b7
|
SHA256 (xfce4/xfce4-terminal-1.1.5.tar.xz) = 3c5b1d3a01a9a113852ac0f77d1c85bf3a356b43de33ec805b21ceca7d6f0a63
|
||||||
SIZE (xfce4/xfce4-terminal-1.1.4.tar.bz2) = 1498643
|
SIZE (xfce4/xfce4-terminal-1.1.5.tar.xz) = 440192
|
||||||
|
|
18
x11/xfce4-terminal/files/patch-terminal_terminal-util.c
Normal file
18
x11/xfce4-terminal/files/patch-terminal_terminal-util.c
Normal file
|
@ -0,0 +1,18 @@
|
||||||
|
--- terminal/terminal-util.c.orig 2025-03-26 18:40:26 UTC
|
||||||
|
+++ terminal/terminal-util.c
|
||||||
|
@@ -30,13 +30,13 @@
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#ifdef __FreeBSD__
|
||||||
|
-#include <libprocstat.h>
|
||||||
|
-#include <libutil.h>
|
||||||
|
#include <sys/param.h>
|
||||||
|
#include <sys/queue.h>
|
||||||
|
#include <sys/socket.h>
|
||||||
|
#include <sys/types.h>
|
||||||
|
#include <sys/user.h>
|
||||||
|
+#include <libprocstat.h>
|
||||||
|
+#include <libutil.h>
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#ifdef ENABLE_X11
|
Loading…
Add table
Reference in a new issue