multimedia/svt-*: hook GStreamer plugins

This commit is contained in:
Jan Beich 2019-05-12 06:36:01 +00:00
parent ccad449cdd
commit d4c68d5eb2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=501363
11 changed files with 136 additions and 0 deletions

View file

@ -145,6 +145,9 @@
SUBDIR += gstreamer1-plugins-resindvd SUBDIR += gstreamer1-plugins-resindvd
SUBDIR += gstreamer1-plugins-rtmp SUBDIR += gstreamer1-plugins-rtmp
SUBDIR += gstreamer1-plugins-smoothstreaming SUBDIR += gstreamer1-plugins-smoothstreaming
SUBDIR += gstreamer1-plugins-svt-av1
SUBDIR += gstreamer1-plugins-svt-hevc
SUBDIR += gstreamer1-plugins-svt-vp9
SUBDIR += gstreamer1-plugins-theora SUBDIR += gstreamer1-plugins-theora
SUBDIR += gstreamer1-plugins-ttml SUBDIR += gstreamer1-plugins-ttml
SUBDIR += gstreamer1-plugins-ugly SUBDIR += gstreamer1-plugins-ugly

View file

@ -0,0 +1,32 @@
# $FreeBSD$
PORTNAME= svt-av1
PORTVERSION= s20180509
CATEGORIES= multimedia
PKGNAMEPREFIX= gstreamer1-plugins-
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
PATCHFILES= c77dc3f81301.patch:-p2
MAINTAINER= jbeich@FreeBSD.org
COMMENT= GStreamer (svt-av1) plugin
LICENSE= LGPL21+ # based on SPDX header
LICENSE_FILE= ${_LICENSE_STORE}/LGPL21
LIB_DEPENDS= libSvtAv1Enc.so:multimedia/svt-av1
USES= meson pkgconfig
USE_GITHUB= yes
USE_GNOME= glib20
USE_GSTREAMER1= yes
GH_ACCOUNT= OpenVisualCloud
GH_PROJECT= SVT-AV1
GH_TAGNAME= ad4522fb
WRKSRC_SUBDIR= gstreamer-plugin
PLIST_FILES= lib/gstreamer-1.0/libgstsvtav1enc.so
post-patch:
@${REINPLACE_CMD} '/-O2/d' ${WRKSRC}/meson.build
.include <bsd.port.mk>

View file

@ -0,0 +1,5 @@
TIMESTAMP = 1557368472
SHA256 (OpenVisualCloud-SVT-AV1-s20180509-ad4522fb_GH0.tar.gz) = c2d12fe52ab328c9e59f27f23acda448703188340fb17d44d270820d276f3ae4
SIZE (OpenVisualCloud-SVT-AV1-s20180509-ad4522fb_GH0.tar.gz) = 2226530
SHA256 (c77dc3f81301.patch) = d94814e6fea033c04c6c10b195e28139639e53c298e488c077fb60fa0cbcbf6d
SIZE (c77dc3f81301.patch) = 848

View file

@ -0,0 +1,4 @@
This plugin provides svtav1enc element to GStreamer in order to use
the Scalable Video Technology for AV1 Encoder.
WWW: https://01.org/svt

View file

@ -0,0 +1,30 @@
# $FreeBSD$
PORTNAME= svt-hevc
DISTVERSIONPREFIX= v
DISTVERSION= 1.3.0-32
DISTVERSIONSUFFIX= -ga0dcd77
CATEGORIES= multimedia
PKGNAMEPREFIX= gstreamer1-plugins-
MAINTAINER= jbeich@FreeBSD.org
COMMENT= GStreamer (svt-hevc) plugin
LICENSE= LGPL21+ # based on SPDX header
LICENSE_FILE= ${_LICENSE_STORE}/LGPL21
LIB_DEPENDS= libSvtHevcEnc.so:multimedia/svt-hevc
USES= meson pkgconfig
USE_GITHUB= yes
USE_GNOME= glib20
USE_GSTREAMER1= yes
GH_ACCOUNT= OpenVisualCloud
GH_PROJECT= SVT-HEVC
WRKSRC_SUBDIR= gstreamer-plugin
PLIST_FILES= lib/gstreamer-1.0/libgstsvthevcenc.so
post-patch:
@${REINPLACE_CMD} '/-O2/d' ${WRKSRC}/meson.build
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
TIMESTAMP = 1557301098
SHA256 (OpenVisualCloud-SVT-HEVC-v1.3.0-32-ga0dcd77_GH0.tar.gz) = cfff9280afd366bea73d093bdfa0a82b700345f09ce486ef7edc0399ab1fab13
SIZE (OpenVisualCloud-SVT-HEVC-v1.3.0-32-ga0dcd77_GH0.tar.gz) = 1165629

View file

@ -0,0 +1,19 @@
encoderColorFormat was added after 1.3.0, so omit it for now.
../gstsvthevcenc.c:732:15: error: no member named 'encoderColorFormat' in 'struct EB_H265_ENC_CONFIGURATION'
svt_config->encoderColorFormat = EB_YUV420;
~~~~~~~~~~ ^
../gstsvthevcenc.c:732:36: error: use of undeclared identifier 'EB_YUV420'
svt_config->encoderColorFormat = EB_YUV420;
^
--- gstsvthevcenc.c.orig 2019-03-27 13:22:12 UTC
+++ gstsvthevcenc.c
@@ -729,7 +729,6 @@ set_default_svt_configuration (EB_H265_ENC_CONFIGURATI
svt_config->recoveryPointSeiFlag = FALSE;
svt_config->enableTemporalId = 1;
svt_config->encoderBitDepth = 8;
- svt_config->encoderColorFormat = EB_YUV420;
svt_config->compressedTenBitFormat = FALSE;
svt_config->profile = 1;
svt_config->tier = 0;

View file

@ -0,0 +1,4 @@
This plugin provides svtav1enc element to GStreamer in order to use
the Scalable Video Technology for HEVC Encoder.
WWW: https://01.org/svt

View file

@ -0,0 +1,29 @@
# $FreeBSD$
PORTNAME= svt-vp9
PORTVERSION= s20180426
CATEGORIES= multimedia
PKGNAMEPREFIX= gstreamer1-plugins-
MAINTAINER= jbeich@FreeBSD.org
COMMENT= GStreamer (svt-vp9) plugin
LICENSE= LGPL21+ # based on SPDX header
LICENSE_FILE= ${_LICENSE_STORE}/LGPL21
LIB_DEPENDS= libSvtVp9Enc.so:multimedia/svt-vp9
USES= meson pkgconfig
USE_GITHUB= yes
USE_GNOME= glib20
USE_GSTREAMER1= yes
GH_ACCOUNT= OpenVisualCloud
GH_PROJECT= SVT-VP9
GH_TAGNAME= ce24589
WRKSRC_SUBDIR= gstreamer-plugin
PLIST_FILES= lib/gstreamer-1.0/libgstsvtvp9enc.so
post-patch:
@${REINPLACE_CMD} '/-O2/d' ${WRKSRC}/meson.build
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
TIMESTAMP = 1556317138
SHA256 (OpenVisualCloud-SVT-VP9-s20180426-ce24589_GH0.tar.gz) = 2e9d91450a00e6be2b20b922fbd6d1d9037be9d9e96ac3879dfde51326cc40b0
SIZE (OpenVisualCloud-SVT-VP9-s20180426-ce24589_GH0.tar.gz) = 981773

View file

@ -0,0 +1,4 @@
This plugin provides svtav1enc element to GStreamer in order to use
the Scalable Video Technology for VP9 Encoder.
WWW: https://01.org/svt