- Update to 1.2.0

PR:		ports/126129
Submitted by:	Jose Garcia Juanino <jjuanino@gmail.com> (maintainer)
This commit is contained in:
Pav Lucistnik 2008-08-01 11:43:55 +00:00
parent 1a3d5680dd
commit d4b2a52be7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=217909
9 changed files with 36 additions and 139 deletions

View file

@ -6,8 +6,8 @@
#
PORTNAME= xmlcopyeditor
PORTVERSION= 1.1.0.6
PORTREVISION= 1
PORTVERSION= 1.2.0
DISTVERSIONSUFFIX=-2
CATEGORIES= editors
MASTER_SITES= SF
MASTER_SITE_SUBDIR=xml-copy-editor
@ -20,25 +20,14 @@ WX_COMPS= wx contrib
WX_CONF_ARGS= absolute
WX_UNICODE= yes
USE_GETTEXT= yes
USE_DOS2UNIX= src/rulesets/ruleset.css \
src/rulesets/ruleset.xsd \
src/rulesets/Contractions.xml \
src/aspellpaths.h \
src/po/sk/backup/sk.po \
src/po/sk/sk.po \
src/po/fr/messages.po \
src/po/sv/messages.po \
src/po/translate.txt \
src/po/de/messages.po \
src/po/en_us/messages.po \
src/help/xmlcopyeditor.hhp \
USE_DOS2UNIX= src/templates/DTD.dtd \
src/help/html/generic.css \
src/rng/docbook.rnc \
src/help/xmlcopyeditor.hhp \
src/rulesets/ruleset.css \
src/rng/tei_all.rnc \
src/rng/docbook.rnc \
src/rng/tei_minimal.rnc \
src/rng/docbookxi.rnc \
src/templates/DTD.dtd \
src/filters/WordprocessingML.xml
src/rng/docbookxi.rnc
BUILD_DEPENDS+= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost
LIB_DEPENDS+= xerces-c.27:${PORTSDIR}/textproc/xerces-c2 \
@ -46,7 +35,15 @@ LIB_DEPENDS+= xerces-c.27:${PORTSDIR}/textproc/xerces-c2 \
aspell.16:${PORTSDIR}/textproc/aspell \
pcre.0:${PORTSDIR}/devel/pcre
USE_AUTOTOOLS= autoconf:261 automake:19
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
# workaround for automake (it needs config.rpath)
post-extract:
${TOUCH} ${WRKSRC}/config.rpath
# iconv.m4 is located in ${LOCALBASE}/share/aclocal
ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
USE_AUTOTOOLS= aclocal:110 autoconf:262 automake:110 libtool:15
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}

View file

@ -1,3 +1,3 @@
MD5 (xmlcopyeditor-1.1.0.6.tar.gz) = 29350234faca3ad978ff74dbbf7f3ef5
SHA256 (xmlcopyeditor-1.1.0.6.tar.gz) = b4b9a203c23daddf926cc41841416c2fc08a6979f3019feae984d087e2851111
SIZE (xmlcopyeditor-1.1.0.6.tar.gz) = 2202764
MD5 (xmlcopyeditor-1.2.0-2.tar.gz) = 4d5bcb5e2eb0bbca1e9b250f90c0dd98
SHA256 (xmlcopyeditor-1.2.0-2.tar.gz) = 2b1bb81950b6c8c5c4e8bd442eb04424428a17653aa9373302688127eae4a5d5
SIZE (xmlcopyeditor-1.2.0-2.tar.gz) = 2502114

View file

@ -1,83 +0,0 @@
--- aclocal.m4.orig Thu Dec 20 19:29:53 2007
+++ aclocal.m4 Thu Dec 20 19:30:48 2007
@@ -7243,3 +7243,80 @@
]) # _AM_PROG_TAR
+# ---------------------------------------------------------------------------
+# test for availability of iconv()
+# ---------------------------------------------------------------------------
+
+# From Bruno Haible.
+
+AC_DEFUN([AM_ICONV],
+[
+ # Some systems have iconv in libc, some have it in libiconv (OSF/1 and
+ # those with the standalone portable GNU libiconv installed).
+
+ AC_ARG_WITH([libiconv-prefix],
+[ --with-libiconv-prefix=DIR search for libiconv in DIR/include and DIR/lib], [
+ for dir in `echo "$withval" | tr : ' '`; do
+ if test -d $dir/include; then CPPFLAGS="$CPPFLAGS -I$dir/include"; fi
+ if test -d $dir/lib; then LDFLAGS="$LDFLAGS -L$dir/lib"; fi
+ done
+ ])
+
+ AC_CACHE_CHECK(for iconv, am_cv_func_iconv, [
+ am_cv_func_iconv="no, consider installing GNU libiconv"
+ am_cv_lib_iconv=no
+ AC_TRY_LINK([#include <stdlib.h>
+#include <iconv.h>],
+ [iconv_t cd = iconv_open("","");
+ iconv(cd,NULL,NULL,NULL,NULL);
+ iconv_close(cd);],
+ am_cv_func_iconv=yes)
+ if test "$am_cv_func_iconv" != yes; then
+ am_save_LIBS="$LIBS"
+ LIBS="$LIBS -liconv"
+ AC_TRY_LINK([#include <stdlib.h>
+#include <iconv.h>],
+ [iconv_t cd = iconv_open("","");
+ iconv(cd,NULL,NULL,NULL,NULL);
+ iconv_close(cd);],
+ am_cv_lib_iconv=yes
+ am_cv_func_iconv=yes)
+ LIBS="$am_save_LIBS"
+ fi
+ ])
+ if test "$am_cv_func_iconv" = yes; then
+ AC_DEFINE(HAVE_ICONV, 1, [Define if you have the iconv() function.])
+ AC_CACHE_CHECK([if iconv needs const], wx_cv_func_iconv_const,
+ AC_TRY_COMPILE([
+#include <stdlib.h>
+#include <iconv.h>
+extern
+#ifdef __cplusplus
+"C"
+#endif
+#if defined(__STDC__) || defined(__cplusplus)
+size_t iconv (iconv_t cd, char * *inbuf, size_t *inbytesleft, char * *outbuf, size_t *outbytesleft);
+#else
+size_t iconv();
+#endif
+ ],
+ [],
+ wx_cv_func_iconv_const="no",
+ wx_cv_func_iconv_const="yes"
+ )
+ )
+
+ iconv_const=
+ if test "x$wx_cv_func_iconv_const" = "xyes"; then
+ iconv_const="const"
+ fi
+
+ AC_DEFINE_UNQUOTED(ICONV_CONST, $iconv_const,
+ [Define as const if the declaration of iconv() needs const.])
+ fi
+ LIBICONV=
+ if test "$am_cv_lib_iconv" = yes; then
+ LIBICONV="-liconv"
+ fi
+ AC_SUBST(LIBICONV)
+])

View file

@ -1,5 +1,5 @@
--- configure.in.orig Thu Dec 20 16:54:28 2007
+++ configure.in Thu Dec 20 16:56:11 2007
--- configure.in.orig
+++ configure.in
@@ -35,6 +35,9 @@
# Call WXTEST func
WXTEST

View file

@ -1,5 +1,5 @@
--- src/Makefile.am.orig 2008-01-22 18:07:11.000000000 +0100
+++ src/Makefile.am 2008-01-22 18:12:05.000000000 +0100
--- src/Makefile.am.orig
+++ src/Makefile.am
@@ -9,8 +9,8 @@
bin_PROGRAMS = xmlcopyeditor
bindir = ${prefix}/bin
@ -11,15 +11,14 @@
# the application source, library search path, and link libraries
xmlcopyeditor_SOURCES = xmlcopyeditor.cpp associatedialog.cpp casehandler.cpp \
@@ -50,16 +50,6 @@
@@ -49,15 +49,6 @@
templates/*.lzx \
templates/*.xlf \
help/*.* help/html/*.* \
- copying/*.txt copying/boost_shared_ptr/* \
- copying/Expat/* copying/libxml2/* copying/libxslt/* \
- copying/PCRE/* copying/Scintilla/* \
- copying/scowl/* \
- copying/wxStyledTextCtrl/* copying/ximian/* \
- copying/wxStyledTextCtrl/* \
- copying/wxStEditor/* \
- copying/xmlcopyeditor/* \
- copying/Aspell/* \
@ -28,12 +27,3 @@
po/sk/messages.mo \
po/sv/messages.mo \
po/fr/messages.mo \
@@ -68,7 +58,7 @@
po/zh_TW/messages.mo \
po/uk_UA/messages.mo \
po/uk_UA/messages.mo \
- po/en_us/messages.po \
+ po/en_us/messages.po
pixmap_DATA = xmlcopyeditor.png

View file

@ -1,6 +1,6 @@
--- src/xmlcopyeditor.cpp.orig 2008-01-22 18:07:12.000000000 +0100
+++ src/xmlcopyeditor.cpp 2008-01-22 18:15:34.000000000 +0100
@@ -2984,10 +2984,7 @@
--- src/xmlcopyeditor.cpp.orig
+++ src/xmlcopyeditor.cpp
@@ -3002,10 +3002,7 @@
nconv = iconv (
cd,
@ -12,7 +12,7 @@
&docBufferLeft,
&iconvBuffer,
&iconvBufferLeft );
@@ -4637,10 +4634,7 @@
@@ -4617,10 +4614,7 @@
nconv = iconv (
cd,

View file

@ -1,5 +1,5 @@
--- src/xmlcopyeditor.h.orig Thu Dec 20 19:39:44 2007
+++ src/xmlcopyeditor.h Thu Dec 20 19:40:47 2007
--- src/xmlcopyeditor.h.orig
+++ src/xmlcopyeditor.h
@@ -21,6 +21,7 @@
#define XMLCOPYEDITOR_H

View file

@ -1,8 +0,0 @@
************************************************************************
Note for XML docbook users:
1) In Edit->Preferences menu change "Application directory" text box to
"%%LOCALBASE%%/share/xsl".
2) Install textproc/docbook-xml port.
************************************************************************

View file

@ -1,9 +1,7 @@
@comment $FreeBSD$
bin/xmlcopyeditor
share/applications/xmlcopyeditor.desktop
share/pixmaps/xmlcopyeditor.png
%%DATADIR%%/filters/OpenDocument.xml
%%DATADIR%%/filters/WordprocessingML.xml
%%DATADIR%%/filters/filter.xsd
%%DATADIR%%/help/Table of Contents.hhc
%%DATADIR%%/help/html/appendix.html
%%DATADIR%%/help/html/association.html
@ -68,6 +66,7 @@ share/pixmaps/xmlcopyeditor.png
%%DATADIR%%/po/de/messages.mo
%%DATADIR%%/po/en_us/messages.po
%%DATADIR%%/po/fr/messages.mo
%%DATADIR%%/po/ru/messages.mo
%%DATADIR%%/po/sk/messages.mo
%%DATADIR%%/po/sv/messages.mo
%%DATADIR%%/po/uk_UA/messages.mo
@ -124,6 +123,8 @@ share/pixmaps/xmlcopyeditor.png
%%DATADIR%%/rulesets/American.xml
%%DATADIR%%/rulesets/Commonwealth.xml
%%DATADIR%%/rulesets/Contractions.xml
%%DATADIR%%/rulesets/Default dictionary and style.xml
%%DATADIR%%/rulesets/Default dictionary.xml
%%DATADIR%%/rulesets/Default style.xml
%%DATADIR%%/rulesets/Disability.xml
%%DATADIR%%/rulesets/Diversity.xml
@ -202,6 +203,7 @@ share/pixmaps/xmlcopyeditor.png
@dirrm %%DATADIR%%/po/uk_UA
@dirrm %%DATADIR%%/po/sv
@dirrm %%DATADIR%%/po/sk
@dirrm %%DATADIR%%/po/ru
@dirrm %%DATADIR%%/po/fr
@dirrm %%DATADIR%%/po/en_us
@dirrm %%DATADIR%%/po/de
@ -209,7 +211,6 @@ share/pixmaps/xmlcopyeditor.png
@dirrm %%DATADIR%%/png
@dirrm %%DATADIR%%/help/html
@dirrm %%DATADIR%%/help
@dirrm %%DATADIR%%/filters
@dirrm %%DATADIR%%
@dirrmtry share/pixmaps
@dirrmtry share/applications