textproc/py-mwparserfromhell: Remove unnecessary dependency

This commit is contained in:
Yuri Victorovich 2025-03-16 13:35:28 -07:00
parent be23ccb967
commit d21b9a0a66
2 changed files with 11 additions and 4 deletions

View file

@ -12,10 +12,6 @@ WWW= https://github.com/earwig/mwparserfromhell
LICENSE= MIT LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE LICENSE_FILE= ${WRKSRC}/LICENSE
DEPRECATED= Depends on expired devel/py-pytest-runner
EXPIRATION_DATE=2025-03-31
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-runner>0:devel/py-pytest-runner@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
USES= python USES= python

View file

@ -0,0 +1,11 @@
--- setup.py.orig 2025-03-16 19:50:17 UTC
+++ setup.py
@@ -82,7 +82,7 @@ setup(
packages=find_packages("src"),
package_dir={"": "src"},
ext_modules=[tokenizer] if use_extension else [],
- setup_requires=["pytest-runner"]
+ setup_requires=[]
if "test" in sys.argv or "pytest" in sys.argv
else [],
tests_require=["pytest"],