math/openmesh: Update 8.1 -> 9.0

This commit is contained in:
Yuri Victorovich 2022-10-10 23:10:09 -07:00
parent f9bc3f7ccf
commit d07f49af4a
15 changed files with 12 additions and 186 deletions

View file

@ -1,6 +1,5 @@
PORTNAME= openmesh
DISTVERSION= 8.1
PORTREVISION= 1
DISTVERSION= 9.0
CATEGORIES= math
MASTER_SITES= http://www.openmesh.org/media/Releases/${DISTVERSION}/
DISTNAME= OpenMesh-${DISTVERSION}
@ -20,6 +19,8 @@ USE_GL= gl glu glut
USE_XORG= xi xmu
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/OpenMesh-${DISTVERSION}.0
post-install:
@${RMDIR} ${STAGEDIR}${PREFIX}/include/OpenMesh/Tools/VDPM/xpm

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1616633090
SHA256 (OpenMesh-8.1.tar.gz) = 0953777f483d47ea9fa00c329838443a7a09dde8be77bf7de188001cb9e768a7
SIZE (OpenMesh-8.1.tar.gz) = 26934610
TIMESTAMP = 1665466636
SHA256 (OpenMesh-9.0.tar.gz) = b9574c921482798ce75a8bf578345a84b928ca26ee759219d21b310e2db9d006
SIZE (OpenMesh-9.0.tar.gz) = 32660128

View file

@ -1,12 +0,0 @@
--- src/OpenMesh/Apps/Decimating/decimater.cc.orig 2020-03-12 13:55:53 UTC
+++ src/OpenMesh/Apps/Decimating/decimater.cc
@@ -53,6 +53,9 @@
#include <string>
#include <memory>
#include <map>
+#if defined(__FreeBSD__)
+#include <unistd.h>
+#endif
//--------------------
#include <OpenMesh/Core/IO/MeshIO.hh>
//--------------------

View file

@ -1,12 +0,0 @@
--- src/OpenMesh/Apps/Decimating/decimaterviewer.cc.orig 2020-03-12 13:55:53 UTC
+++ src/OpenMesh/Apps/Decimating/decimaterviewer.cc
@@ -44,6 +44,9 @@
#ifdef _MSC_VER
# pragma warning(disable: 4267 4311)
#endif
+#if defined(__FreeBSD__)
+#include <unistd.h>
+#endif
#include <iostream>
#include <fstream>

View file

@ -1,12 +0,0 @@
--- src/OpenMesh/Apps/QtViewer/meshviewer.cc.orig 2020-03-12 13:55:53 UTC
+++ src/OpenMesh/Apps/QtViewer/meshviewer.cc
@@ -42,6 +42,9 @@
#ifdef _MSC_VER
# pragma warning(disable: 4267 4311)
#endif
+#if defined(__FreeBSD__)
+#include <unistd.h>
+#endif
#include <iostream>
#include <fstream>

View file

@ -1,12 +0,0 @@
--- src/OpenMesh/Apps/Smoothing/smooth.cc.orig 2020-03-12 13:55:53 UTC
+++ src/OpenMesh/Apps/Smoothing/smooth.cc
@@ -48,6 +48,9 @@
#include <OpenMesh/Tools/Utils/Timer.hh>
#include <OpenMesh/Tools/Smoother/JacobiLaplaceSmootherT.hh>
#include <OpenMesh/Tools/Utils/getopt.h>
+#if defined(__FreeBSD__)
+#include <unistd.h>
+#endif
using namespace OpenMesh;

View file

@ -1,12 +0,0 @@
--- src/OpenMesh/Apps/Subdivider/adaptive_subdivider.cc.orig 2020-03-12 13:55:53 UTC
+++ src/OpenMesh/Apps/Subdivider/adaptive_subdivider.cc
@@ -62,6 +62,9 @@
# include <cmath>
using std::pow;
#endif
+#if defined(__FreeBSD__)
+#include <unistd.h>
+#endif
using OpenMesh::Subdivider::Adaptive::CompositeTraits;

View file

@ -1,12 +0,0 @@
--- src/OpenMesh/Apps/Subdivider/subdivider.cc.orig 2020-03-12 13:55:53 UTC
+++ src/OpenMesh/Apps/Subdivider/subdivider.cc
@@ -43,6 +43,9 @@
#include <iostream>
#include <sstream>
+#if defined(__FreeBSD__)
+#include <unistd.h>
+#endif
// ---------------------------------------- OpenMesh Stuff
#include <OpenMesh/Core/IO/MeshIO.hh>
#include <OpenMesh/Core/Mesh/TriMesh_ArrayKernelT.hh>

View file

@ -1,12 +0,0 @@
--- src/OpenMesh/Apps/VDProgMesh/Analyzer/vdpmanalyzer.cc.orig 2020-03-12 13:55:54 UTC
+++ src/OpenMesh/Apps/VDProgMesh/Analyzer/vdpmanalyzer.cc
@@ -51,6 +51,9 @@
#include <limits>
#include <exception>
#include <cmath>
+#if defined(__FreeBSD__)
+#include <unistd.h>
+#endif
// -------------------- OpenMesh
#include <OpenMesh/Core/IO/MeshIO.hh>
#include <OpenMesh/Core/Mesh/TriMesh_ArrayKernelT.hh>

View file

@ -1,12 +0,0 @@
--- src/OpenMesh/Apps/VDProgMesh/mkbalancedpm/mkbalancedpm.cc.orig 2020-03-12 13:55:54 UTC
+++ src/OpenMesh/Apps/VDProgMesh/mkbalancedpm/mkbalancedpm.cc
@@ -45,6 +45,9 @@
#include <iostream>
#include <sstream>
#include <cmath>
+#if defined(__FreeBSD__)
+#include <unistd.h>
+#endif
// -------------------- OpenMesh
#include <OpenMesh/Core/IO/MeshIO.hh>
#include <OpenMesh/Core/Mesh/TriMesh_ArrayKernelT.hh>

View file

@ -1,12 +0,0 @@
--- src/OpenMesh/Apps/mconvert/mconvert.cc.orig 2020-03-12 13:55:54 UTC
+++ src/OpenMesh/Apps/mconvert/mconvert.cc
@@ -45,6 +45,9 @@
#include <iterator>
#include <fstream>
#include <string>
+#if defined(__FreeBSD__)
+#include <unistd.h>
+#endif
//
#include <OpenMesh/Core/IO/MeshIO.hh>
#include <OpenMesh/Core/Mesh/TriMesh_ArrayKernelT.hh>

View file

@ -1,11 +0,0 @@
--- src/OpenMesh/Core/CMakeLists.txt.orig 2020-03-12 13:55:54 UTC
+++ src/OpenMesh/Core/CMakeLists.txt
@@ -41,7 +41,7 @@ if (WIN32)
endif()
else ()
- acg_add_library (OpenMeshCore SHAREDANDSTATIC ${sources} ${headers})
+ acg_add_library (OpenMeshCore SHARED ${sources} ${headers})
set_target_properties (OpenMeshCore PROPERTIES VERSION ${OPENMESH_VERSION_MAJOR}.${OPENMESH_VERSION_MINOR}
SOVERSION ${OPENMESH_VERSION_MAJOR}.${OPENMESH_VERSION_MINOR} )

View file

@ -1,29 +0,0 @@
--- src/OpenMesh/Tools/CMakeLists.txt.orig 2021-03-25 00:45:18 UTC
+++ src/OpenMesh/Tools/CMakeLists.txt
@@ -43,7 +43,7 @@ if (WIN32)
endif()
else ()
- acg_add_library (OpenMeshTools SHAREDANDSTATIC ${sources} ${headers})
+ acg_add_library (OpenMeshTools SHARED ${sources} ${headers})
set_target_properties (OpenMeshTools PROPERTIES VERSION ${OPENMESH_VERSION_MAJOR}.${OPENMESH_VERSION_MINOR}
SOVERSION ${OPENMESH_VERSION_MAJOR}.${OPENMESH_VERSION_MINOR} )
endif ()
@@ -51,7 +51,7 @@ endif ()
target_link_libraries (OpenMeshTools OpenMeshCore)
IF( NOT WIN32 )
- target_link_libraries (OpenMeshToolsStatic OpenMeshCoreStatic)
+ #target_link_libraries (OpenMeshToolsStatic OpenMeshCoreStatic)
ENDIF(NOT WIN32)
if ( (${PROJECT_NAME} MATCHES "OpenMesh") AND BUILD_APPS )
@@ -67,7 +67,7 @@ if ( (${PROJECT_NAME} MATCHES "OpenMesh") AND BUILD_AP
if (APPLE)
# let bundle generation depend on target
add_dependencies (fixbundle OpenMeshTools)
- add_dependencies (fixbundle OpenMeshToolsStatic)
+ #add_dependencies (fixbundle OpenMeshToolsStatic)
endif()
endif()

View file

@ -1,29 +0,0 @@
--- src/OpenMesh/Tools/Utils/Timer.cc.orig 2020-03-12 13:55:54 UTC
+++ src/OpenMesh/Tools/Utils/Timer.cc
@@ -41,6 +41,8 @@
+#include <sys/time.h>
+
#ifndef DOXY_IGNORE_THIS
// ----------------------------------------------------------------------------
#include <OpenMesh/Core/System/config.h>
@@ -145,7 +147,7 @@ double TimerImplWin32::seconds(void) const
}
// ------------------------------------------------------------- posix time ----
-#elif defined(__GNUC__) && defined(__POSIX__)
+#elif 0 && defined(__GNUC__) && defined(__POSIX__)
#ifndef DOXY_IGNORE_THIS
# include <time.h>
@@ -183,7 +185,7 @@ class TimerImplPosix : public TimerImpl (protected)
};
// ----------------------------------------------------------- gettimeofday ----
-#elif (defined(__GNUC__) && !defined(__FreeBSD__) || (defined(__INTEL_COMPILER) && !defined(WIN32))) && !defined(__MINGW32__)
+#elif 0 && (defined(__GNUC__) && !defined(__FreeBSD__) || (defined(__INTEL_COMPILER) && !defined(WIN32))) && !defined(__MINGW32__)
# include <sys/time.h>
# include <sys/resource.h>

View file

@ -33,8 +33,6 @@ include/OpenMesh/Core/IO/Options.hh
include/OpenMesh/Core/IO/SR_binary.hh
include/OpenMesh/Core/IO/SR_binary_spec.hh
include/OpenMesh/Core/IO/SR_binary_vector_of_bool.inl
include/OpenMesh/Core/IO/SR_binary_vector_of_fundamentals.inl
include/OpenMesh/Core/IO/SR_binary_vector_of_string.inl
include/OpenMesh/Core/IO/SR_rbo.hh
include/OpenMesh/Core/IO/SR_store.hh
include/OpenMesh/Core/IO/SR_types.hh
@ -101,8 +99,10 @@ include/OpenMesh/Core/Utils/Endian.hh
include/OpenMesh/Core/Utils/GenProg.hh
include/OpenMesh/Core/Utils/HandleToPropHandle.hh
include/OpenMesh/Core/Utils/Noncopyable.hh
include/OpenMesh/Core/Utils/Predicates.hh
include/OpenMesh/Core/Utils/Property.hh
include/OpenMesh/Core/Utils/PropertyContainer.hh
include/OpenMesh/Core/Utils/PropertyCreator.hh
include/OpenMesh/Core/Utils/PropertyManager.hh
include/OpenMesh/Core/Utils/RandomNumberGenerator.hh
include/OpenMesh/Core/Utils/SingletonT.hh
@ -197,10 +197,12 @@ include/OpenMesh/Tools/VDPM/VHierarchyNode.hh
include/OpenMesh/Tools/VDPM/VHierarchyNodeIndex.hh
include/OpenMesh/Tools/VDPM/VHierarchyWindow.hh
include/OpenMesh/Tools/VDPM/ViewingParameters.hh
lib/libOpenMeshCore.a
lib/libOpenMeshCore.so
lib/libOpenMeshCore.so.8.1
lib/libOpenMeshCore.so.9.0
lib/libOpenMeshTools.a
lib/libOpenMeshTools.so
lib/libOpenMeshTools.so.8.1
lib/libOpenMeshTools.so.9.0
libdata/pkgconfig/openmesh.pc
share/OpenMesh/cmake/OpenMeshConfig-%%CMAKE_BUILD_TYPE%%.cmake
share/OpenMesh/cmake/OpenMeshConfig.cmake