devel/electron22: update to 22.3.5

Changelog: https://github.com/electron/electron/releases/tag/v22.3.5
This commit is contained in:
Hiroki Tagato 2023-03-31 15:29:24 +09:00
parent a42566d59f
commit d06abfacce
5 changed files with 15 additions and 15 deletions

View file

@ -221,7 +221,7 @@ REACTIVEOBJC_VER= 74ab5baccc6f7202c8ac69a8d1e152c29dc1ea76
# See ${WRKSRC}/electron/DEPS for MANTLE_VER
MANTLE_VER= 78d3966b3c331292ea29ec38661b25df0a245948
YARN_TIMESTAMP= 1679622751
YARN_TIMESTAMP= 1680156343
.include "Makefile.version"
.include <bsd.port.pre.mk> # required for COMPILER_VERSION

View file

@ -1,2 +1,2 @@
ELECTRON_VER= 22.3.4
ELECTRON_VER= 22.3.5
ELECTRON_VER_MAJOR= ${ELECTRON_VER:C/\..*//}

View file

@ -1,14 +1,14 @@
TIMESTAMP = 1679623663
TIMESTAMP = 1680157181
SHA256 (electron/chromium-108.0.5359.215.tar.xz) = aba0730b347269efda217affe804f6fced296aa02f810c8c9a6fd7d46cd7bf9a
SIZE (electron/chromium-108.0.5359.215.tar.xz) = 1584734880
SHA256 (electron/f8b5da24d33317766d3933fb6711b0603fc4fb6f) = 63706737ca75e0e5c97885186b2a7ab019ca71d1315ee08870193bbfa7486bfc
SIZE (electron/f8b5da24d33317766d3933fb6711b0603fc4fb6f) = 9900677
SHA256 (electron/336e775eec536b2d785cc80eff6ac39051931286) = a2ca2962daf482a8f943163541e1c73ba4b2694fabcd2510981f2db4eda493c8
SIZE (electron/336e775eec536b2d785cc80eff6ac39051931286) = 32624734
SHA256 (electron/electron-yarn-cache-22.3.4.tar.xz) = 3b78a78bb250e510934981e75abdcf01aca502dfd5d141787b8e8e6828264198
SIZE (electron/electron-yarn-cache-22.3.4.tar.xz) = 38901100
SHA256 (electron/electron-electron-v22.3.4_GH0.tar.gz) = 81508b10f7b344dd543e72df5ee4e03d0aa62fd86527dce787c09a1ab18a4be9
SIZE (electron/electron-electron-v22.3.4_GH0.tar.gz) = 10544860
SHA256 (electron/electron-yarn-cache-22.3.5.tar.xz) = 75d8fe319a9694149158ebbc9388ac541029c7572287909a0006ec8ec9dd581a
SIZE (electron/electron-yarn-cache-22.3.5.tar.xz) = 38902228
SHA256 (electron/electron-electron-v22.3.5_GH0.tar.gz) = bc3b6a1572b14510fa1343da338e64240796a94743f6ba7dd30c3b23bb2d59cd
SIZE (electron/electron-electron-v22.3.5_GH0.tar.gz) = 10569244
SHA256 (electron/nodejs-node-v16.17.1_GH0.tar.gz) = e63378aa6aa18b9e05486e46eaca6c6e09904366e5100d7e04c6dbd344a42f60
SIZE (electron/nodejs-node-v16.17.1_GH0.tar.gz) = 90485310
SHA256 (electron/nodejs-nan-16fa32231e2ccd89d2804b3f765319128b20c4ac_GH0.tar.gz) = 3807ae6a1e451a29f068540472f100f9718d457c60ac62f2f8469d1d57475d39

View file

@ -1,4 +1,4 @@
--- components/crash/core/app/BUILD.gn.orig 2022-11-30 08:12:58 UTC
--- components/crash/core/app/BUILD.gn.orig 2023-03-30 06:28:08 UTC
+++ components/crash/core/app/BUILD.gn
@@ -52,7 +52,7 @@ static_library("app") {
"crashpad.h",
@ -29,7 +29,7 @@
deps += [
"//base:base_static",
"//components/crash/core/common",
@@ -224,11 +228,6 @@ if (is_mac || is_android || is_linux || is_chromeos) {
@@ -223,11 +227,6 @@ if (is_mac || is_android || is_linux || is_chromeos) {
# define custom UserStreamDataSources.
executable("chrome_crashpad_handler") {
sources = [ "chrome_crashpad_handler.cc" ]

View file

@ -1,4 +1,4 @@
--- media/base/video_frame.cc.orig 2022-11-30 08:12:58 UTC
--- media/base/video_frame.cc.orig 2023-03-30 06:28:08 UTC
+++ media/base/video_frame.cc
@@ -75,7 +75,7 @@ std::string VideoFrame::StorageTypeToString(
return "OWNED_MEMORY";
@ -27,7 +27,7 @@
// This class allows us to embed a vector<ScopedFD> into a scoped_refptr, and
// thus to have several VideoFrames share the same set of DMABUF FDs.
class VideoFrame::DmabufHolder
@@ -625,7 +625,7 @@ scoped_refptr<VideoFrame> VideoFrame::WrapExternalGpuM
@@ -614,7 +614,7 @@ scoped_refptr<VideoFrame> VideoFrame::WrapExternalGpuM
for (size_t i = 0; i < num_planes; ++i)
planes[i].stride = gpu_memory_buffer->stride(i);
uint64_t modifier = gfx::NativePixmapHandle::kNoModifier;
@ -36,7 +36,7 @@
if (gpu_memory_buffer->GetType() == gfx::NATIVE_PIXMAP) {
const auto gmb_handle = gpu_memory_buffer->CloneHandle();
if (gmb_handle.is_null() ||
@@ -671,7 +671,7 @@ scoped_refptr<VideoFrame> VideoFrame::WrapExternalGpuM
@@ -660,7 +660,7 @@ scoped_refptr<VideoFrame> VideoFrame::WrapExternalGpuM
return frame;
}
@ -45,7 +45,7 @@
// static
scoped_refptr<VideoFrame> VideoFrame::WrapExternalDmabufs(
const VideoFrameLayout& layout,
@@ -888,7 +888,7 @@ scoped_refptr<VideoFrame> VideoFrame::WrapVideoFrame(
@@ -877,7 +877,7 @@ scoped_refptr<VideoFrame> VideoFrame::WrapVideoFrame(
}
}
@ -54,7 +54,7 @@
DCHECK(frame->dmabuf_fds_);
// If there are any |dmabuf_fds_| plugged in, we should refer them too.
wrapping_frame->dmabuf_fds_ = frame->dmabuf_fds_;
@@ -1275,7 +1275,7 @@ const gpu::MailboxHolder& VideoFrame::mailbox_holder(
@@ -1264,7 +1264,7 @@ const gpu::MailboxHolder& VideoFrame::mailbox_holder(
: mailbox_holders_[texture_index];
}
@ -63,7 +63,7 @@
const std::vector<base::ScopedFD>& VideoFrame::DmabufFds() const {
DCHECK_EQ(storage_type_, STORAGE_DMABUFS);
@@ -1387,7 +1387,7 @@ VideoFrame::VideoFrame(const VideoFrameLayout& layout,
@@ -1376,7 +1376,7 @@ VideoFrame::VideoFrame(const VideoFrameLayout& layout,
storage_type_(storage_type),
visible_rect_(Intersection(visible_rect, gfx::Rect(layout.coded_size()))),
natural_size_(natural_size),